- Bring up-to-date with current releases of Tcl/Tk
- Refactor and make easier to maintain and update Feature safe: yes PR: 176230 Submitted by: Pietro Cerutti <gahr@FreeBSD.org> Approved by: maintainer (timeout after 2 months)
This commit is contained in:
parent
3b9788da01
commit
d294f6c7ec
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315951
9 changed files with 1314 additions and 1357 deletions
|
@ -1,15 +1,11 @@
|
|||
# New ports collection makefile for: tcl-manual
|
||||
# Date created: 13 December 2001
|
||||
# Whom: Edwin Groothuis (edwin@mavetju.org)
|
||||
#
|
||||
# Created by: Edwin Groothuis (edwin@mavetju.org)
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tcl-manual
|
||||
PORTVERSION= 20041118
|
||||
PORTVERSION= 20130208
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= SF/tcl/Tcl/8.3.5
|
||||
DISTFILES= tcl8.3.5-html.tar.gz tcl8.4.7-html.tar.gz tcl8.5a1-html.tar.gz
|
||||
MASTER_SITES= SF/tcl/Tcl/
|
||||
DISTFILES=
|
||||
|
||||
MAINTAINER= edwin@mavetju.org
|
||||
COMMENT= Documentation for TCL (Tool Command Language)
|
||||
|
@ -17,28 +13,33 @@ COMMENT= Documentation for TCL (Tool Command Language)
|
|||
NO_WRKSUBDIR= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
VERSIONS= 8.4.19 \
|
||||
8.5.14 \
|
||||
8.6.0
|
||||
|
||||
.for v in ${VERSIONS}
|
||||
DISTFILES+= $v/tcl$v-html.tar.gz
|
||||
.endfor
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "*.orig" -delete
|
||||
@${REINPLACE_CMD} -e 's|tcl\.h|tcl8.3/tcl.h|g' \
|
||||
${WRKDIR}/tcl8.3.5/html/TclLib/*
|
||||
@${REINPLACE_CMD} -e 's|tk\.h|tk8.3/tk.h|g' \
|
||||
${WRKDIR}/tcl8.3.5/html/TkLib/*
|
||||
@${REINPLACE_CMD} -e 's|tcl\.h|tcl8.4/tcl.h|g' \
|
||||
${WRKDIR}/tcl8.4.7/html/TclLib/*
|
||||
@${REINPLACE_CMD} -e 's|tk\.h|tk8.4/tk.h|g' \
|
||||
${WRKDIR}/tcl8.4.7/html/TkLib/*
|
||||
@${REINPLACE_CMD} -e 's|tcl\.h|tcl8.5/tcl.h|g' \
|
||||
${WRKDIR}/tcl8.5a1/html/TclLib/*
|
||||
@${REINPLACE_CMD} -e 's|tk\.h|tk8.5/tk.h|g' \
|
||||
${WRKDIR}/tcl8.5a1/html/TkLib/*
|
||||
.for v in ${VERSIONS}
|
||||
@${REINPLACE_CMD} -e 's|<b>tclsh</b>|<b>tclsh${v:R}</b>|g; \
|
||||
s|/usr/local/bin/tclsh|${PREFIX}/bin/tclsh${v:R}|g' \
|
||||
${WRKSRC}/tcl${v}/html/UserCmd/tclsh.htm
|
||||
@${REINPLACE_CMD} -e 's|<b>wish</b>|<b>wish${v:R}</b>|g; \
|
||||
s|/usr/local/bin/wish|${PREFIX}/bin/wish${v:R}|g' \
|
||||
${WRKSRC}/tcl${v}/html/UserCmd/wish.htm
|
||||
@${REINPLACE_CMD} -e 's|tcl\.h|tcl${v:R}/tcl.h|g' \
|
||||
${WRKDIR}/tcl${v}/html/TclLib/*
|
||||
@${REINPLACE_CMD} -e 's|tk\.h|tk${v:R}/tk.h|g' \
|
||||
${WRKDIR}/tcl${v}/html/TkLib/*
|
||||
@${FIND} ${WRKSRC} -name "*.bak" -delete
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/tcl83
|
||||
${MKDIR} ${PREFIX}/share/doc/tcl84
|
||||
${MKDIR} ${PREFIX}/share/doc/tcl85
|
||||
${CP} -R ${WRKDIR}/tcl8.5a1/html/* ${PREFIX}/share/doc/tcl85
|
||||
${CP} -R ${WRKDIR}/tcl8.4.7/html/* ${PREFIX}/share/doc/tcl84
|
||||
${CP} -R ${WRKDIR}/tcl8.3.5/html/* ${PREFIX}/share/doc/tcl83
|
||||
.for v in ${VERSIONS}
|
||||
${MKDIR} ${PREFIX}/share/doc/tcl${v:R:S/.//}
|
||||
${CP} -R ${WRKDIR}/tcl${v}/html/* ${PREFIX}/share/doc/tcl${v:R:S/.//}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SHA256 (tcl8.3.5-html.tar.gz) = f15281d2dff15f1646c43400446ddcff674f39498ea4a986762476cfebc938f1
|
||||
SIZE (tcl8.3.5-html.tar.gz) = 620957
|
||||
SHA256 (tcl8.4.7-html.tar.gz) = 94e2b22fc8357156df213dea99ab4d65211ce334df53232ea0bf9e1c2b25a2c4
|
||||
SIZE (tcl8.4.7-html.tar.gz) = 715175
|
||||
SHA256 (tcl8.5a1-html.tar.gz) = a107358b0a4467867fe51d2ef0b0362d2e74b4a2644ee2175d066a4677c7f7e8
|
||||
SIZE (tcl8.5a1-html.tar.gz) = 747311
|
||||
SHA256 (8.4.19/tcl8.4.19-html.tar.gz) = 53b0d0b2859060b7cd6b9e0524e257aa60a56213a8cd75630b22e44180dbe888
|
||||
SIZE (8.4.19/tcl8.4.19-html.tar.gz) = 747413
|
||||
SHA256 (8.5.14/tcl8.5.14-html.tar.gz) = 3b2c9369568dd922a955d77b2fdc206baee7aa021c5b8769d9b0f76625b501a0
|
||||
SIZE (8.5.14/tcl8.5.14-html.tar.gz) = 935323
|
||||
SHA256 (8.6.0/tcl8.6.0-html.tar.gz) = 7d440f01bda9e4a2b88f735ae92292967bdfc6853e145718bba5f72edddd586a
|
||||
SIZE (8.6.0/tcl8.6.0-html.tar.gz) = 1168655
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.3.5/html/UserCmd/tclsh.htm.orig Sat Oct 19 05:11:58 2002
|
||||
+++ tcl8.3.5/html/UserCmd/tclsh.htm Thu Nov 18 12:48:36 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>tclsh - Simple shell containing Tcl interpreter</DL>
|
||||
<DD><A HREF="tclsh.htm#M3" NAME="L3">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>tclsh</B> ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>tclsh8.3</B> ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="tclsh.htm#M4" NAME="L4">DESCRIPTION</A>
|
||||
<DD><A HREF="tclsh.htm#M5" NAME="L5">SCRIPT FILES</A>
|
||||
@@ -21,7 +21,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
tclsh - Simple shell containing Tcl interpreter
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>tclsh</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>tclsh8.3</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">DESCRIPTION</A></H3>
|
||||
<B>Tclsh</B> is a shell-like application that reads Tcl commands
|
||||
from its standard input or from a file and evaluates them.
|
||||
@@ -46,7 +46,7 @@
|
||||
case, but the script file can always <B><A HREF="../TclCmd/source.htm">source</A></B> it if desired.
|
||||
<P>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/tclsh</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/tclsh8.3</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark the file as executable.
|
||||
This assumes that <B>tclsh</B> has been installed in the default
|
||||
@@ -60,7 +60,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using tclsh \
|
||||
-exec tclsh "$0" "$@"</B></PRE>
|
||||
+exec tclsh8.3 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>tclsh</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.3.5/html/UserCmd/wish.htm.orig Sat Oct 19 05:11:58 2002
|
||||
+++ tcl8.3.5/html/UserCmd/wish.htm Thu Nov 18 12:49:21 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>wish - Simple windowing shell</DL>
|
||||
<DD><A HREF="wish.htm#M3" NAME="L14">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>wish</B> ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>wish8.3</B> ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="wish.htm#M4" NAME="L15">OPTIONS</A>
|
||||
<DL>
|
||||
@@ -35,7 +35,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
wish - Simple windowing shell
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>wish</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>wish8.3</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">OPTIONS</A></H3>
|
||||
<DL>
|
||||
<P><DT><A NAME="M5"><B>-colormap </B><I>new</I></A><DD>
|
||||
@@ -143,7 +143,7 @@
|
||||
<P></DL>
|
||||
<H3><A NAME="M22">SCRIPT FILES</A></H3>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/wish</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/wish8.3</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark it as executable.
|
||||
This assumes that <B>wish</B> has been installed in the default
|
||||
@@ -157,7 +157,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" "$@"</B></PRE>
|
||||
+exec wish8.3 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>wish</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.4.7/html/UserCmd/tclsh.htm.orig Tue Jul 27 05:21:39 2004
|
||||
+++ tcl8.4.7/html/UserCmd/tclsh.htm Thu Nov 18 12:48:14 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>tclsh - Simple shell containing Tcl interpreter</DL>
|
||||
<DD><A HREF="tclsh.htm#M3" NAME="L3">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>tclsh</B> ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>tclsh8.4</B> ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="tclsh.htm#M4" NAME="L4">DESCRIPTION</A>
|
||||
<DD><A HREF="tclsh.htm#M5" NAME="L5">SCRIPT FILES</A>
|
||||
@@ -23,7 +23,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
tclsh - Simple shell containing Tcl interpreter
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>tclsh</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>tclsh8.4</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">DESCRIPTION</A></H3>
|
||||
<B>Tclsh</B> is a shell-like application that reads Tcl commands
|
||||
from its standard input or from a file and evaluates them.
|
||||
@@ -56,7 +56,7 @@
|
||||
line, but the script file can always <B><A HREF="../TclCmd/source.htm">source</A></B> it if desired.
|
||||
<P>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/tclsh</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/tclsh8.4</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark the file as executable.
|
||||
This assumes that <B>tclsh</B> has been installed in the default
|
||||
@@ -70,7 +70,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using tclsh \
|
||||
-exec tclsh "$0" "$@"</B></PRE>
|
||||
+exec tclsh8.4 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>tclsh</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.4.7/html/UserCmd/wish.htm.orig Tue Jul 27 05:21:39 2004
|
||||
+++ tcl8.4.7/html/UserCmd/wish.htm Thu Nov 18 12:49:51 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>wish - Simple windowing shell</DL>
|
||||
<DD><A HREF="wish.htm#M3" NAME="L16">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>wish</B> ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>wish8.4</B> ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="wish.htm#M4" NAME="L17">OPTIONS</A>
|
||||
<DL>
|
||||
@@ -35,7 +35,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
wish - Simple windowing shell
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>wish</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>wish8.4</B> ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">OPTIONS</A></H3>
|
||||
<DL>
|
||||
<DT><A NAME="M5"><B>-colormap </B><I>new</I></A><DD>
|
||||
@@ -144,7 +144,7 @@
|
||||
<P></DL>
|
||||
<H3><A NAME="M22">SCRIPT FILES</A></H3>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/wish</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/wish8.4</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark it as executable.
|
||||
This assumes that <B>wish</B> has been installed in the default
|
||||
@@ -158,7 +158,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" "$@"</B></PRE>
|
||||
+exec wish8.4 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>wish</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.5a1/html/UserCmd/tclsh.htm.orig Thu Mar 4 11:24:31 2004
|
||||
+++ tcl8.5a1/html/UserCmd/tclsh.htm Thu Nov 18 12:47:37 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>tclsh - Simple shell containing Tcl interpreter</DL>
|
||||
<DD><A HREF="tclsh.htm#M3" NAME="L3">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>tclsh</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>tclsh8.5</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="tclsh.htm#M4" NAME="L4">DESCRIPTION</A>
|
||||
<DD><A HREF="tclsh.htm#M5" NAME="L5">SCRIPT FILES</A>
|
||||
@@ -23,7 +23,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
tclsh - Simple shell containing Tcl interpreter
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>tclsh</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>tclsh8.5</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">DESCRIPTION</A></H3>
|
||||
<B>Tclsh</B> is a shell-like application that reads Tcl commands
|
||||
from its standard input or from a file and evaluates them.
|
||||
@@ -58,7 +58,7 @@
|
||||
line, but the script file can always <B><A HREF="../TclCmd/source.htm">source</A></B> it if desired.
|
||||
<P>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/tclsh</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/tclsh8.5</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark the file as executable.
|
||||
This assumes that <B>tclsh</B> has been installed in the default
|
||||
@@ -72,7 +72,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using tclsh \
|
||||
-exec tclsh "$0" "$@"</B></PRE>
|
||||
+exec tclsh8.5 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>tclsh</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
|
@ -1,38 +0,0 @@
|
|||
--- tcl8.5a1/html/UserCmd/wish.htm.orig Thu Mar 4 11:24:31 2004
|
||||
+++ tcl8.5a1/html/UserCmd/wish.htm Thu Nov 18 12:47:04 2004
|
||||
@@ -4,7 +4,7 @@
|
||||
<DL><DD>wish - Simple windowing shell</DL>
|
||||
<DD><A HREF="wish.htm#M3" NAME="L16">SYNOPSIS</A>
|
||||
<DL>
|
||||
-<DD><B>wish</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?
|
||||
+<DD><B>wish8.5</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?
|
||||
</DL>
|
||||
<DD><A HREF="wish.htm#M4" NAME="L17">OPTIONS</A>
|
||||
<DL>
|
||||
@@ -36,7 +36,7 @@
|
||||
<H3><A NAME="M2">NAME</A></H3>
|
||||
wish - Simple windowing shell
|
||||
<H3><A NAME="M3">SYNOPSIS</A></H3>
|
||||
-<B>wish</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?<BR>
|
||||
+<B>wish8.5</B> ?-encoding <I>name</I>? ?<I>fileName arg arg ...</I>?<BR>
|
||||
<H3><A NAME="M4">OPTIONS</A></H3>
|
||||
<DL>
|
||||
<DT><A NAME="M5"><B>-encoding </B><I>name</I></A><DD>
|
||||
@@ -154,7 +154,7 @@
|
||||
<P></DL>
|
||||
<H3><A NAME="M23">SCRIPT FILES</A></H3>
|
||||
If you create a Tcl script in a file whose first line is
|
||||
-<PRE><B>#!/usr/local/bin/wish</B></PRE>
|
||||
+<PRE><B>#!/usr/local/bin/wish8.5</B></PRE>
|
||||
then you can invoke the script file directly from your shell if
|
||||
you mark it as executable.
|
||||
This assumes that <B>wish</B> has been installed in the default
|
||||
@@ -168,7 +168,7 @@
|
||||
following three lines:
|
||||
<PRE><B>#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" "$@"</B></PRE>
|
||||
+exec wish8.5 "$0" "$@"</B></PRE>
|
||||
This approach has three advantages over the approach in the previous
|
||||
paragraph. First, the location of the <B>wish</B> binary doesn't have
|
||||
to be hard-wired into the script: it can be anywhere in your shell
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue