New port: science/coot: Crystallographic Object-Oriented Toolkit

This commit is contained in:
Yuri Victorovich 2018-07-08 04:45:25 +00:00
parent b0ea0642ac
commit d2a568e451
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=474154
7 changed files with 14552 additions and 0 deletions

View file

@ -46,6 +46,7 @@
SUBDIR += clhep
SUBDIR += clipper
SUBDIR += colt
SUBDIR += coot
SUBDIR += crf++
SUBDIR += dcl
SUBDIR += devisor

50
science/coot/Makefile Normal file
View file

@ -0,0 +1,50 @@
# $FreeBSD$
PORTNAME= coot
DISTVERSION= 0.8.9.1
CATEGORIES= science
MASTER_SITES= https://www2.mrc-lmb.cam.ac.uk/personal/pemsley/${PORTNAME}/source/releases/ \
https://www2.mrc-lmb.cam.ac.uk/personal/pemsley/${PORTNAME}/dependencies/:data
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} refmac-monomer-library${EXTRACT_SUFX}:data reference-structures${EXTRACT_SUFX}:data
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Crystallographic Object-Oriented Toolkit
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libccp4c.so:science/libccp4 \
libclipper-core.so:science/clipper \
libcurl.so:ftp/curl \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libgsl.so:math/gsl \
libmmdb2.so:science/mmdb2 \
libpng16.so:graphics/png \
libsfftw.so:math/fftw-float \
libssm.so:science/libssm
RUN_DEPENDS= bash:shells/bash
USES= desktop-file-utils fortran gettext-runtime gmake libtool localbase:ldflags pkgconfig python:2.7 shebangfix sqlite
SHEBANG_FILES= src/coot.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-python
CONFIGURE_ARGS= --enable-shared --disable-static
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 libartlgpl2 libgnomecanvas pango pangox-compat
USE_GL= gl glu glut
USE_XORG= ice sm x11 xmu xt
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAKE_ENV= PYTHON=${PYTHON_CMD}
CXXFLAGS+= -I${PYTHON_INCLUDEDIR}
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/lib/data
@cd ${WRKDIR} && ${COPYTREE_SHARE} monomers ${STAGEDIR}${DATADIR}/lib/data/
@cd ${WRKDIR} && ${COPYTREE_SHARE} reference-structures ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>

7
science/coot/distinfo Normal file
View file

@ -0,0 +1,7 @@
TIMESTAMP = 1531013796
SHA256 (coot/coot-0.8.9.1.tar.gz) = 51b6faef11177a8ab682fbe28448f935ae1252ad53b4efa31339ff658a63ff94
SIZE (coot/coot-0.8.9.1.tar.gz) = 19360553
SHA256 (coot/refmac-monomer-library.tar.gz) = 03562eec612103a48bd114cfe0d171943e88f94b84610d16d542cda138e5f36b
SIZE (coot/refmac-monomer-library.tar.gz) = 37439851
SHA256 (coot/reference-structures.tar.gz) = 44db38506f0f90c097d4855ad81a82a36b49cd1e3ffe7d6ee4728b15109e281a
SIZE (coot/reference-structures.tar.gz) = 6728787

View file

@ -0,0 +1,8 @@
--- src/cc-interface-image.hh.orig 2018-07-08 02:10:49 UTC
+++ src/cc-interface-image.hh
@@ -1,4 +1,5 @@
+#include <Python.h>
// make a png given the info in text_info_dict
// fields: text, font, size, colour, slant, weight

View file

@ -0,0 +1,11 @@
--- src/rama_plot.cc.orig 2018-07-08 02:28:57 UTC
+++ src/rama_plot.cc
@@ -39,6 +39,8 @@
#include <iostream>
#include <algorithm>
+#include <sys/stat.h>
+
#include <gdk/gdkkeysyms.h> // for keyboarding.
#include "utils/coot-utils.hh" // int to string

9
science/coot/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
Coot is for macromolecular model building, model completion and validation,
particularly suitable for protein modelling using X-ray data.
Coot displays maps and models and allows model manipulations such as
idealization, real space refinement, manual rotation/translation, rigid-body
fitting, ligand search, solvation, mutations, rotamers, Ramachandran plots,
skeletonization, non-crystallographic symmetry and more.
WWW: https://www2.mrc-lmb.cam.ac.uk/personal/pemsley/coot/

14466
science/coot/pkg-plist Normal file

File diff suppressed because it is too large Load diff