- Install INFO docs again as they're more complete [1]

- Drop BROKEN: builds fine on 8.4R i386/amd64
- Checking "no" value is only required for MK_ variables
- Convert to option helpers
- Clarify LICENSE allows any later version

PR:		191548 [1]
This commit is contained in:
Jan Beich 2015-04-15 17:08:01 +00:00
parent 4cfe78f920
commit d2d8918ccf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=384063
4 changed files with 30 additions and 28 deletions

View file

@ -2,40 +2,29 @@
PORTNAME= cvs
PORTVERSION= 1.20120905
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= LOCAL/eadler
MAINTAINER= ports@FreeBSD.org
COMMENT= Version control system
LICENSE= GPLv2
LICENSE= GPLv2 # or any later version
OPTIONS_DEFINE= KERBEROS EXAMPLES
OPTIONS_DEFAULT=KERBEROS
USES= tar:xz uidfix
KERBEROS_MAKE_ARGS= KERBEROS_SUPPORT=yes
USES= makeinfo tar:xz uidfix
WRKSRC= ${WRKDIR}/call/cvs-build
INFO= cvs cvsclient
# bsd.stage.makes sets the wrong value for DESTDIR
DESTDIRNAME= NADA
MAKE_ARGS= DESTDIR=${STAGEDIR}${PREFIX}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKERBEROS}
MAKE_ARGS+= KERBEROS_SUPPORT=yes
.else
MAKE_ARGS+= KERBEROS_SUPPORT=no
.endif
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
BROKEN= does not link
.endif
pre-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/contrib
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,9 +0,0 @@
--- Makefile.orig 2012-01-21 05:30:07 UTC
+++ Makefile
@@ -1,5 +1,5 @@
# $FreeBSD: head/gnu/usr.bin/cvs/Makefile 175384 2008-01-16 17:16:36Z obrien $
-SUBDIR = lib libdiff cvs contrib cvsbug doc
+SUBDIR = lib libdiff cvs contrib cvsbug
.include <bsd.subdir.mk>

View file

@ -0,0 +1,22 @@
From 6733b1455f97531bace80bf7118dc644fe73fd3d Mon Sep 17 00:00:00 2001
From: tg <tg@mirbsd.org>
Date: Wed, 26 Jun 2013 18:15:51 +0000
Subject: Make cvs.texinfo compatible with newer makeinfo (Closes: #711298)
diff --git a/doc/cvs.texinfo b/doc/cvs.texinfo
index a0136a5..d11a5e1 100644
--- ../cvs/doc/cvs.texinfo
+++ ../cvs/doc/cvs.texinfo
@@ -113,9 +113,9 @@ approved by the Free Software Foundation.
@sp 4
@comment The title is printed in a large font.
@center @titlefont{Version Management}
-@sp
+@sp 1
@center @titlefont{with}
-@sp
+@sp 1
@center @titlefont{CVS}
@sp 2
@center for @sc{cvs} @value{VERSION}

View file

@ -5,7 +5,7 @@
LDADD= ${LIBCVS} ${LIBDIFF} -lgnuregex -lmd -lcrypt -lz
-.if ${MK_KERBEROS_SUPPORT} != "no"
+.if ${KERBEROS_SUPPORT} != "no"
+.if defined(KERBEROS_SUPPORT)
CFLAGS+= -DHAVE_GSSAPI -DENCRYPTION
LDADD+= -lgssapi -lkrb5 -lhx509 -lasn1 -lcrypto -lroken -lcrypt -lcom_err
DPADD+= ${LIBGSSAPI} ${LIBKRB5} ${LIBHX509} ${LIBASN1} ${LIBCRYPTO} ${LIBROKEN}