Fix build with gcc 3.4

Reported by:	pointyhat

Mark IGNORE on amd64, crahes on startup.
Probably broken on other 64bit archs too, because of a lot of LP64-warnings.
This commit is contained in:
Tilman Keskinoz 2004-08-14 09:48:27 +00:00
parent 9c984d1d35
commit d2d9f64a68
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116188
2 changed files with 22 additions and 1 deletions

View file

@ -22,6 +22,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_X_PREFIX= yes
USE_GNOME= gtk12
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
IGNORE= "crashes on startup"
.endif
post-extract:
@${RM} ${WRKSRC}/../share/docs/LICENSE~
@ -32,4 +38,4 @@ post-install:
.endfor
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,15 @@
--- src/ftp_tree.h.orig Sat Aug 14 11:40:27 2004
+++ ftp_tree.h Sat Aug 14 11:41:17 2004
@@ -321,10 +321,12 @@
break;
default:
+ break;
}
break;
default:
+ break;
}
return FALSE;
}