Mass upgrade of CPAN ports:

p5-Apache		->	1.00b2
	p5-Array-PrintCols	->	2.0
	p5-C-Scan		->	0.4
	p5-DBD-Pg		->	0.62
	p5-Data-Flow		->	0.05
	p5-Devel-Peek		->	0.83
	p5-HTML-Stream		->	1.40
	p5-HTTPD-Tools		->	0.55
	p5-Image-Size		->	2.4
	p5-IniConf		->	0.92
	p5-Msql			->	1.1809
	p5-Mysql		->	1.1809
	p5-PGP			->	0.3a
	p5-Pg			->	1.6.1
	p5-Tk			->	402.002
	p5-WWW-Search		->	1.010
	p5-libwww		->	5.12
This commit is contained in:
James FitzGibbon 1997-09-14 02:55:26 +00:00
parent 95d2da7653
commit d2efc9486f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=7898
43 changed files with 177 additions and 235 deletions

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-DBD-Pg
# Version required: 0.3
# Version required: 0.62
# Date created: June 17th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.2 1997/06/19 07:46:16 asami Exp $
# $Id: Makefile,v 1.3 1997/06/24 18:43:10 jfitz Exp $
#
DISTNAME= DBD-Pg-0.3
PKGNAME= p5-DBD-Pg-0.3
DISTNAME= DBD-Pg-0.62
PKGNAME= p5-DBD-Pg-0.62
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD

View file

@ -1 +1 @@
MD5 (DBD-Pg-0.3.tar.gz) = dd1e2d3e87f5308d7671c6acfbafff50
MD5 (DBD-Pg-0.62.tar.gz) = fbb6144ad32762d8dae71d40c7af10c5

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-DBD-Pg
# Version required: 0.3
# Version required: 0.62
# Date created: June 17th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.2 1997/06/19 07:46:16 asami Exp $
# $Id: Makefile,v 1.3 1997/06/24 18:43:10 jfitz Exp $
#
DISTNAME= DBD-Pg-0.3
PKGNAME= p5-DBD-Pg-0.3
DISTNAME= DBD-Pg-0.62
PKGNAME= p5-DBD-Pg-0.62
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD

View file

@ -1 +1 @@
MD5 (DBD-Pg-0.3.tar.gz) = dd1e2d3e87f5308d7671c6acfbafff50
MD5 (DBD-Pg-0.62.tar.gz) = fbb6144ad32762d8dae71d40c7af10c5

View file

@ -1,27 +1,29 @@
# New ports collection makefile for: p5-MySQL
# Version required: 1.17
# Date created: June 17th 1997
# New ports collection makefile for: p5-Mysql-modules
# Version required: 1.1809
# Date created: September 29th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.1.1.1 1997/06/18 19:39:25 jfitz Exp $
# $Id: Makefile,v 1.14 1997/09/13 17:55:20 jfitz Exp $
#
DISTNAME= Mysqlperl-1.17
PKGNAME= p5-Mysql-1.17
DISTNAME= Mysql-modules-1.1809
PKGNAME= p5-Mysql-modules-1.1809
CATEGORIES= databases perl5
MASTER_SITES= http://www.tcx.se/Contrib/
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
MAINTAINER= jfitz@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql
BUILD_DEPENDS= ${PREFIX}/lib/libmysqlclient.a:${PORTSDIR}/databases/mysql/ \
${PREFIX}/lib/perl5/site_perl/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable/ \
${PREFIX}/lib/perl5/site_perl/DBI.pm:${PORTSDIR}/databases/p5-DBI/
CONFIGURE_ENV+= PREFIX=${PREFIX} MSQL_HOME=${PREFIX}
USE_PERL5= YES
MAN3= Mysql.3
MANPREFIX= ${PREFIX}/lib/perl5
CONFIGURE_ENV+= PREFIX=${PREFIX}
MAN1= pmsql.1 dbimon.1
MAN3= Mysql.3 DBD::mSQL.3
MAN3PREFIX= ${PREFIX}/lib/perl5
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL

View file

@ -1 +1 @@
MD5 (Mysqlperl-1.17.tgz) = a92064386ff373a31fb1fe854e81e461
MD5 (Mysql-modules-1.1809.tar.gz) = 53372267db84fb9d4c0807407a8a286d

View file

@ -1 +1 @@
perl5 interface to the MySQL database
perl5 modules for accessing MiniSQL (mSQL) databases.

View file

@ -1,58 +1,13 @@
What you achieve with MysqlPerl
------------------------------
Msql.pm and DBD::mSQL implement two different approaches to
communicate with an mSQL server. DBD::mSQL is built upon the DBI, the
generic Perl Database Interface. It brings you an identical interface
to a broad variety of databases and is in this regard comparable to
ODBC. The advantage of the DBI approach is portability and
interoperability. Msql.pm is the elder species. It was written before
DBI was available but it was inspired by an early draft of the DBI
specification. As it has been circulating longer it is more mature and
pretty stable. It's also more complete than DBD::mSQL.
MysqlPerl is an interface between the perl programming language and the
MySQL programming API that comes with the MySQL relational database
management system. All functions provided by the MySQL programming API
are supported.
From perl you activate the interface with the statement
use Mysql;
After that you can connect to multiple msql database servers and send
multiple queries to any of them via an simple object oriented
interface. Two types of objects are available: database handles and
statement handles. Perl returns a database handle to the Connect
method like so:
$dbh = Mysql->connect($hostname,$databasename);
Once you have connected to a database, you get a statement handle
with:
$sth = $dbh->query("select foo from bar");
You can open as many queries as you like simultaneously by selecting a
different scalar to hold the object:
$another_sth = $dbh->Query("select bar from foo");
The statement handle allows you to step through the virtual table
returned from the database with the FetchRow method:
@row = $sth->fetchrow;
or
%hash = $sth->fetchhash;
You can access all metadata that MySQL supplies for a given table. To
find out the number of rows or the number of fields returned by a
query you simply say:
$numrows = $sth->numrows;
$numfields = $sth->numfields;
To find out the size in bytes for the field with the offset 0 (the
first field of a query), you say:
$length = $sth->length->[0];
The list of the names for each column is returned by
@list => $sth->name;
As for other metadata available, consult the manpage that comes with
MysqlPerl and study the examples in the file t/msql.t, which is the
extensive testscript to test your installation, but is heavily
commented, so you may use it as a tutorial.
Some day in the future DBD::mSQL will probably be the clearly superior
competitor in this package. Today you have to decide on your own about
the trade-offs.

View file

@ -1,8 +1,16 @@
bin/dbimon
bin/pmsql
lib/perl5/man/man3/DBD::mysql.3.gz
lib/perl5/man/man3/Mysql.3.gz
lib/perl5/site_perl/DBD/mysql.pm
lib/perl5/site_perl/Mysql.pm
lib/perl5/site_perl/Mysql/Statement.pm
lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql/mysql.bs
lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql/mysql.so
lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.bs
lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.so
man/man1/pmsql.1.gz
man/man1/dbimon.1.gz
lib/perl5/site_perl/i386-freebsd/auto/Mysql/.packlist
@dirrm lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql
@dirrm lib/perl5/site_perl/i386-freebsd/auto/Mysql
@dirrm lib/perl5/site_perl/Mysql

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Msql-modules
# Version required: 1.1808
# Version required: 1.1809
# Date created: September 29th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.13 1997/07/14 13:23:27 jfitz Exp $
# $Id: Makefile,v 1.14 1997/09/13 17:55:20 jfitz Exp $
#
DISTNAME= Msql-modules-1.1808
PKGNAME= p5-Msql-modules-1.1808
DISTNAME= Msql-modules-1.1809
PKGNAME= p5-Msql-modules-1.1809
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Msql
@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= Msql
MAINTAINER= jfitz@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/lib/libmsql.a:${PORTSDIR}/databases/msql/ \
${PREFIX}/lib/perl5/site_perl/Data/ShowTable.pm:${PORTSDIR}/misc/p5-Data/ShowTable/ \
${PREFIX}/lib/perl5/site_perl/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable/ \
${PREFIX}/lib/perl5/site_perl/DBI.pm:${PORTSDIR}/databases/p5-DBI/
CONFIGURE_ENV+= PREFIX=${PREFIX} MSQL_HOME=${PREFIX}

View file

@ -1 +1 @@
MD5 (Msql-modules-1.1808.tar.gz) = 764e0267a86b479be1ac33de4860dfe1
MD5 (Msql-modules-1.1809.tar.gz) = 2d6f02d62b26cb2bb105c77b8e740f49

View file

@ -1,27 +1,29 @@
# New ports collection makefile for: p5-MySQL
# Version required: 1.17
# Date created: June 17th 1997
# New ports collection makefile for: p5-Mysql-modules
# Version required: 1.1809
# Date created: September 29th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.1.1.1 1997/06/18 19:39:25 jfitz Exp $
# $Id: Makefile,v 1.14 1997/09/13 17:55:20 jfitz Exp $
#
DISTNAME= Mysqlperl-1.17
PKGNAME= p5-Mysql-1.17
DISTNAME= Mysql-modules-1.1809
PKGNAME= p5-Mysql-modules-1.1809
CATEGORIES= databases perl5
MASTER_SITES= http://www.tcx.se/Contrib/
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
MAINTAINER= jfitz@FreeBSD.ORG
BUILD_DEPENDS= ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql
BUILD_DEPENDS= ${PREFIX}/lib/libmysqlclient.a:${PORTSDIR}/databases/mysql/ \
${PREFIX}/lib/perl5/site_perl/Data/ShowTable.pm:${PORTSDIR}/devel/p5-Data-ShowTable/ \
${PREFIX}/lib/perl5/site_perl/DBI.pm:${PORTSDIR}/databases/p5-DBI/
CONFIGURE_ENV+= PREFIX=${PREFIX} MSQL_HOME=${PREFIX}
USE_PERL5= YES
MAN3= Mysql.3
MANPREFIX= ${PREFIX}/lib/perl5
CONFIGURE_ENV+= PREFIX=${PREFIX}
MAN1= pmsql.1 dbimon.1
MAN3= Mysql.3 DBD::mSQL.3
MAN3PREFIX= ${PREFIX}/lib/perl5
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL

View file

@ -1 +1 @@
MD5 (Mysqlperl-1.17.tgz) = a92064386ff373a31fb1fe854e81e461
MD5 (Mysql-modules-1.1809.tar.gz) = 53372267db84fb9d4c0807407a8a286d

View file

@ -1 +1 @@
perl5 interface to the MySQL database
perl5 modules for accessing MiniSQL (mSQL) databases.

View file

@ -1,58 +1,13 @@
What you achieve with MysqlPerl
------------------------------
Msql.pm and DBD::mSQL implement two different approaches to
communicate with an mSQL server. DBD::mSQL is built upon the DBI, the
generic Perl Database Interface. It brings you an identical interface
to a broad variety of databases and is in this regard comparable to
ODBC. The advantage of the DBI approach is portability and
interoperability. Msql.pm is the elder species. It was written before
DBI was available but it was inspired by an early draft of the DBI
specification. As it has been circulating longer it is more mature and
pretty stable. It's also more complete than DBD::mSQL.
MysqlPerl is an interface between the perl programming language and the
MySQL programming API that comes with the MySQL relational database
management system. All functions provided by the MySQL programming API
are supported.
From perl you activate the interface with the statement
use Mysql;
After that you can connect to multiple msql database servers and send
multiple queries to any of them via an simple object oriented
interface. Two types of objects are available: database handles and
statement handles. Perl returns a database handle to the Connect
method like so:
$dbh = Mysql->connect($hostname,$databasename);
Once you have connected to a database, you get a statement handle
with:
$sth = $dbh->query("select foo from bar");
You can open as many queries as you like simultaneously by selecting a
different scalar to hold the object:
$another_sth = $dbh->Query("select bar from foo");
The statement handle allows you to step through the virtual table
returned from the database with the FetchRow method:
@row = $sth->fetchrow;
or
%hash = $sth->fetchhash;
You can access all metadata that MySQL supplies for a given table. To
find out the number of rows or the number of fields returned by a
query you simply say:
$numrows = $sth->numrows;
$numfields = $sth->numfields;
To find out the size in bytes for the field with the offset 0 (the
first field of a query), you say:
$length = $sth->length->[0];
The list of the names for each column is returned by
@list => $sth->name;
As for other metadata available, consult the manpage that comes with
MysqlPerl and study the examples in the file t/msql.t, which is the
extensive testscript to test your installation, but is heavily
commented, so you may use it as a tutorial.
Some day in the future DBD::mSQL will probably be the clearly superior
competitor in this package. Today you have to decide on your own about
the trade-offs.

View file

@ -1,8 +1,16 @@
bin/dbimon
bin/pmsql
lib/perl5/man/man3/DBD::mysql.3.gz
lib/perl5/man/man3/Mysql.3.gz
lib/perl5/site_perl/DBD/mysql.pm
lib/perl5/site_perl/Mysql.pm
lib/perl5/site_perl/Mysql/Statement.pm
lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql/mysql.bs
lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql/mysql.so
lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.bs
lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.so
man/man1/pmsql.1.gz
man/man1/dbimon.1.gz
lib/perl5/site_perl/i386-freebsd/auto/Mysql/.packlist
@dirrm lib/perl5/site_perl/i386-freebsd/auto/DBD/mysql
@dirrm lib/perl5/site_perl/i386-freebsd/auto/Mysql
@dirrm lib/perl5/site_perl/Mysql

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-C-Scan
# Version required: 0.3
# New ports collection makefixle for: p5-C-Scan
# Version required: 0.4
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.7 1997/05/24 13:17:00 jfitz Exp $
# $Id: Makefile,v 1.8 1997/06/24 18:43:06 jfitz Exp $
#
DISTNAME= C-Scan-0.3
PKGNAME= p5-C-Scan-0.3
DISTNAME= C-Scan-0.4
PKGNAME= p5-C-Scan-0.4
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= C

View file

@ -1 +1 @@
MD5 (C-Scan-0.3.tar.gz) = 59a01840a75817d8c883233555c43c68
MD5 (C-Scan-0.4.tar.gz) = 25eb293913fc4884092c6d46e631d520

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-IniConf
# Version required: 0.91
# Version required: 0.92
# Date created: October 21st 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.5 1997/05/24 13:17:03 jfitz Exp $
# $Id: Makefile,v 1.6 1997/06/24 18:43:22 jfitz Exp $
#
DISTNAME= IniConf.pm-0.91
PKGNAME= p5-IniConf-0.91
DISTNAME= IniConf.pm-0.92
PKGNAME= p5-IniConf-0.92
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IniConf

View file

@ -1 +1 @@
MD5 (IniConf.pm-0.91.tar.gz) = 5b24be5b28ebf7b6105a7dc5481aac0d
MD5 (IniConf.pm-0.92.tar.gz) = 0057de0a61aacf1de8ec966fd70c9ded

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Data-Flow
# Version required: 0.04
# Version required: 0.05
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.5 1997/05/24 13:17:01 jfitz Exp $
# $Id: Makefile,v 1.6 1997/06/24 18:43:12 jfitz Exp $
#
DISTNAME= Data-Flow-0.04
PKGNAME= p5-Data-Flow-0.04
DISTNAME= Data-Flow-0.05
PKGNAME= p5-Data-Flow-0.05
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Data

View file

@ -1 +1 @@
MD5 (Data-Flow-0.04.tar.gz) = 5c6f9ed8aee0fbf68eaa59247f99b948
MD5 (Data-Flow-0.05.tar.gz) = aac4ec71bc145ce6bb9663360524b258

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Devel-Peek
# Version required: 0.82
# Version required: 0.83
# Date created: June 15th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.1.1.1 1997/06/16 02:47:24 jfitz Exp $
# $Id: Makefile,v 1.2 1997/06/24 18:43:17 jfitz Exp $
#
DISTNAME= Devel-Peek-0.82
PKGNAME= p5-Devel-Peek-0.82
DISTNAME= Devel-Peek-0.83
PKGNAME= p5-Devel-Peek-0.83
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Devel

View file

@ -1 +1 @@
MD5 (Devel-Peek-0.82.tar.gz) = 4b0476fbe5c10b3d5bf7ab2812d0a356
MD5 (Devel-Peek-0.83.tar.gz) = 3b16266fb7e2d2456b320d40c16a465e

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-IniConf
# Version required: 0.91
# Version required: 0.92
# Date created: October 21st 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.5 1997/05/24 13:17:03 jfitz Exp $
# $Id: Makefile,v 1.6 1997/06/24 18:43:22 jfitz Exp $
#
DISTNAME= IniConf.pm-0.91
PKGNAME= p5-IniConf-0.91
DISTNAME= IniConf.pm-0.92
PKGNAME= p5-IniConf-0.92
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IniConf

View file

@ -1 +1 @@
MD5 (IniConf.pm-0.91.tar.gz) = 5b24be5b28ebf7b6105a7dc5481aac0d
MD5 (IniConf.pm-0.92.tar.gz) = 0057de0a61aacf1de8ec966fd70c9ded

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Image-Size
# Version required: 2.2
# Version required: 2.4
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.9 1997/05/29 02:53:15 jfitz Exp $
# $Id: Makefile,v 1.10 1997/06/24 18:43:21 jfitz Exp $
#
DISTNAME= Image-Size-2.2
PKGNAME= p5-Image-Size-2.2
DISTNAME= Image-Size-2.4
PKGNAME= p5-Image-Size-2.4
CATEGORIES= graphics www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Image

View file

@ -1 +1 @@
MD5 (Image-Size-2.2.tar.gz) = 42901f6df9cb2c6d7ef55acd8e509b05
MD5 (Image-Size-2.4.tar.gz) = f79ff6f82c62d7f86233225f57c6f725

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Array-PrintCols
# Version required: 1.2
# Version required: 2.0
# Date created: October 17th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.7 1997/05/24 13:17:11 jfitz Exp $
# $Id: Makefile,v 1.8 1997/06/24 18:43:04 jfitz Exp $
#
DISTNAME= Array-PrintCols-1.2
PKGNAME= p5-Array-PrintCols-1.2
DISTNAME= Array-PrintCols-2.0
PKGNAME= p5-Array-PrintCols-2.0
CATEGORIES= misc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Array
@ -16,9 +16,10 @@ MAINTAINER= jfitz@FreeBSD.ORG
USE_PERL5= YES
NO_BUILD= YES
WRKSRC= ${WRKDIR}/Array-PrintCols
MAN3= Array::PrintCols.3p
MAN3= Array::PrintCols.3
MANPREFIX= ${PREFIX}/lib/perl5
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (Array-PrintCols-1.2.tar.gz) = 9dd483fbc72eefb0587a0e0c0a614926
MD5 (Array-PrintCols-2.0.tar.gz) = b33da62022d8a5ef64c4d073a8baa0ab

View file

@ -1,4 +1,5 @@
lib/perl5/site_perl/Array/PrintCols-1.2.pm
lib/perl5/man/man3/Array::PrintCols.3.gz
lib/perl5/site_perl/Array/PrintCols.pm
lib/perl5/man/man3/Array::PrintCols.3p.gz
@dirrm lib/perl5/site_perl/Array
lib/perl5/site_perl/Array/tester.pl
lib/perl5/site_perl/i386-freebsd/auto/Array/PrintCols/.packlist
@dirrm lib/perl5/site_perl/i386-freebsd/auto/Array/PrintCols

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-PGP
# Version required: 0.2alpha
# Version required: 0.3a
# Date created: October 21st 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.7 1997/06/09 16:06:42 jfitz Exp $
# $Id: Makefile,v 1.8 1997/06/24 18:43:28 jfitz Exp $
#
DISTNAME= PGP-0.2alpha
PKGNAME= p5-PGP-0.2a
DISTNAME= PGP-0.3a
PKGNAME= p5-PGP-0.3a
CATEGORIES= security perl5
#MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITES=
@ -19,10 +19,12 @@ BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
USE_PERL5= YES
NO_WRKSUBDIR= YES
MAN3= PGP.3
MAN3= PGP::Pipe.3
MANPREFIX= ${PREFIX}/lib/perl5
pre-configure:
@${CP} ${WRKSRC}/PGP/Pipe.pm ${WRKSRC}
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL

View file

@ -1 +1 @@
MD5 (PGP-0.2alpha.tar.gz) = 979ca0729c0f2fb18c088ab16b11848d
MD5 (PGP-0.3a.tar.gz) = f1dcc422173e529fab8b69a83567e107

View file

@ -0,0 +1,8 @@
--- Makefile.PL.orig Sat Sep 13 19:04:08 1997
+++ Makefile.PL Sat Sep 13 19:04:23 1997
@@ -1,4 +1,4 @@
use ExtUtils::MakeMaker;
-&WriteMakefile;
+&WriteMakefile( 'NAME' => "PGP::Pipe" );

View file

@ -1,4 +1,4 @@
lib/perl5/man/man3/PGP.3.gz
lib/perl5/site_perl/PGP-parse.pl
lib/perl5/site_perl/PGP.pm
lib/perl5/site_perl/i386-freebsd/auto/work/.packlist
lib/perl5/man/man3/PGP::Pipe.3.gz
lib/perl5/site_perl/PGP/Pipe.pm
lib/perl5/site_perl/i386-freebsd/auto/PGP/Pipe/.packlist
@dirrm lib/perl5/site_perl/i386-freebsd/auto/PGP/Pipe

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-Apache
# Version required: 0.98
# Version required: 1.00b2
# Date created: April 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.4 1997/05/26 01:56:54 asami Exp $
# $Id: Makefile,v 1.5 1997/06/24 18:43:04 jfitz Exp $
#
DISTNAME= mod_perl-0.98
PKGNAME= p5-Apache-0.98
DISTNAME= mod_perl-1.00b2
PKGNAME= p5-Apache-1.00b2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache

View file

@ -1 +1 @@
MD5 (mod_perl-0.98.tar.gz) = d6b77a5999e033245af4ffbc2ab86e7a
MD5 (mod_perl-1.00b2.tar.gz) = 21f4e414e8fb40a5f190cf7996230c3d

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-HTML-Stream
# Version required: 1.38
# Version required: 1.40
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.6 1997/05/24 13:17:16 jfitz Exp $
# $Id: Makefile,v 1.7 1997/06/24 18:43:20 jfitz Exp $
#
DISTNAME= HTML-Stream-1.38
PKGNAME= p5-HTML-Stream-1.38
DISTNAME= HTML-Stream-1.40
PKGNAME= p5-HTML-Stream-1.40
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML

View file

@ -1 +1 @@
MD5 (HTML-Stream-1.38.tar.gz) = 9825ecb79696f347ab7dc71f4d95fc1b
MD5 (HTML-Stream-1.40.tar.gz) = 6e1e49d44cae16b5a7fdfd066d4584ad

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-HTTPD-Tools
# Version required: 0.53
# Version required: 0.55
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.6 1997/05/24 13:17:16 jfitz Exp $
# $Id: Makefile,v 1.7 1997/06/24 18:43:20 jfitz Exp $
#
DISTNAME= HTTPD-Tools-0.53
PKGNAME= p5-HTTPD-Tools-0.53
DISTNAME= HTTPD-Tools-0.55
PKGNAME= p5-HTTPD-Tools-0.55
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTTPD

View file

@ -1 +1 @@
MD5 (HTTPD-Tools-0.53.tar.gz) = 34b6803828934020fb77599b344abb23
MD5 (HTTPD-Tools-0.55.tar.gz) = b870f0b9c769408488fd4fc583445a92

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: p5-HTTPD-Tools
# Version required: 0.53
# Version required: 0.55
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id: Makefile,v 1.6 1997/05/24 13:17:16 jfitz Exp $
# $Id: Makefile,v 1.7 1997/06/24 18:43:20 jfitz Exp $
#
DISTNAME= HTTPD-Tools-0.53
PKGNAME= p5-HTTPD-Tools-0.53
DISTNAME= HTTPD-Tools-0.55
PKGNAME= p5-HTTPD-Tools-0.55
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTTPD

View file

@ -1 +1 @@
MD5 (HTTPD-Tools-0.53.tar.gz) = 34b6803828934020fb77599b344abb23
MD5 (HTTPD-Tools-0.55.tar.gz) = b870f0b9c769408488fd4fc583445a92