Initial import.
This commit is contained in:
parent
0912ba6e80
commit
d2f7b6d9f7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22193
5 changed files with 72 additions and 0 deletions
19
misc/gtl/Makefile
Normal file
19
misc/gtl/Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
# New ports collection makefile for: gtl
|
||||
# Version required: 0.3.1
|
||||
# Date created: 05 October 1999
|
||||
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= GTL-0.3.1
|
||||
PKGNAME= gtl-0.3.1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.fmi.uni-passau.de/archive/archive.theory/ftp/GTL/
|
||||
|
||||
MAINTAINER= nakai@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_NEWGCC= yes
|
||||
|
||||
.include <bsd.port.mk>
|
18
misc/gtl/files/patch-aa
Normal file
18
misc/gtl/files/patch-aa
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- include/GTL/GTL.h.orig Fri Oct 1 13:22:15 1999
|
||||
+++ include/GTL/GTL.h Fri Oct 1 13:22:57 1999
|
||||
@@ -115,6 +115,7 @@
|
||||
|
||||
#include <memory>
|
||||
|
||||
+#ifndef __FreeBSD__
|
||||
/**
|
||||
* @internal
|
||||
*/
|
||||
@@ -122,6 +123,7 @@
|
||||
class allocator : public alloc
|
||||
{
|
||||
};
|
||||
+#endif
|
||||
|
||||
#endif
|
||||
|
1
misc/gtl/pkg-comment
Normal file
1
misc/gtl/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
the graph template library that supports graphs and graph algorithm
|
1
misc/gtl/pkg-descr
Normal file
1
misc/gtl/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
the graph template library that supports graphs and graph algorithm
|
33
misc/gtl/pkg-plist
Normal file
33
misc/gtl/pkg-plist
Normal file
|
@ -0,0 +1,33 @@
|
|||
include/GTL/GTL.h
|
||||
include/GTL/algorithm.h
|
||||
include/GTL/bfs.h
|
||||
include/GTL/biconnectivity.h
|
||||
include/GTL/debug.h
|
||||
include/GTL/dfs.h
|
||||
include/GTL/edge.h
|
||||
include/GTL/edge_data.h
|
||||
include/GTL/edge_map.h
|
||||
include/GTL/embedding.h
|
||||
include/GTL/gml_parser.h
|
||||
include/GTL/gml_scanner.h
|
||||
include/GTL/graph.h
|
||||
include/GTL/max_flow.h
|
||||
include/GTL/max_flow_mkm.h
|
||||
include/GTL/ne_map.h
|
||||
include/GTL/node.h
|
||||
include/GTL/node_data.h
|
||||
include/GTL/node_map.h
|
||||
include/GTL/planarity.h
|
||||
include/GTL/pq_node.h
|
||||
include/GTL/pq_tree.h
|
||||
include/GTL/st_number.h
|
||||
include/GTL/symlist.h
|
||||
include/GTL/topsort.h
|
||||
include/GTL/version.h
|
||||
lib/libGTL.a
|
||||
lib/libGTL.la
|
||||
lib/libGTL.so
|
||||
lib/libGTL.so.3
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@dirrm include/GTL
|
Loading…
Reference in a new issue