- Add LICENSE
- Switch to USES=localbase - Cosmetic fixes - Strip library - Fix library paths order to fix build in presence of older version of itself PR: 210635 Submitted by: amdmi3 Approved by: maintainer timeout (malus.x@gmail.com, 2 weeks)
This commit is contained in:
parent
2b0e2759ae
commit
d336ad8586
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418443
2 changed files with 28 additions and 10 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= libdlna
|
||||
PORTVERSION= 0.2.3
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://libdlna.geexbox.org/releases/ \
|
||||
LOCAL/ehaupt
|
||||
|
@ -11,10 +11,13 @@ MASTER_SITES= http://libdlna.geexbox.org/releases/ \
|
|||
MAINTAINER= malus.x@gmail.com
|
||||
COMMENT= Reference DLNA open-source implementation
|
||||
|
||||
LIB_DEPENDS+= libavcodec.so:multimedia/ffmpeg
|
||||
LICENSE= LGPL21+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USES= tar:bzip2 gmake pkgconfig
|
||||
USES= gmake localbase pkgconfig tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
|
@ -22,12 +25,7 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-optimize \
|
|||
--includedir="${PREFIX}/include" \
|
||||
--libdir="${PREFIX}/lib"
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's#\(PKGCONFIG_DIR = \).*#\1${STAGEDIR}${PREFIX}/libdata/pkgconfig#' \
|
||||
${WRKSRC}/Makefile
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libdlna.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
20
devel/libdlna/files/patch-Makefile
Normal file
20
devel/libdlna/files/patch-Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.orig 2007-11-26 20:47:43 UTC
|
||||
+++ Makefile
|
||||
@@ -4,7 +4,7 @@ endif
|
||||
include config.mak
|
||||
|
||||
DISTFILE = libdlna-$(VERSION).tar.bz2
|
||||
-PKGCONFIG_DIR = $(libdir)/pkgconfig
|
||||
+PKGCONFIG_DIR = $(prefix)/libdata/pkgconfig
|
||||
PKGCONFIG_FILE = libdlna.pc
|
||||
|
||||
LIBTEST = test-libdlna
|
||||
@@ -19,7 +19,7 @@ EXTRADIST = AUTHORS \
|
||||
SUBDIRS = src \
|
||||
|
||||
CFLAGS += -Isrc
|
||||
-LDFLAGS += -Lsrc -ldlna
|
||||
+LDFLAGS := -Lsrc -ldlna ${LDFLAGS}
|
||||
|
||||
ifeq ($(BUILD_STATIC),yes)
|
||||
LDFLAGS += $(EXTRALIBS)
|
Loading…
Reference in a new issue