- Added Qt 4 support
- Fix update-mime-database handling PR: 126474 Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer)
This commit is contained in:
parent
bd8d847856
commit
d37224f61b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218637
5 changed files with 124 additions and 51 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= google-gadgets
|
||||
PORTVERSION= 0.10.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
|
||||
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
|
||||
|
@ -32,15 +33,18 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefo
|
|||
|
||||
USE_LDCONFIG= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack gtk20
|
||||
USE_GCC= 4.2+
|
||||
USE_GSTREAMER= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no --disable-update-mime-database
|
||||
CONFIGURE_ARGS= --enable-ltdl-install=no
|
||||
USE_AUTOTOOLS= libtool:15:env autoconf:261:env automake:110:env aclocal:110:env libltdl:15
|
||||
WANT_GNOME= yes
|
||||
USE_GNOME= gnomehack
|
||||
|
||||
OPTIONS= DEBUGGING "Enable debug output on runtime" on
|
||||
OPTIONS= DEBUGGING "Enable debug output on runtime" on\
|
||||
GTK "Build GTK Host" on\
|
||||
QT "Build Qt Host" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -48,16 +52,37 @@ OPTIONS= DEBUGGING "Enable debug output on runtime" on
|
|||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GTK)
|
||||
PLIST_SUB+= GTK="@comment "
|
||||
CONFIGURE_ARGS+= --disable-gtk-host --disable-libggadget-gtk --disable-gtkmoz-browser-element --disable-gtk-system-framework
|
||||
.elif defined(WITH_GTK)
|
||||
USE_GNOME= gtk20
|
||||
PLIST_SUB+= GTK=""
|
||||
CONFIGURE_ARGS+= --enable-gtk-host
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_QT)
|
||||
PLIST_SUB+= QT="@comment "
|
||||
CONFIGURE_ARGS+= --disable-qt-host --disable-libggadget-qt --disable-qt-system-framework\
|
||||
--disable-qtwebkit-browser-element --disable-qt-script-runtime --disable-qt-xml-http-request
|
||||
.else
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= webkit opengl gui corelib script network moc
|
||||
PLIST_SUB+= QT=""
|
||||
CONFIGURE_ARGS+= --enable-qt-host
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_QT) && defined(WITHOUT_GTK)
|
||||
IGNORE=This port requires GTK or Qt host to be enabled
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -type f -name Makefile.am -exec ${GREP} -l pkgconfig {} \; | ${XARGS} ${REINPLACE_CMD} -e 's|^\(pkgconfigdir[[:space:]]*=\).*|\1 $$(prefix)/libdata/pkgconfig|'
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC} && ${SH} autotools/bootstrap.sh && ${CP} ${AUTOMAKE_DIR}/mkinstalldirs libltdl/
|
||||
|
||||
post-deinstall:
|
||||
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
|
||||
|
||||
post-install:
|
||||
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@-update-desktop-database
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -3,7 +3,7 @@ $FreeBSD$
|
|||
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -325,6 +325,13 @@
|
||||
@@ -334,6 +334,13 @@
|
||||
GGL_PLATFORM_SHORT=\"linux\"
|
||||
GGL_PLATFORM=\"linux\"
|
||||
;;
|
||||
|
@ -17,3 +17,20 @@ $FreeBSD$
|
|||
*solaris* )
|
||||
ggl_host_type=solaris
|
||||
PREDEFINED_MACROS="$PREDEFINED_MACROS -DGGL_HOST_SOLARIS=1"
|
||||
@@ -352,6 +359,7 @@
|
||||
AM_CONDITIONAL([GGL_HOST_MACOSX], [test x$ggl_host_type = xmacosx])
|
||||
AM_CONDITIONAL([GGL_HOST_LINUX], [test x$ggl_host_type = xlinux])
|
||||
AM_CONDITIONAL([GGL_HOST_SOLARIS], [test x$ggl_host_type = xsolaris])
|
||||
+AM_CONDITIONAL([GGL_HOST_FREEBSD], [test x$ggl_host_type = xfreebsd])
|
||||
|
||||
AC_SUBST(PREDEFINED_MACROS)
|
||||
AC_SUBST(DEFAULT_COMPILE_FLAGS)
|
||||
@@ -445,7 +453,7 @@
|
||||
fi
|
||||
|
||||
# Check qt4
|
||||
-if test x$ggl_host_type = xlinux; then
|
||||
+if test x$ggl_host_type = xlinux -o x$ggl_host_type = xfreebsd; then
|
||||
PKG_CHECK_MODULES(QT4, [QtGui >= 4.3, QtCore >= 4.3, QtOpenGL >= 4.3,
|
||||
QtNetwork >= 4.3],
|
||||
[has_qt4=yes
|
||||
|
|
14
deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc
Normal file
14
deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ggadget/qt/utilities.cc.orig
|
||||
+++ ggadget/qt/utilities.cc
|
||||
@@ -111,7 +111,7 @@
|
||||
if (fork() != 0)
|
||||
_exit(0);
|
||||
|
||||
- execl(xdg_open.c_str(), xdg_open.c_str(), url, NULL);
|
||||
+ execl(xdg_open.c_str(), xdg_open.c_str(), url, (const char*)0);
|
||||
|
||||
DLOG("Failed to exec command: %s", xdg_open.c_str());
|
||||
_exit(-1);
|
|
@ -1,13 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
UPDATE_MIME_DATABASE=update-mime-database
|
||||
|
||||
case $2 in
|
||||
POST-INSTALL)
|
||||
${UPDATE_MIME_DATABASE} ${PKG_PREFIX}/share/mime
|
||||
;;
|
||||
POST-DEINSTALL)
|
||||
${UPDATE_MIME_DATABASE} ${PKG_PREFIX}/share/mime
|
||||
;;
|
||||
esac
|
||||
|
|
@ -1,4 +1,5 @@
|
|||
bin/ggl-gtk
|
||||
%%GTK%%bin/ggl-gtk
|
||||
%%QT%%bin/ggl-qt
|
||||
include/google-gadgets/ggadget/anchor_element.h
|
||||
include/google-gadgets/ggadget/audioclip_interface.h
|
||||
include/google-gadgets/ggadget/backoff.h
|
||||
|
@ -38,15 +39,15 @@ include/google-gadgets/ggadget/gadget.h
|
|||
include/google-gadgets/ggadget/gadget_consts.h
|
||||
include/google-gadgets/ggadget/gadget_manager_interface.h
|
||||
include/google-gadgets/ggadget/graphics_interface.h
|
||||
include/google-gadgets/ggadget/gtk/cairo_graphics.h
|
||||
include/google-gadgets/ggadget/gtk/hotkey.h
|
||||
include/google-gadgets/ggadget/gtk/key_convert.h
|
||||
include/google-gadgets/ggadget/gtk/main_loop.h
|
||||
include/google-gadgets/ggadget/gtk/menu_builder.h
|
||||
include/google-gadgets/ggadget/gtk/single_view_host.h
|
||||
include/google-gadgets/ggadget/gtk/tooltip.h
|
||||
include/google-gadgets/ggadget/gtk/utilities.h
|
||||
include/google-gadgets/ggadget/gtk/view_widget_binder.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/cairo_graphics.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/hotkey.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/key_convert.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/main_loop.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/menu_builder.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/single_view_host.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/tooltip.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/utilities.h
|
||||
%%GTK%%include/google-gadgets/ggadget/gtk/view_widget_binder.h
|
||||
include/google-gadgets/ggadget/host_interface.h
|
||||
include/google-gadgets/ggadget/image_cache.h
|
||||
include/google-gadgets/ggadget/image_interface.h
|
||||
|
@ -69,6 +70,12 @@ include/google-gadgets/ggadget/module.h
|
|||
include/google-gadgets/ggadget/object_element.h
|
||||
include/google-gadgets/ggadget/options_interface.h
|
||||
include/google-gadgets/ggadget/progressbar_element.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/qt_graphics.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/qt_main_loop.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/qt_menu.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/qt_view_host.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/qt_view_widget.h
|
||||
%%QT%%include/google-gadgets/ggadget/qt/utilities.h
|
||||
include/google-gadgets/ggadget/registerable_interface.h
|
||||
include/google-gadgets/ggadget/run_once.h
|
||||
include/google-gadgets/ggadget/scoped_ptr.h
|
||||
|
@ -110,7 +117,7 @@ include/google-gadgets/ggadget/xml_http_request_interface.h
|
|||
include/google-gadgets/ggadget/xml_parser_interface.h
|
||||
include/google-gadgets/ggadget/xml_utils.h
|
||||
include/google-gadgets/ggadget/zip_file_manager.h
|
||||
lib/google-gadgets/gtkmoz-browser-child
|
||||
%%GTK%%lib/google-gadgets/gtkmoz-browser-child
|
||||
lib/google-gadgets/include/ggadget/sysdeps.h
|
||||
lib/google-gadgets/modules/curl-xml-http-request.a
|
||||
lib/google-gadgets/modules/curl-xml-http-request.la
|
||||
|
@ -133,18 +140,33 @@ lib/google-gadgets/modules/gst-audio-framework.so
|
|||
lib/google-gadgets/modules/gst-mediaplayer-element.a
|
||||
lib/google-gadgets/modules/gst-mediaplayer-element.la
|
||||
lib/google-gadgets/modules/gst-mediaplayer-element.so
|
||||
lib/google-gadgets/modules/gtk-edit-element.a
|
||||
lib/google-gadgets/modules/gtk-edit-element.la
|
||||
lib/google-gadgets/modules/gtk-edit-element.so
|
||||
lib/google-gadgets/modules/gtk-system-framework.a
|
||||
lib/google-gadgets/modules/gtk-system-framework.la
|
||||
lib/google-gadgets/modules/gtk-system-framework.so
|
||||
lib/google-gadgets/modules/gtkmoz-browser-element.a
|
||||
lib/google-gadgets/modules/gtkmoz-browser-element.la
|
||||
lib/google-gadgets/modules/gtkmoz-browser-element.so
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.a
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.la
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.so
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.a
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.la
|
||||
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.so
|
||||
%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.a
|
||||
%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.la
|
||||
%%GTK%%lib/google-gadgets/modules/gtkmoz-browser-element.so
|
||||
lib/google-gadgets/modules/libxml2-xml-parser.a
|
||||
lib/google-gadgets/modules/libxml2-xml-parser.la
|
||||
lib/google-gadgets/modules/libxml2-xml-parser.so
|
||||
%%QT%%lib/google-gadgets/modules/qt-edit-element.a
|
||||
%%QT%%lib/google-gadgets/modules/qt-edit-element.la
|
||||
%%QT%%lib/google-gadgets/modules/qt-edit-element.so
|
||||
%%QT%%lib/google-gadgets/modules/qt-script-runtime.a
|
||||
%%QT%%lib/google-gadgets/modules/qt-script-runtime.la
|
||||
%%QT%%lib/google-gadgets/modules/qt-script-runtime.so
|
||||
%%QT%%lib/google-gadgets/modules/qt-system-framework.a
|
||||
%%QT%%lib/google-gadgets/modules/qt-system-framework.la
|
||||
%%QT%%lib/google-gadgets/modules/qt-system-framework.so
|
||||
%%QT%%lib/google-gadgets/modules/qt-xml-http-request.a
|
||||
%%QT%%lib/google-gadgets/modules/qt-xml-http-request.la
|
||||
%%QT%%lib/google-gadgets/modules/qt-xml-http-request.so
|
||||
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.a
|
||||
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.la
|
||||
%%QT%%lib/google-gadgets/modules/qtwebkit-browser-element.so
|
||||
lib/google-gadgets/modules/smjs-script-runtime.a
|
||||
lib/google-gadgets/modules/smjs-script-runtime.la
|
||||
lib/google-gadgets/modules/smjs-script-runtime.so
|
||||
|
@ -156,19 +178,25 @@ lib/libggadget-dbus-1.0.a
|
|||
lib/libggadget-dbus-1.0.la
|
||||
lib/libggadget-dbus-1.0.so
|
||||
lib/libggadget-dbus-1.0.so.0
|
||||
lib/libggadget-gtk-1.0.a
|
||||
lib/libggadget-gtk-1.0.la
|
||||
lib/libggadget-gtk-1.0.so
|
||||
lib/libggadget-gtk-1.0.so.0
|
||||
%%GTK%%lib/libggadget-gtk-1.0.a
|
||||
%%GTK%%lib/libggadget-gtk-1.0.la
|
||||
%%GTK%%lib/libggadget-gtk-1.0.so
|
||||
%%GTK%%lib/libggadget-gtk-1.0.so.0
|
||||
lib/libggadget-js-1.0.a
|
||||
lib/libggadget-js-1.0.la
|
||||
lib/libggadget-js-1.0.so
|
||||
lib/libggadget-js-1.0.so.0
|
||||
%%QT%%lib/libggadget-qt-1.0.a
|
||||
%%QT%%lib/libggadget-qt-1.0.la
|
||||
%%QT%%lib/libggadget-qt-1.0.so
|
||||
%%QT%%lib/libggadget-qt-1.0.so.0
|
||||
libdata/pkgconfig/libggadget-1.0.pc
|
||||
libdata/pkgconfig/libggadget-dbus-1.0.pc
|
||||
libdata/pkgconfig/libggadget-gtk-1.0.pc
|
||||
%%GTK%%libdata/pkgconfig/libggadget-gtk-1.0.pc
|
||||
libdata/pkgconfig/libggadget-js-1.0.pc
|
||||
share/applications/ggl-gtk.desktop
|
||||
%%QT%%libdata/pkgconfig/libggadget-qt-1.0.pc
|
||||
%%GTK%%share/applications/ggl-gtk.desktop
|
||||
%%QT%%share/applications/ggl-qt.desktop
|
||||
%%DATADIR%%/analog_clock.gg
|
||||
%%DATADIR%%/digital_alarm_clock.gg
|
||||
%%DATADIR%%/google-gadget-browser.gg
|
||||
|
@ -176,17 +204,19 @@ share/applications/ggl-gtk.desktop
|
|||
%%DATADIR%%/resources.gg
|
||||
%%DATADIR%%/rss.gg
|
||||
share/mime/packages/00-google-gadgets.xml
|
||||
share/mime/application/x-google-gadgets.xml
|
||||
share/pixmaps/google-gadgets.png
|
||||
@dirrm share/mime/packages
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm lib/google-gadgets/modules
|
||||
@dirrm lib/google-gadgets/include/ggadget
|
||||
@dirrm lib/google-gadgets/include
|
||||
@dirrm lib/google-gadgets
|
||||
%%QT%%@dirrm include/google-gadgets/ggadget/qt
|
||||
@dirrm include/google-gadgets/ggadget/js
|
||||
@dirrm include/google-gadgets/ggadget/gtk
|
||||
%%GTK%%@dirrm include/google-gadgets/ggadget/gtk
|
||||
@dirrm include/google-gadgets/ggadget/dbus
|
||||
@dirrm include/google-gadgets/ggadget
|
||||
@dirrm include/google-gadgets
|
||||
@dirrmtry share/mime/application
|
||||
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
|
||||
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
|
||||
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
|
|
Loading…
Reference in a new issue