astro/py-astlib: Update to 0.11.9
- Convert to USE_PYTHON=pep517 Changes: https://github.com/mattyowl/astLib/releases
This commit is contained in:
parent
5ce890ac98
commit
d37f408537
3 changed files with 30 additions and 6 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= astlib
|
||||
PORTVERSION= 0.11.8
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.11.9
|
||||
CATEGORIES= astro python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -14,6 +13,8 @@ WWW= https://astlib.readthedocs.io/en/latest/ \
|
|||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0.1:math/py-numpy@${PY_FLAVOR} \
|
||||
|
@ -21,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
|
|||
${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
||||
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1661599215
|
||||
SHA256 (astLib-0.11.8.tar.gz) = 2bb3619a71bada2375d5b10ad364a85a0bc631f6580c48537c192b40f70bc5fd
|
||||
SIZE (astLib-0.11.8.tar.gz) = 9913587
|
||||
TIMESTAMP = 1697463070
|
||||
SHA256 (astLib-0.11.9.tar.gz) = b2f9b7be58ffa96fc7876732038694d0faba026a0bf53003ccb0010c0e54feb7
|
||||
SIZE (astLib-0.11.9.tar.gz) = 9917509
|
||||
|
|
23
astro/py-astlib/files/patch-setup.py
Normal file
23
astro/py-astlib/files/patch-setup.py
Normal file
|
@ -0,0 +1,23 @@
|
|||
Reference: https://github.com/mattyowl/astLib/pull/9
|
||||
https://github.com/mattyowl/astLib/commit/6844b308fb9ff1a71486dff98793bfec1ed13349
|
||||
|
||||
--- setup.py.orig 2023-10-12 15:29:16 UTC
|
||||
+++ setup.py
|
||||
@@ -36,7 +36,7 @@ class build_PyWCSTools_ext(build_ext):
|
||||
|
||||
os.chdir(sourceDir)
|
||||
cc=setuptools._distutils.ccompiler.new_compiler(setuptools._distutils.ccompiler.get_default_compiler())
|
||||
- cc.compiler_so=[sysconfig.get_config_var('CC')]+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
|
||||
+ cc.compiler_so=sysconfig.get_config_var('CC').split()+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
|
||||
|
||||
# Suppress warnings from compiling WCSTools wcssubs-3.9.5
|
||||
if "-Wstrict-prototypes" in cc.compiler_so:
|
||||
@@ -55,7 +55,7 @@ class build_PyWCSTools_ext(build_ext):
|
||||
|
||||
build_ext.build_extensions(self)
|
||||
|
||||
-setup(name='astLib',
|
||||
+setup(name='astlib',
|
||||
version='0.11.9',
|
||||
url='https://astlib.readthedocs.io',
|
||||
author='Matt Hilton & Steven Boada',
|
Loading…
Reference in a new issue