Update to version 0.1.3 and use Tcl 8.2.

Submitted by:	Ade Lovett <ade@lovett.com>
This commit is contained in:
Steve Price 1999-11-28 18:09:55 +00:00
parent 01ad77c489
commit d380ccd4c1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23467
4 changed files with 59 additions and 46 deletions

View file

@ -1,12 +1,12 @@
# New ports collection makefile for: gracer
# Version required: 0.1.0
# Version required: 0.1.3
# Date created: Fri Jul 30 20:50:16 MET DST 1999
# Whom: nox@jelal.kn-bremen.de
#
# $FreeBSD$
#
DISTNAME= gracer-0.1.0
DISTNAME= gracer-0.1.3
CATEGORIES= games
MASTER_SITES= http://arch.comp.kyutech.ac.jp/~matsu/my_products/gtk/race/
@ -14,14 +14,15 @@ MAINTAINER= nox@jelal.kn-bremen.de
LIB_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3 \
gif.5:${PORTSDIR}/graphics/giflib \
png.3:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tcl80.1:${PORTSDIR}/lang/tcl80
tcl82.1:${PORTSDIR}/lang/tcl82
# doesn't work, program still looks for its files in /usr/local
#USE_X_PREFIX= yes
USE_AUTOCONF= yes
CFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include -L${LOCALBASE}/lib
CONFIGURE_ENV+= "CPP=cc -E -I${LOCALBASE}/include"
USE_AUTOCONF= YES
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/tcl8.2 \
-I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_GMAKE= yes
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (gracer-0.1.0.tar.gz) = b0850bc93488e0fcb4517a9bb1b41e0f
MD5 (gracer-0.1.3.tar.gz) = 484ff502f483d81f5504768ebb302c62

View file

@ -1,50 +1,33 @@
Index: configure.in
@@ -209,8 +209,8 @@
--- configure.in.orig Thu Oct 21 21:58:10 1999
+++ configure.in Wed Nov 3 16:51:22 1999
@@ -236,7 +236,7 @@
tcl_prefix=$with_tcl)
for tcl_prefix in $tcl_prefix $exec_prefix /usr/local /usr NONE; do
- if test -r $tcl_prefix/lib/tclConfig.sh; then
- AC_MSG_RESULT([use tclConfig.sh in $tcl_prefix/lib])
+ if test -r $tcl_prefix/lib/tcl8.0/tclConfig.sh; then
+ AC_MSG_RESULT([use tclConfig.sh in $tcl_prefix/lib/tcl8.0])
+ if test -r $tcl_prefix/lib/tcl8.2/tclConfig.sh; then
break;
fi
done
@@ -219,29 +219,31 @@
@@ -245,18 +245,18 @@
AC_MSG_ERROR([could't find tclConfig.sh])
fi
-file=${tcl_prefix}/lib/tclConfig.sh
+file=${tcl_prefix}/lib/tcl8.0/tclConfig.sh
+file=${tcl_prefix}/lib/tcl8.2/tclConfig.sh
if test ! -r ${file}; then
AC_MSG_ERROR(tclConfig.sh doesn't exist)
fi
-AC_MSG_RESULT([use tclConfig.sh in $tcl_prefix/lib])
+AC_MSG_RESULT([use tclConfig.sh in $tcl_prefix/lib/tcl8.0])
+AC_MSG_RESULT([use tclConfig.sh in $tcl_prefix/lib/tcl8.2])
. $file
-TCL_CFLAGS="-I$tcl_prefix/include"
+TCL_CFLAGS="-I$tcl_prefix/include/tcl8.0"
TCL_LDFLAGS="$TCL_LIB_SPEC $TCL_LIBS"
if test $TCL_MAJOR_VERSION -lt 8; then
AC_MSG_ERROR([tcl version 8.0 or higher is required.])
fi
-TCL_CFLAGS="-I$TCL_SRC_DIR"
+TCL_CFLAGS="-I$tcl_prefix/lib/tcl8.2"
TCL_LDFLAGS="$TCL_LIB_SPEC"
AC_SUBST(TCL_CFLAGS)
AC_SUBST(TCL_LDFLAGS)
####################################################### Check Graphics library
+x_suffix="$X_LIBS $X_PRE_LIBS -lX11 -lXi -lXext -lXmu $X_EXTRA_LIBS -lm"
+
AC_SUBST(GIF_LIBS)
AC_CHECK_HEADER(gif_lib.h,
AC_CHECK_LIB(ungif, DGifOpenFileHandle,
- GIF_LIBS="-lungif"
+ GIF_LIBS="-lungif",
AC_CHECK_LIB(gif, DGifOpenFileHandle,
GIF_LIBS="-lgif",
AC_MSG_ERROR([GIF library file not found]),
- $GX_LIBS),
- $GX_LIBS),
+ $x_suffix),
+ $x_suffix),
AC_MSG_ERROR([GIF header not found]))
AC_SUBST(JPEG_LIBS)

View file

@ -1,6 +1,12 @@
bin/gracer
share/gracer/courses/course1.grc
share/gracer/courses/course1.grs
share/gracer/courses/course2.grc
share/gracer/courses/course2.grs
share/gracer/courses/course3.grc
share/gracer/courses/course3.grs
share/gracer/courses/course4.grc
share/gracer/courses/course4.grs
share/gracer/courses/grass.jpg
share/gracer/courses/road.jpg
share/gracer/license
@ -12,15 +18,27 @@ share/gracer/scripts/cache.tcl
share/gracer/scripts/glut.tcl
share/gracer/scripts/gr.tcl
share/gracer/scripts/init.tcl
share/gracer/scripts/init.tcl.in
share/gracer/scripts/ui.tcl
share/gracer/scripts/ui.tcl.in
share/gracer/sounds/exhaust.au
share/gracer/vehicles/cart.grv
share/gracer/vehicles/cart/cart.grs
share/gracer/vehicles/cart/engine.dat
share/gracer/vehicles/cart/fbmu.dat
share/gracer/vehicles/cart/ftire.dat
share/gracer/vehicles/cart/rtire.dat
share/gracer/vehicles/formula.grv
share/gracer/vehicles/formula/engine.dat
share/gracer/vehicles/formula/fbmu.dat
share/gracer/vehicles/formula/formula.grs
share/gracer/vehicles/formula/ftire.dat
share/gracer/vehicles/formula/rtire.dat
share/gracer/vehicles/mini.grv
share/gracer/vehicles/mini/engine.dat
share/gracer/vehicles/mini/fbmu.dat
share/gracer/vehicles/mini/ftire.dat
share/gracer/vehicles/mini/mini.grs
share/gracer/vehicles/mini/rtire.dat
share/gracer/vehicles/mini/sbmu.dat
share/gracer/vehicles/road.grv
share/gracer/vehicles/road/engine.dat
share/gracer/vehicles/road/fbmu.dat
@ -28,10 +46,21 @@ share/gracer/vehicles/road/ftire.dat
share/gracer/vehicles/road/road.grs
share/gracer/vehicles/road/rtire.dat
share/gracer/vehicles/road/sbmu.dat
@dirrm share/gracer/courses
@dirrm share/gracer/scenes
@dirrm share/gracer/scripts
@dirrm share/gracer/vehicles/formula
share/gracer/vehicles/s2000.grv
share/gracer/vehicles/s2000/engine.dat
share/gracer/vehicles/s2000/fbmu.dat
share/gracer/vehicles/s2000/ftire.dat
share/gracer/vehicles/s2000/rtire.dat
share/gracer/vehicles/s2000/s2000.grs
share/gracer/vehicles/s2000/sbmu.dat
@dirrm share/gracer/vehicles/s2000
@dirrm share/gracer/vehicles/road
@dirrm share/gracer/vehicles/mini
@dirrm share/gracer/vehicles/formula
@dirrm share/gracer/vehicles/cart
@dirrm share/gracer/vehicles
@dirrm share/gracer/sounds
@dirrm share/gracer/scripts
@dirrm share/gracer/scenes
@dirrm share/gracer/courses
@dirrm share/gracer