o Improve previous fix for building on OSVERSION < 500000: simple

patch instead of USE_GCC=3.4+
o Bump PORTREVISION due to dependency change
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2005-09-13 16:53:25 +00:00
parent 7cced28062
commit d3b1a26146
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=142605
2 changed files with 14 additions and 10 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= normalizemime
PORTVERSION= 1.16.20050628
PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://hyvatti.iki.fi/~jaakko/spam/
DISTNAME= normalizemime.cc
@ -34,10 +35,4 @@ do-build:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME:R} ${PREFIX}/bin
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
USE_GCC=3.4+
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,6 +1,15 @@
--- normalizemime.cc.orig Tue Aug 30 21:31:02 2005
+++ normalizemime.cc Tue Aug 30 21:33:08 2005
@@ -498,7 +498,7 @@
--- normalizemime.cc.orig Tue Sep 13 00:03:52 2005
+++ normalizemime.cc Tue Sep 13 00:04:18 2005
@@ -58,6 +58,8 @@
#include <map>
#include <string>
+#include <sys/types.h>
+
#include <regex.h>
#include <assert.h>
#include <ctype.h>
@@ -498,7 +500,7 @@
char *obuf = buf;
memcpy (icopy, message.c_str(), in_left);
message.erase ();