Upgrade to 0.16 and unbreak on FreeBSD-5.3.

PR:		ports/76738
Submitted by:	maintainer.
This commit is contained in:
Thierry Thomas 2005-02-12 21:11:43 +00:00
parent 1d4a3faf88
commit d409680541
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128630
6 changed files with 41 additions and 2135 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= monotone
PORTVERSION= 0.11
PORTREVISION= 1
PORTVERSION= 0.16
CATEGORIES= devel
MASTER_SITES= http://www.venge.net/monotone/ \
http://norton.kettering.edu/freebsd/
@ -16,7 +15,7 @@ MAINTAINER= mwicks@kettering.edu
COMMENT= A distributed version control system with digital signatures
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
boost_regex.1:${PORTSDIR}/devel/boost
boost_regex.2:${PORTSDIR}/devel/boost
USE_ICONV= yes
.if !defined(WITHOUT_NLS)
@ -30,48 +29,33 @@ LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
PLIST_FILES= bin/depot.cgi bin/monotone
PLIST_FILES= bin/monotone
INFO= monotone
MAN1= monotone.1
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS= --disable-nls
CONFIGURE_ARGS+= --disable-nls
.endif
.if !defined(WITHOUT_ADNS)
LIB_DEPENDS+= adns.1:${PORTSDIR}/dns/adns
.else
CONFIGURE_ARGS= --with-bundled-adns
CONFIGURE_ARGS+= --with-bundled-adns
.endif
.if !defined(WITHOUT_LUA)
LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
.else
CONFIGURE_ARGS= --with-bundled-lua
CONFIGURE_ARGS+= --with-bundled-lua
.endif
.if !defined(WITHOUT_SQLITE)
LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
.else
CONFIGURE_ARGS= --with-bundled-sqlite
CONFIGURE_ARGS+= --with-bundled-sqlite
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if ${OSVERSION} < 500000
BROKEN= "Does not run on FreeBSD-4.x at this time"
BROKEN= "Does not compile on FreeBSD-4.11"
.endif
EXPIRATION_DATE=2005-02-18
DEPRECATED= Does not compile (5.x) or run (4.x)
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
post-patch:
${TOUCH} ${WRKDIR}/${DISTNAME}/configure
${TOUCH} ${WRKDIR}/${DISTNAME}/*.in
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (monotone-0.11.tar.gz) = 126d792c5e9a4387db5f547c33b3fe5a
SIZE (monotone-0.11.tar.gz) = 1861996
MD5 (monotone-0.16.tar.gz) = 66fe3f50a8fe621afc8f355b25201ecb
SIZE (monotone-0.16.tar.gz) = 3438625

View file

@ -1,11 +1,15 @@
--- Makefile.in.orig Mon Mar 1 00:49:43 2004
+++ Makefile.in Sun Mar 21 22:49:58 2004
@@ -1143,7 +1143,7 @@
$(CXXLINK) $(depot_cgi_LDFLAGS) $(depot_cgi_OBJECTS) $(depot_cgi_LDADD) $(LIBS)
--- Makefile.in.orig Fri Dec 31 03:17:42 2004
+++ Makefile.in Wed Jan 26 22:20:17 2005
@@ -1153,10 +1153,10 @@
-test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
monotone$(EXEEXT): $(monotone_OBJECTS) $(monotone_DEPENDENCIES)
@rm -f monotone$(EXEEXT)
- $(CXXLINK) $(monotone_LDFLAGS) $(monotone_OBJECTS) $(monotone_LDADD) $(LIBS)
+ $(CXXLINK) $(monotone_LDFLAGS) $(monotone_OBJECTS) $(monotone_LDADD) $(LIBS) $(LTLIBINTL) $(LTLIBICONV)
+ $(CXXLINK) $(monotone_LDFLAGS) $(monotone_OBJECTS) $(monotone_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
unit_tests$(EXEEXT): $(unit_tests_OBJECTS) $(unit_tests_DEPENDENCIES)
@rm -f unit_tests$(EXEEXT)
$(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS)
- $(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS)
+ $(CXXLINK) $(unit_tests_LDFLAGS) $(unit_tests_OBJECTS) $(unit_tests_LDADD) $(LIBS) $(LIBINTL) $(LIBICONV)
mostlyclean-compile:
-rm -f *.$(OBJEXT)

File diff suppressed because it is too large Load diff

View file

@ -1,14 +1,13 @@
--- monotone.cc.orig Wed Jan 7 13:11:47 2004
+++ monotone.cc Sun Mar 21 22:49:59 2004
@@ -129,8 +129,11 @@
--- monotone.cc.orig Fri Dec 31 03:16:53 2004
+++ monotone.cc Wed Jan 26 22:20:17 2005
@@ -140,8 +140,10 @@
setlocale(LC_CTYPE, "");
setlocale(LC_MESSAGES, "");
+
+#ifdef ENABLE_NLS
bindtextdomain(PACKAGE, LOCALEDIR);
textdomain(PACKAGE);
+#endif
// decode all argv values into a UTF-8 array
L(F("set locale: LC_CTYPE=%s, LC_MESSAGES=%s\n")
% (setlocale(LC_CTYPE, NULL) == NULL ? "n/a" : setlocale(LC_CTYPE, NULL))

View file

@ -1,6 +1,6 @@
--- sanity.hh.orig Wed Jan 7 13:11:48 2004
+++ sanity.hh Sun Mar 21 22:49:59 2004
@@ -58,7 +58,11 @@
--- sanity.hh.orig Fri Dec 31 03:16:54 2004
+++ sanity.hh Wed Jan 26 22:20:17 2005
@@ -64,7 +64,12 @@
extern sanity global_sanity;
// F is for when you want to build a boost formatter
@ -9,6 +9,7 @@
+#else
+#define F(str) boost::format((str))
+#endif
+
// L is for logging, you can log all you want
#define L(fmt) global_sanity.log(fmt)
#define L(fmt) global_sanity.log(fmt, __FILE__, __LINE__)