databases/mysql-connector-c: Update version 6.1.6=>6.1.9
This commit is contained in:
parent
4e02ee6405
commit
d4426ad8fb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435432
6 changed files with 21 additions and 33 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mysql-connector-c
|
||||
PORTVERSION= 6.1.6
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 6.1.9
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= MYSQL/Connector-C
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (mysql-connector-c-6.1.6-src.tar.gz) = 2222433012c415871958b61bc4f3683e1ebe77e3389f698b267058c12533ea78
|
||||
SIZE (mysql-connector-c-6.1.6-src.tar.gz) = 3475044
|
||||
TIMESTAMP = 1488661538
|
||||
SHA256 (mysql-connector-c-6.1.9-src.tar.gz) = 4e808704443365ad5b649673d03eca8fbebc0a4da9f1f96616c6bd1b1901ab2b
|
||||
SIZE (mysql-connector-c-6.1.9-src.tar.gz) = 3494748
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2015-02-25 21:09:49 UTC
|
||||
--- CMakeLists.txt.orig 2017-03-04 21:11:15 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -541,7 +541,7 @@ ADD_SUBDIRECTORY(packaging/WiX)
|
||||
@@ -562,7 +562,7 @@ ADD_SUBDIRECTORY(packaging/WiX)
|
||||
#
|
||||
# RPM installs documentation directly from the source tree
|
||||
#
|
||||
|
|
|
@ -1,24 +1,21 @@
|
|||
--- cmake/ssl.cmake.orig 2015-02-25 21:09:49 UTC
|
||||
--- cmake/ssl.cmake.orig 2017-03-04 21:14:36 UTC
|
||||
+++ cmake/ssl.cmake
|
||||
@@ -166,17 +166,19 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
@@ -166,7 +166,7 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
# Encoded as MNNFFPPS: major minor fix patch status
|
||||
FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
|
||||
OPENSSL_VERSION_NUMBER
|
||||
- REGEX "^#define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
|
||||
- REGEX "^#[ ]*define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
|
||||
+ REGEX "define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
|
||||
)
|
||||
STRING(REGEX REPLACE
|
||||
"^.*OPENSSL_VERSION_NUMBER[\t ]+0x([0-9]).*$" "\\1"
|
||||
OPENSSL_MAJOR_VERSION "${OPENSSL_VERSION_NUMBER}"
|
||||
)
|
||||
|
||||
+ # LibreSSL is allowed too
|
||||
@@ -176,7 +176,8 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
IF(OPENSSL_INCLUDE_DIR AND
|
||||
OPENSSL_LIBRARY AND
|
||||
CRYPTO_LIBRARY AND
|
||||
- OPENSSL_MAJOR_VERSION STREQUAL "1"
|
||||
+ (OPENSSL_MAJOR_VERSION STREQUAL "1" OR
|
||||
+ OPENSSL_MAJOR_VERSION STREQUAL "2")
|
||||
+ OPENSSL_MAJOR_VERSION STREQUAL "2")
|
||||
)
|
||||
SET(OPENSSL_FOUND TRUE)
|
||||
ELSE()
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- vio/viossl.c.orig 2015-06-20 10:21:51 UTC
|
||||
+++ vio/viossl.c
|
||||
@@ -392,8 +392,10 @@ static int ssl_do(struct st_VioSSLFd *pt
|
||||
SSL_SESSION_set_timeout(SSL_get_session(ssl), timeout);
|
||||
SSL_set_fd(ssl, sd);
|
||||
#ifndef HAVE_YASSL
|
||||
+#ifdef SSL_OP_NO_COMPRESSION
|
||||
SSL_set_options(ssl, SSL_OP_NO_COMPRESSION);
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
/*
|
||||
Since yaSSL does not support non-blocking send operations, use
|
|
@ -2,6 +2,7 @@ bin/mysql-connector-c/my_print_defaults
|
|||
bin/mysql-connector-c/mysql_config
|
||||
bin/mysql-connector-c/perror
|
||||
include/mysql-connector-c/big_endian.h
|
||||
include/mysql-connector-c/binary_log_types.h
|
||||
include/mysql-connector-c/byte_order_generic.h
|
||||
include/mysql-connector-c/byte_order_generic_x86.h
|
||||
include/mysql-connector-c/decimal.h
|
||||
|
@ -12,6 +13,7 @@ include/mysql-connector-c/m_ctype.h
|
|||
include/mysql-connector-c/m_string.h
|
||||
include/mysql-connector-c/my_alloc.h
|
||||
include/mysql-connector-c/my_byteorder.h
|
||||
include/mysql-connector-c/my_command.h
|
||||
include/mysql-connector-c/my_compiler.h
|
||||
include/mysql-connector-c/my_config.h
|
||||
include/mysql-connector-c/my_dbug.h
|
||||
|
@ -19,14 +21,16 @@ include/mysql-connector-c/my_dir.h
|
|||
include/mysql-connector-c/my_getopt.h
|
||||
include/mysql-connector-c/my_global.h
|
||||
include/mysql-connector-c/my_list.h
|
||||
include/mysql-connector-c/my_pthread.h
|
||||
include/mysql-connector-c/my_sys.h
|
||||
include/mysql-connector-c/my_thread.h
|
||||
include/mysql-connector-c/my_thread_local.h
|
||||
include/mysql-connector-c/my_xml.h
|
||||
include/mysql-connector-c/mysql.h
|
||||
include/mysql-connector-c/mysql/client_authentication.h
|
||||
include/mysql-connector-c/mysql/client_plugin.h
|
||||
include/mysql-connector-c/mysql/client_plugin.h.pp
|
||||
include/mysql-connector-c/mysql/get_password.h
|
||||
include/mysql-connector-c/mysql/mysql_lex_string.h
|
||||
include/mysql-connector-c/mysql/plugin_auth_common.h
|
||||
include/mysql-connector-c/mysql/plugin_trace.h
|
||||
include/mysql-connector-c/mysql/psi/mysql_file.h
|
||||
|
@ -58,10 +62,10 @@ include/mysql-connector-c/sql_state.h
|
|||
include/mysql-connector-c/sslopt-case.h
|
||||
include/mysql-connector-c/sslopt-longopts.h
|
||||
include/mysql-connector-c/sslopt-vars.h
|
||||
include/mysql-connector-c/thr_cond.h
|
||||
include/mysql-connector-c/thr_mutex.h
|
||||
include/mysql-connector-c/thr_rwlock.h
|
||||
include/mysql-connector-c/typelib.h
|
||||
lib/mysql-connector-c/libmysqlclient.a
|
||||
lib/mysql-connector-c/libmysqlclient.so
|
||||
lib/mysql-connector-c/libmysqlclient.so.18
|
||||
lib/mysql-connector-c/libmysqlclient_r.a
|
||||
lib/mysql-connector-c/libmysqlclient_r.so
|
||||
lib/mysql-connector-c/libmysqlclient_r.so.18
|
||||
|
|
Loading…
Reference in a new issue