multimedia/kodi: regen patch-configure.ac
- Add atomic lib to search libs, resolve 9.3 i386 build issue - Bump PORTREVISION due to libatomic shlib dependency PR: 202812 Submitted by: mickael.maillot@gmail.com (maintainer) MFH: 2015Q3 X-MFH-With: r397342, r397605, r397613
This commit is contained in:
parent
1eae21323d
commit
d45e9d1d3f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=397820
2 changed files with 18 additions and 11 deletions
|
@ -2,6 +2,7 @@
|
|||
|
||||
PORTNAME= kodi
|
||||
DISTVERSION= 15.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia java
|
||||
MASTER_SITES= https://codeload.github.com/xbmc/xbmc/tar.gz/${KODI_COMMIT}?dummy=/ \
|
||||
GH:ffmpeg
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- configure.ac.orig 2015-03-31 16:37:07 UTC
|
||||
--- configure.ac.orig 2015-08-16 14:37:32 UTC
|
||||
+++ configure.ac
|
||||
@@ -636,10 +636,12 @@
|
||||
i386-*-freebsd*)
|
||||
|
@ -13,7 +13,7 @@
|
|||
;;
|
||||
arm-apple-darwin*)
|
||||
use_joystick=no
|
||||
@@ -808,10 +810,16 @@
|
||||
@@ -824,10 +826,16 @@
|
||||
# platform specific flags
|
||||
if echo "$ARCH" | grep -q "freebsd" ; then
|
||||
LOCALBASE="${LOCALBASE:-/usr/local}"
|
||||
|
@ -33,7 +33,7 @@
|
|||
fi
|
||||
if test "$host_vendor" = "apple" ; then
|
||||
# standard application paths
|
||||
@@ -944,6 +952,7 @@
|
||||
@@ -960,6 +968,7 @@
|
||||
|
||||
# Check inotify availability
|
||||
AC_CHECK_HEADER([sys/inotify.h], AC_DEFINE([HAVE_INOTIFY],[1],[Define if we have inotify]),)
|
||||
|
@ -41,7 +41,7 @@
|
|||
|
||||
# Checks for boost headers using CXX instead of CC
|
||||
AC_LANG_PUSH([C++])
|
||||
@@ -1240,7 +1249,7 @@
|
||||
@@ -1257,12 +1266,13 @@
|
||||
)
|
||||
|
||||
#Check to see if libs are needed for functions that are often built-in to libc
|
||||
|
@ -50,7 +50,13 @@
|
|||
AC_SEARCH_LIBS([dlopen],dl)
|
||||
AC_SEARCH_LIBS([clock_gettime],rt)
|
||||
AC_SEARCH_LIBS([dn_expand], resolv)
|
||||
@@ -1740,7 +1749,7 @@
|
||||
AC_SEARCH_LIBS([_dn_expand], resolv)
|
||||
AC_SEARCH_LIBS([__dn_expand],resolv)
|
||||
+AC_SEARCH_LIBS([__atomic_load_8], [atomic])
|
||||
|
||||
# platform dependent libraries
|
||||
if test "$host_vendor" = "apple" ; then
|
||||
@@ -1727,7 +1737,7 @@
|
||||
|
||||
if test "$cross_compiling" != "yes"; then
|
||||
if test "$use_debug" != "yes"; then
|
||||
|
@ -59,7 +65,7 @@
|
|||
fi
|
||||
if test "$use_optimizations" != "yes"; then
|
||||
FFMPEG_OPTS="${FFMPEG_OPTS} --disable-optimizations"
|
||||
@@ -1751,7 +1760,7 @@
|
||||
@@ -1738,7 +1748,7 @@
|
||||
SAVE_LIBS="$LIBS"
|
||||
# check for system installed ffmpeg. We require minimum versions.
|
||||
PKG_CHECK_MODULES([FFMPEG], [$FFMPEG_LIBNAMES],
|
||||
|
@ -68,7 +74,7 @@
|
|||
[FFMPEG_FOUND="false"])
|
||||
|
||||
if test "${USE_STATIC_FFMPEG}" = "1" && test "$FFMPEG_FOUND" = "true"; then
|
||||
@@ -1778,7 +1787,7 @@
|
||||
@@ -1765,7 +1775,7 @@
|
||||
elif test "$with_ffmpeg" = "force"; then
|
||||
# always build our ffmpeg
|
||||
AC_MSG_NOTICE("FFmpeg installation forced by user - installing our version")
|
||||
|
@ -77,7 +83,7 @@
|
|||
export PKG_CONFIG_PATH="${ffmpeg_build}/ffmpeg-install/lib/pkgconfig:$PKG_CONFIG_PATH"
|
||||
|
||||
elif test "$with_ffmpeg" != "no"; then
|
||||
@@ -1791,7 +1800,7 @@
|
||||
@@ -1778,7 +1788,7 @@
|
||||
|
||||
if test "$FFMPEG_FOUND" != "true"; then
|
||||
PKG_CHECK_MODULES([FFMPEG], [$FFMPEG_LIBNAMES],
|
||||
|
@ -86,7 +92,7 @@
|
|||
[AC_MSG_ERROR("ffmpeg not found")])
|
||||
fi
|
||||
|
||||
@@ -2204,7 +2213,7 @@
|
||||
@@ -2173,7 +2183,7 @@
|
||||
# we don't compile with default upstream squish, so we use our own one
|
||||
# even on non unified deps platforms
|
||||
if test "$cross_compiling" != "yes"; then
|
||||
|
@ -95,7 +101,7 @@
|
|||
export PKG_CONFIG_PATH="${abs_top_srcdir}/tools/depends/native/libsquish-native/squish-install/lib/pkgconfig:$PKG_CONFIG_PATH"
|
||||
fi
|
||||
PKG_CHECK_MODULES([SQUISH], [squish],
|
||||
@@ -2215,7 +2224,7 @@
|
||||
@@ -2184,7 +2194,7 @@
|
||||
AC_PATH_PROG([TEXTUREPACKER], [TexturePacker], ["none"],
|
||||
[$PATH$PATH_SEPARATOR${abs_top_srcdir}/tools/depends/native/TexturePacker/bin])
|
||||
if test "$TEXTUREPACKER" = "none"; then
|
||||
|
@ -104,7 +110,7 @@
|
|||
TEXTUREPACKER="${abs_top_srcdir}/tools/depends/native/TexturePacker/bin/TexturePacker"
|
||||
fi
|
||||
if test -x "$TEXTUREPACKER"; then
|
||||
@@ -2479,6 +2488,8 @@
|
||||
@@ -2448,6 +2458,8 @@
|
||||
LIBS="$LIBS -L\$(abs_top_srcdir)/lib/ffmpeg/libswscale -lswscale"
|
||||
fi
|
||||
|
||||
|
|
Loading…
Reference in a new issue