The LIBMAA library provides many low-level data structures which are
helpful for writing compilers, including hash tables, sets, lists, debugging support, and memory management. Although LIBMAA was designed and implemented as a foundation for the Khepera Transformation System, the data structures are generally applicable to a wide range of programming problems. The memory management routines are especially helpful for improving the performance of memory-intensive applications. WWW: http://www.dict.org/
This commit is contained in:
parent
eda9d1c2b5
commit
d49664bae7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206225
7 changed files with 86 additions and 0 deletions
|
@ -611,6 +611,7 @@
|
|||
SUBDIR += libleaftag
|
||||
SUBDIR += liblogging
|
||||
SUBDIR += libltdl15
|
||||
SUBDIR += libmaa
|
||||
SUBDIR += libmatheval
|
||||
SUBDIR += libmba
|
||||
SUBDIR += libmcs
|
||||
|
|
39
devel/libmaa/Makefile
Normal file
39
devel/libmaa/Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
# Ports collection makefile for: libmaa
|
||||
# Date created: 2008/01/26
|
||||
# Whom: chinsan
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libmaa
|
||||
PORTVERSION= 1.10.10
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= dict
|
||||
DISTNAME= dictd-${PORTVERSION}
|
||||
|
||||
MAINTAINER= chinsan@FreeBSD.org
|
||||
COMMENT= Provides a few data structures and helpful functions
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-local-zlib --with-cflags="${CFLAGS}" \
|
||||
--with-etcdir=${PREFIX}/etc
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/dictd-${PORTVERSION}/libmaa
|
||||
ALL_TARGET= lib
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in COPYING.LIB README
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/libmaa.600dpi.ps ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/libmaa/distinfo
Normal file
3
devel/libmaa/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (dictd-1.10.10.tar.gz) = 9698b15af5919bd1c930978774310fc4
|
||||
SHA256 (dictd-1.10.10.tar.gz) = 0ec57fb93665ae539a1a12541266ca283dfa20b3597127b53de29e668fd28870
|
||||
SIZE (dictd-1.10.10.tar.gz) = 693972
|
11
devel/libmaa/files/patch-getopt.c
Normal file
11
devel/libmaa/files/patch-getopt.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- getopt.c.orig 2008-01-26 13:11:10.000000000 +0800
|
||||
+++ getopt.c 2008-01-26 13:14:27.000000000 +0800
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc) && !defined(__FreeBSD__)
|
||||
extern int fprintf( FILE *, const char *, ... );
|
||||
extern int strncmp( const char *, const char *, int n );
|
||||
#endif
|
11
devel/libmaa/files/patch-strtol.c
Normal file
11
devel/libmaa/files/patch-strtol.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- strtol.c.orig 1995-08-25 12:59:08.000000000 +0800
|
||||
+++ strtol.c 2008-01-26 13:15:27.000000000 +0800
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc) && !defined(__FreeBSD__)
|
||||
extern int errno;
|
||||
extern int toupper(int);
|
||||
#endif
|
11
devel/libmaa/pkg-descr
Normal file
11
devel/libmaa/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
The LIBMAA library provides many low-level data structures which are
|
||||
helpful for writing compilers, including hash tables, sets, lists,
|
||||
debugging support, and memory management. Although LIBMAA was
|
||||
designed and implemented as a foundation for the Khepera
|
||||
Transformation System, the data structures are generally applicable to
|
||||
a wide range of programming problems.
|
||||
|
||||
The memory management routines are especially helpful for improving the
|
||||
performance of memory-intensive applications.
|
||||
|
||||
WWW: http://www.dict.org/
|
10
devel/libmaa/pkg-plist
Normal file
10
devel/libmaa/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $FreeBSD$
|
||||
include/maa.h
|
||||
lib/libmaa.la
|
||||
lib/libmaa.so.1
|
||||
lib/libmaa.so
|
||||
lib/libmaa.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LIB
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libmaa.600dpi.ps
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue