Update to 2.3.15.
This commit is contained in:
parent
9c0c476da8
commit
d4c121b709
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=191527
5 changed files with 61 additions and 16 deletions
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= balsa
|
||||
PORTVERSION= 2.3.14
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.3.15
|
||||
CATEGORIES= mail gnome
|
||||
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
|
||||
DISTNAME= balsa-${PORTVERSION}
|
||||
|
@ -28,8 +27,8 @@ INSTALLS_OMF= yes
|
|||
INSTALLS_ICONS= yes
|
||||
USE_PERL5= yes
|
||||
USE_OPENSSL= yes
|
||||
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libgnomeprintui \
|
||||
gtkhtml3
|
||||
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui gtkhtml3 \
|
||||
libgnomeprintui
|
||||
USE_GETTEXT= yes
|
||||
USE_AUTOTOOLS= libltdl:15
|
||||
USE_GCC= 3.4+
|
||||
|
@ -41,12 +40,13 @@ CONFIGURE_ARGS= --enable-threads \
|
|||
--with-ssl \
|
||||
--enable-gtkhtml=yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LIBS="-L${LOCALBASE}/lib -liconv"
|
||||
LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
|
||||
|
||||
MAN1= balsa.1
|
||||
|
||||
OPTIONS= LDAP "Enable LDAP support" on \
|
||||
GTKSPELL "Spell checking support" on \
|
||||
GTKSV "Enable GtkSourceview support" on \
|
||||
GPG "Enable GnuPG support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -66,6 +66,11 @@ LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
|
|||
CONFIGURE_ARGS+=--with-gtkspell
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GTKSV)
|
||||
USE_GNOME+= gtksourceview
|
||||
CONFIGURE_ARGS+=--with-gtksourceview
|
||||
.endif
|
||||
|
||||
.if ${PREFIX}==${LOCALBASE}
|
||||
PLIST_SUB+= GTKICON="@comment "
|
||||
.else
|
||||
|
@ -77,8 +82,7 @@ post-patch:
|
|||
${WRKSRC}/libbalsa/mailbox_imap.c
|
||||
# PREFIX safeness
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's|^(HICOLOR_ICON_DIR)[^/]+/|\1=${PREFIX}/| ; \
|
||||
s|libgtkhtml-3.8|libgtkhtml-3.14|g' \
|
||||
-e 's|^(HICOLOR_ICON_DIR)[^/]+/|\1=${PREFIX}/|' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (balsa-2.3.14.tar.bz2) = 6a86f8bebc21bd279b9fd4d2a21a36c0
|
||||
SHA256 (balsa-2.3.14.tar.bz2) = aecb8262a33e17ddba99a0171bc9595008e584fd0eb4dc2bff4e36a3b43503fb
|
||||
SIZE (balsa-2.3.14.tar.bz2) = 2372012
|
||||
MD5 (balsa-2.3.15.tar.bz2) = 1f38726db84fb5a9b2e8bdfa3e11baf0
|
||||
SHA256 (balsa-2.3.15.tar.bz2) = 835e154f03ea6556c81cd5d408c4dd070e7658214f7c78e9eed0f7fa7fb42f6d
|
||||
SIZE (balsa-2.3.15.tar.bz2) = 2534332
|
||||
|
|
|
@ -1,6 +1,24 @@
|
|||
--- configure.orig Sat Mar 19 14:39:26 2005
|
||||
+++ configure Sat Mar 19 14:40:24 2005
|
||||
@@ -21821,7 +21821,7 @@
|
||||
--- configure.orig Thu May 3 23:07:19 2007
|
||||
+++ configure Thu May 3 23:10:58 2007
|
||||
@@ -6120,7 +6120,7 @@ cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_GTK_PRINT 1
|
||||
_ACEOF
|
||||
|
||||
- gnome_print_extras=""
|
||||
+ #gnome_print_extras=""
|
||||
else
|
||||
gnome_print_extras="libgnomeprint-2.2 >= 2.1.4 libgnomeprintui-2.2 >= 2.1.4"
|
||||
fi
|
||||
@@ -6732,7 +6732,7 @@ if eval "test \"\${$as_ac_Lib+set}\" = s
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lgtkhtml-$i $LIBS"
|
||||
+LIBS="-lgtkhtml-$i $HTML_LIBS $LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -7008,7 +7008,7 @@ if test "${ac_cv_lib_ldap_ldap_search+se
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
|
@ -9,7 +27,7 @@
|
|||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -21885,7 +21885,7 @@
|
||||
@@ -7072,7 +7072,7 @@ cat >>confdefs.h <<\_ACEOF
|
||||
#define ENABLE_LDAP 1
|
||||
_ACEOF
|
||||
|
||||
|
@ -18,7 +36,7 @@
|
|||
else
|
||||
{ { echo "$as_me:$LINENO: error: *** You enabled LDAP but ldap library is not found." >&5
|
||||
echo "$as_me: error: *** You enabled LDAP but ldap library is not found." >&2;}
|
||||
@@ -22664,13 +22664,13 @@
|
||||
@@ -8735,13 +8735,13 @@ _ACEOF
|
||||
else
|
||||
|
||||
|
||||
|
@ -36,7 +54,7 @@
|
|||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -22684,11 +22684,11 @@
|
||||
@@ -8755,11 +8755,11 @@ extern "C"
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
|
|
17
mail/balsa/files/patch-src_print-gtk.c
Normal file
17
mail/balsa/files/patch-src_print-gtk.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- src/print-gtk.c.orig Thu May 3 22:59:46 2007
|
||||
+++ src/print-gtk.c Thu May 3 23:01:30 2007
|
||||
@@ -378,12 +378,14 @@ get_default_user_units(void)
|
||||
gchar *e = _("default:mm");
|
||||
|
||||
#ifdef HAVE_LANGINFO
|
||||
+#ifdef _NL_MEASUREMENT_MEASUREMENT
|
||||
gchar *imperial = NULL;
|
||||
|
||||
imperial = nl_langinfo(_NL_MEASUREMENT_MEASUREMENT);
|
||||
if (imperial && imperial[0] == 2 )
|
||||
return GTK_UNIT_INCH; /* imperial */
|
||||
if (imperial && imperial[0] == 1 )
|
||||
+#endif
|
||||
return GTK_UNIT_MM; /* metric */
|
||||
#endif
|
||||
|
|
@ -93,6 +93,7 @@ share/locale/ca/LC_MESSAGES/balsa.mo
|
|||
share/locale/cs/LC_MESSAGES/balsa.mo
|
||||
share/locale/da/LC_MESSAGES/balsa.mo
|
||||
share/locale/de/LC_MESSAGES/balsa.mo
|
||||
share/locale/dz/LC_MESSAGES/balsa.mo
|
||||
share/locale/el/LC_MESSAGES/balsa.mo
|
||||
share/locale/en_CA/LC_MESSAGES/balsa.mo
|
||||
share/locale/en_GB/LC_MESSAGES/balsa.mo
|
||||
|
@ -117,6 +118,7 @@ share/locale/nb/LC_MESSAGES/balsa.mo
|
|||
share/locale/ne/LC_MESSAGES/balsa.mo
|
||||
share/locale/nl/LC_MESSAGES/balsa.mo
|
||||
share/locale/nn/LC_MESSAGES/balsa.mo
|
||||
share/locale/oc/LC_MESSAGES/balsa.mo
|
||||
share/locale/pa/LC_MESSAGES/balsa.mo
|
||||
share/locale/pl/LC_MESSAGES/balsa.mo
|
||||
share/locale/pt/LC_MESSAGES/balsa.mo
|
||||
|
@ -172,6 +174,8 @@ share/locale/zh_TW/LC_MESSAGES/balsa.mo
|
|||
@dirrmtry share/locale/pt
|
||||
@dirrmtry share/locale/pl/LC_MESSAGES
|
||||
@dirrmtry share/locale/pl
|
||||
@dirrmtry share/locale/oc/LC_MESSAGES
|
||||
@dirrmtry share/locale/oc
|
||||
@dirrmtry share/locale/nn/LC_MESSAGES
|
||||
@dirrmtry share/locale/nn
|
||||
@dirrmtry share/locale/ne/LC_MESSAGES
|
||||
|
@ -182,6 +186,8 @@ share/locale/zh_TW/LC_MESSAGES/balsa.mo
|
|||
@dirrmtry share/locale/fi
|
||||
@dirrmtry share/locale/el/LC_MESSAGES
|
||||
@dirrmtry share/locale/el
|
||||
@dirrmtry share/locale/dz/LC_MESSAGES
|
||||
@dirrmtry share/locale/dz
|
||||
@dirrmtry share/locale/cs/LC_MESSAGES
|
||||
@dirrmtry share/locale/cs
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
|
|
Loading…
Reference in a new issue