Update to 1.12.0

With hat:	puppet
This commit is contained in:
Romain Tartière 2019-04-24 02:06:04 +00:00
parent 43ebd1b5ad
commit d4d4295933
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=499803
7 changed files with 7 additions and 95 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= augeas
PORTVERSION= 1.11.0
PORTREVISION= 2
PORTVERSION= 1.12.0
CATEGORIES= textproc
MASTER_SITES= http://download.augeas.net/
@ -15,7 +14,7 @@ LICENSE= LGPL21
TEST_DEPENDS= bash:shells/bash \
gsed:textproc/gsed
USES= autoreconf cpe gmake libtool pathfix pkgconfig readline
USES= autoreconf cpe gmake gnome libtool pathfix pkgconfig readline
USE_GNOME= libxml2
USE_LDCONFIG= yes

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1535439731
SHA256 (augeas-1.11.0.tar.gz) = 393ce8f4055af89cd4c20bf903eacbbd909cf427891f41b56dc2ba66243ea0b0
SIZE (augeas-1.11.0.tar.gz) = 2393675
TIMESTAMP = 1555260791
SHA256 (augeas-1.12.0.tar.gz) = 321942c9cc32185e2e9cb72d0a70eea106635b50269075aca6714e3ec282cb87
SIZE (augeas-1.12.0.tar.gz) = 2429279

View file

@ -1,11 +0,0 @@
--- gnulib/lib/Makefile.am.orig 2015-05-24 00:50:24 UTC
+++ gnulib/lib/Makefile.am
@@ -463,7 +463,7 @@ install-exec-localcharset: all-local
case '$(host_os)' in \
darwin[56]*) \
need_charset_alias=true ;; \
- darwin* | cygwin* | mingw* | pw32* | cegcc*) \
+ darwin* | cygwin* | mingw* | pw32* | cegcc* | freebsd*) \
need_charset_alias=false ;; \
*) \
need_charset_alias=true ;; \

View file

@ -1,26 +0,0 @@
--- lenses/syslog.aug.orig 2018-08-10 20:17:35 UTC
+++ lenses/syslog.aug
@@ -221,7 +221,7 @@ module Syslog =
(* View: entries
entries are either comments/empty lines or entries
*)
- let entries = (empty | comment | entry)*
+ let entries = (empty | comment | entry )*
(* Group: Program matching *)
@@ -253,10 +253,13 @@ module Syslog =
(* Group: Top of the tree *)
+ let include =
+ [ key "include" . sep_tab . store file_r . eol ]
+
(* View: lns
generic entries then programs or hostnames matching blocs
*)
- let lns = entries . ( program | hostname )*
+ let lns = entries . ( program | hostname | include )*
(* Variable: filter
all you need is /etc/syslog.conf

View file

@ -1,9 +0,0 @@
--- lenses/tests/test_syslog.aug.orig 2018-08-10 20:17:35 UTC
+++ lenses/tests/test_syslog.aug
@@ -351,3 +351,6 @@ daemon.info
(* allow space before comments *)
test Syslog.lns get " \t# space comment\n" =
{ "#comment" = "space comment" }
+
+ test Syslog.lns get "include /etc/syslog.d\n" =
+ { "include" = "/etc/syslog.d" }

View file

@ -1,41 +0,0 @@
--- tests/root/etc/syslog.conf.orig 2018-10-25 13:34:21 UTC
+++ tests/root/etc/syslog.conf
@@ -0,0 +1,38 @@
+# $FreeBSD$
+#
+# Spaces ARE valid field separators in this file. However,
+# other *nix-like systems still insist on using tabs as field
+# separators. If you are sharing this file between systems, you
+# may want to use only tabs as field separators here.
+# Consult the syslog.conf(5) manpage.
+*.err;kern.warning;auth.notice;mail.crit /dev/console
+*.notice;authpriv.none;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
+security.* /var/log/security
+auth.info;authpriv.info /var/log/auth.log
+mail.info /var/log/maillog
+lpr.info /var/log/lpd-errs
+ftp.info /var/log/xferlog
+cron.* /var/log/cron
+!-devd
+*.=debug /var/log/debug.log
+*.emerg *
+# uncomment this to log all writes to /dev/console to /var/log/console.log
+# touch /var/log/console.log and chmod it to mode 600 before it will work
+#console.info /var/log/console.log
+# uncomment this to enable logging of all log messages to /var/log/all.log
+# touch /var/log/all.log and chmod it to mode 600 before it will work
+#*.* /var/log/all.log
+# uncomment this to enable logging to a remote loghost named loghost
+#*.* @loghost
+# uncomment these if you're running inn
+# news.crit /var/log/news/news.crit
+# news.err /var/log/news/news.err
+# news.notice /var/log/news/news.notice
+# Uncomment this if you wish to see messages produced by devd
+# !devd
+# *.>=notice /var/log/devd.log
+!ppp
+*.* /var/log/ppp.log
+!*
+include /etc/syslog.d
+include /usr/local/etc/syslog.d

View file

@ -7,11 +7,11 @@ include/fa.h
lib/libaugeas.a
lib/libaugeas.so
lib/libaugeas.so.0
lib/libaugeas.so.0.24.1
lib/libaugeas.so.0.24.2
lib/libfa.a
lib/libfa.so
lib/libfa.so.1
lib/libfa.so.1.5.2
lib/libfa.so.1.5.3
libdata/pkgconfig/augeas.pc
man/man1/augmatch.1.gz
man/man1/augparse.1.gz