multimedia/libgav1: Sync -std= with devel/abseil to match ABI
PR: 250376 Approved by: jbeich
This commit is contained in:
parent
63d746c7ca
commit
d51c9acbfd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559624
2 changed files with 14 additions and 1 deletions
|
@ -3,6 +3,7 @@
|
|||
PORTNAME= libgav1
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.16.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
|
@ -12,7 +13,7 @@ LICENSE= APACHE20
|
|||
|
||||
LIB_DEPENDS= libabsl_synchronization.so:devel/abseil
|
||||
|
||||
USES= cmake compiler:c++11-lib localbase:ldflags
|
||||
USES= cmake compiler:c++17-lang localbase:ldflags
|
||||
USE_GITHUB= yes
|
||||
USE_LDCONFIG= yes
|
||||
GH_ACCOUNT= jbeich # mirror
|
||||
|
|
|
@ -1,7 +1,19 @@
|
|||
- Sync -std= with devel/abseil to match ABI
|
||||
- Avoid leaking abseil dependency to shared library consumers
|
||||
|
||||
--- CMakeLists.txt.orig 2020-07-15 02:27:54 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -16,8 +16,8 @@
|
||||
cmake_minimum_required(VERSION 3.7.1 FATAL_ERROR)
|
||||
|
||||
# libgav1 requires C++11.
|
||||
-set(CMAKE_CXX_STANDARD 11)
|
||||
-set(ABSL_CXX_STANDARD 11)
|
||||
+set(CMAKE_CXX_STANDARD 17)
|
||||
+set(ABSL_CXX_STANDARD 17)
|
||||
|
||||
project(libgav1 CXX)
|
||||
|
||||
@@ -107,8 +107,11 @@ if(NOT "${LIBGAV1_EXE_LINKER_FLAGS}" STREQUAL "")
|
||||
separate_arguments(LIBGAV1_EXE_LINKER_FLAGS)
|
||||
endif()
|
||||
|
|
Loading…
Reference in a new issue