Add New Port: security/hping

Network auditing tool

PR:		21933
Submitted by:	Roman Shterenzon <roman@xpert.com>
This commit is contained in:
James E. Housley 2000-10-28 01:57:17 +00:00
parent 135c022c7c
commit d556cdb473
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34329
17 changed files with 191 additions and 0 deletions

25
net/hping/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: hping
# Date Created: 5 Oct 2000
# Whom: Roman Shterenzon <roman@xpert.com>
#
# $FreeBSD$
#
PORTNAME= hping
PORTVERSION= 2b54
CATEGORIES= security net
MASTER_SITES= http://www.kyuzz.org/antirez/hping2-src/
DISTNAME= hping2-beta54
MAINTAINER= roman@xpert.com
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
MAN8= hping.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
.include <bsd.port.mk>

1
net/hping/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (hping2-beta54.tar.gz) = 703f2102b948f214d59d89b41bca9923

22
net/hping/files/patch-aa Normal file
View file

@ -0,0 +1,22 @@
--- configure.orig Thu Jul 6 20:06:10 2000
+++ configure Thu Oct 5 15:33:45 2000
@@ -65,8 +65,8 @@
;;
*"--force-libpcap")
FORCE_LIBPCAP="-DFORCE_LIBPCAP"
- PCAP="PCAP=libpcap/libpcap.a"
- PCAP_INCLUDE="-I./libpcap"
+ PCAP="PCAP=-lpcap"
+ PCAP_INCLUDE=""
;;
*"--dont-use-proc")
HAVE_PROC=""
@@ -92,7 +92,7 @@
-e s/@FORCE_LIBPCAP@/"$FORCE_LIBPCAP"/g \
-e s/@HAVE_PROC@/"$HAVE_PROC"/g \
-e s^@PCAP@^"$PCAP"^g \
- -e s^@PCAP_INCLUDE@^"$PCAP_INCLUDE$"^g \
+ -e s^@PCAP_INCLUDE@^"$PCAP_INCLUDE"^g \
-e s^@MANPATH@^"$INSTALL_MANPATH"^g \
> Makefile

13
net/hping/files/patch-ab Normal file
View file

@ -0,0 +1,13 @@
--- Makefile.in.orig Thu Oct 5 15:22:25 2000
+++ Makefile.in Thu Oct 5 15:25:28 2000
@@ -6,8 +6,8 @@
# $date: Sun Jul 25 17:56:15 MET DST 1999$
# $rev: 3$
-CC= gcc
-CCOPT= -O2 -Wall @PCAP_INCLUDE@
+CC?= gcc
+CCOPT= $(CFLAGS) -Wall @PCAP_INCLUDE@
DEBUG= -g
#uncomment the following if you need libpcap based build under linux
#(not raccomanded)

10
net/hping/files/patch-ac Normal file
View file

@ -0,0 +1,10 @@
--- getlhs.c.orig Thu Oct 5 15:26:31 2000
+++ getlhs.c Thu Oct 5 15:26:26 2000
@@ -73,6 +73,7 @@
else if ( strstr(ifname, "eth") /* ? */
|| strstr(ifname, "ed")
|| strstr(ifname, "ne")
+ || strstr(ifname, "xe") /* Xircom */
|| strstr(ifname, "xl") /* 3com */
|| strstr(ifname, "vx") /* 3com (older model) */
|| strstr(ifname, "ep") /* 3com 3c589 */

1
net/hping/pkg-comment Normal file
View file

@ -0,0 +1 @@
Network auditing tool

22
net/hping/pkg-descr Normal file
View file

@ -0,0 +1,22 @@
hping2 is a network tool able to send custom ICMP/UDP/TCP
packets and to display target replies like ping do with
ICMP replies. hping2 handle fragmentation, arbitrary packet
body and size and can be used in order to transfer files
under supported protocols. Using hping2 you are able at
least to perform the following jobs:
- Test firewall rules
- [spoofed] port scanning
- Test net performance using different protocols,
packet size, TOS (type of service) and fragmentation.
- Path MTU discovery
- Files transfering even between really fascist firewall rules.
- Traceroute like under different protocols.
- Firewalk like usage.
- Remote OS fingerprint.
- TCP/IP stack auditing.
- A lot of others.
WWW: http://www.kyuzz.org/antirez/hping/
-- Roman Shterenzon <roman@xpert.com>

1
net/hping/pkg-plist Normal file
View file

@ -0,0 +1 @@
sbin/hping

View file

@ -31,6 +31,7 @@
SUBDIR += gpasman
SUBDIR += gtkportscan
SUBDIR += heimdal
SUBDIR += hping
SUBDIR += ident2
SUBDIR += identify
SUBDIR += inflex

25
security/hping/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: hping
# Date Created: 5 Oct 2000
# Whom: Roman Shterenzon <roman@xpert.com>
#
# $FreeBSD$
#
PORTNAME= hping
PORTVERSION= 2b54
CATEGORIES= security net
MASTER_SITES= http://www.kyuzz.org/antirez/hping2-src/
DISTNAME= hping2-beta54
MAINTAINER= roman@xpert.com
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
MAN8= hping.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
.include <bsd.port.mk>

1
security/hping/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (hping2-beta54.tar.gz) = 703f2102b948f214d59d89b41bca9923

View file

@ -0,0 +1,22 @@
--- configure.orig Thu Jul 6 20:06:10 2000
+++ configure Thu Oct 5 15:33:45 2000
@@ -65,8 +65,8 @@
;;
*"--force-libpcap")
FORCE_LIBPCAP="-DFORCE_LIBPCAP"
- PCAP="PCAP=libpcap/libpcap.a"
- PCAP_INCLUDE="-I./libpcap"
+ PCAP="PCAP=-lpcap"
+ PCAP_INCLUDE=""
;;
*"--dont-use-proc")
HAVE_PROC=""
@@ -92,7 +92,7 @@
-e s/@FORCE_LIBPCAP@/"$FORCE_LIBPCAP"/g \
-e s/@HAVE_PROC@/"$HAVE_PROC"/g \
-e s^@PCAP@^"$PCAP"^g \
- -e s^@PCAP_INCLUDE@^"$PCAP_INCLUDE$"^g \
+ -e s^@PCAP_INCLUDE@^"$PCAP_INCLUDE"^g \
-e s^@MANPATH@^"$INSTALL_MANPATH"^g \
> Makefile

View file

@ -0,0 +1,13 @@
--- Makefile.in.orig Thu Oct 5 15:22:25 2000
+++ Makefile.in Thu Oct 5 15:25:28 2000
@@ -6,8 +6,8 @@
# $date: Sun Jul 25 17:56:15 MET DST 1999$
# $rev: 3$
-CC= gcc
-CCOPT= -O2 -Wall @PCAP_INCLUDE@
+CC?= gcc
+CCOPT= $(CFLAGS) -Wall @PCAP_INCLUDE@
DEBUG= -g
#uncomment the following if you need libpcap based build under linux
#(not raccomanded)

View file

@ -0,0 +1,10 @@
--- getlhs.c.orig Thu Oct 5 15:26:31 2000
+++ getlhs.c Thu Oct 5 15:26:26 2000
@@ -73,6 +73,7 @@
else if ( strstr(ifname, "eth") /* ? */
|| strstr(ifname, "ed")
|| strstr(ifname, "ne")
+ || strstr(ifname, "xe") /* Xircom */
|| strstr(ifname, "xl") /* 3com */
|| strstr(ifname, "vx") /* 3com (older model) */
|| strstr(ifname, "ep") /* 3com 3c589 */

View file

@ -0,0 +1 @@
Network auditing tool

22
security/hping/pkg-descr Normal file
View file

@ -0,0 +1,22 @@
hping2 is a network tool able to send custom ICMP/UDP/TCP
packets and to display target replies like ping do with
ICMP replies. hping2 handle fragmentation, arbitrary packet
body and size and can be used in order to transfer files
under supported protocols. Using hping2 you are able at
least to perform the following jobs:
- Test firewall rules
- [spoofed] port scanning
- Test net performance using different protocols,
packet size, TOS (type of service) and fragmentation.
- Path MTU discovery
- Files transfering even between really fascist firewall rules.
- Traceroute like under different protocols.
- Firewalk like usage.
- Remote OS fingerprint.
- TCP/IP stack auditing.
- A lot of others.
WWW: http://www.kyuzz.org/antirez/hping/
-- Roman Shterenzon <roman@xpert.com>

1
security/hping/pkg-plist Normal file
View file

@ -0,0 +1 @@
sbin/hping