As previously announced, remove net/partysip. It has failed to keep
up with the changes in one of its dependencies.
This commit is contained in:
parent
9eedd4fa8f
commit
d5a202c924
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=122729
6 changed files with 0 additions and 193 deletions
|
@ -1,30 +0,0 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: partysip
|
||||
# Date Created: Mar 27, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= partysip
|
||||
PORTVERSION= 2.1.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://osip.atosc.org/download/partysip/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= An implementation of a SIP proxy server
|
||||
|
||||
LIB_DEPENDS= osip2.2:${PORTSDIR}/net/libosip2 \
|
||||
gdbm.3:${PORTSDIR}/databases/gdbm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
CONFIGURE_ARGS= --with-db=gdbm
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
BROKEN= Does not link with libossip-2.0.7. Downgrade libossip to 2.0.6, uncomment BROKEN in Makefile and retry
|
||||
EXPIRATION_DATE=2004-08-20
|
||||
DEPRECATED= ${BROKEN}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (partysip-2.1.1.tar.gz) = 430b0a8caebeacabef102dbd4dfc7db5
|
||||
SIZE (partysip-2.1.1.tar.gz) = 588544
|
|
@ -1,15 +0,0 @@
|
|||
--- scripts/ltmain.sh.orig Fri Nov 7 13:15:21 2003
|
||||
+++ scripts/ltmain.sh Fri Nov 7 13:15:34 2003
|
||||
@@ -5457,10 +5457,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -1,88 +0,0 @@
|
|||
--- ppl/unix/ppldns.c.orig Mon Sep 29 00:20:45 2003
|
||||
+++ ppl/unix/ppldns.c Fri Nov 7 13:10:55 2003
|
||||
@@ -295,40 +295,40 @@
|
||||
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
type = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(type, cp);
|
||||
#else
|
||||
NS_GET16 (type, cp);
|
||||
#endif
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
aclass = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(aclass, cp);
|
||||
#else
|
||||
NS_GET16 (aclass, cp);
|
||||
#endif
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
ttl = _get_long (cp);
|
||||
cp += sizeof (u_long);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETLONG(ttl, cp);
|
||||
#else
|
||||
NS_GET32 (ttl, cp);
|
||||
#endif
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
dlen = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(dlen, cp);
|
||||
#else
|
||||
NS_GET16 (dlen, cp);
|
||||
@@ -340,30 +340,30 @@
|
||||
continue;
|
||||
}
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
pref = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(pref, cp);
|
||||
#else
|
||||
NS_GET16 (pref, cp);
|
||||
#endif
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
weight = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(weight, cp);
|
||||
#else
|
||||
NS_GET16 (weight, cp);
|
||||
#endif
|
||||
|
||||
#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
|
||||
- defined(OLD_NAMESER) || defined(__FreeBSD__)
|
||||
+ defined(OLD_NAMESER)
|
||||
port = _get_short (cp);
|
||||
cp += sizeof (u_short);
|
||||
-#elif defined(__APPLE_CC__)
|
||||
+#elif defined(__APPLE_CC__) || defined(__FreeBSD__)
|
||||
GETSHORT(port, cp);
|
||||
#else
|
||||
NS_GET16 (port, cp);
|
|
@ -1,12 +0,0 @@
|
|||
Partysip is an implementation of a SIP proxy server. SIP stands for the
|
||||
Session Initiation Protocol and is described by the rfc2543 (soon to be
|
||||
deprecated by latest revisions). SIP is a open standard replacement from
|
||||
IETF for H323.
|
||||
|
||||
Partysip is a modular application where some capabilities are added and
|
||||
removed through plugins. The program comes with several GPL plugins. At
|
||||
this step, partysip and its plugins could be used as a 'SIP registrar',
|
||||
a 'SIP redirect server' and a 'SIP statefull proxy server'. (stateless
|
||||
capabilities have been removed)
|
||||
|
||||
WWW: http://www.partysip.org/
|
|
@ -1,46 +0,0 @@
|
|||
bin/partysip
|
||||
bin/partysip-config
|
||||
bin/psp_users
|
||||
etc/partysip/partysip.conf
|
||||
@dirrm etc/partysip
|
||||
include/partysip/osip_msg.h
|
||||
include/partysip/partysip.h
|
||||
include/partysip/psp_config.h
|
||||
include/partysip/psp_macros.h
|
||||
include/partysip/psp_nat.h
|
||||
include/partysip/psp_plug.h
|
||||
include/partysip/psp_req.h
|
||||
include/partysip/psp_utils.h
|
||||
include/ppl/ppl.h
|
||||
include/ppl/ppl_dbm.h
|
||||
include/ppl/ppl_dns.h
|
||||
include/ppl/ppl_dso.h
|
||||
include/ppl/ppl_getopt.h
|
||||
include/ppl/ppl_init.h
|
||||
include/ppl/ppl_md5.h
|
||||
include/ppl/ppl_pipe.h
|
||||
include/ppl/ppl_socket.h
|
||||
include/ppl/ppl_time.h
|
||||
include/ppl/ppl_uinfo.h
|
||||
@dirrm include/partysip
|
||||
@dirrm include/ppl
|
||||
lib/libppl.a
|
||||
lib/libppl.so
|
||||
lib/libppl.so.2
|
||||
lib/partysip/libpsp_auth.a
|
||||
lib/partysip/libpsp_auth.so
|
||||
lib/partysip/libpsp_filter.a
|
||||
lib/partysip/libpsp_filter.so
|
||||
lib/partysip/libpsp_ls_localdb.a
|
||||
lib/partysip/libpsp_ls_localdb.so
|
||||
lib/partysip/libpsp_ls_sfull.a
|
||||
lib/partysip/libpsp_ls_sfull.so
|
||||
lib/partysip/libpsp_ls_static.a
|
||||
lib/partysip/libpsp_ls_static.so
|
||||
lib/partysip/libpsp_rgstrar.a
|
||||
lib/partysip/libpsp_rgstrar.so
|
||||
lib/partysip/libpsp_syntax.a
|
||||
lib/partysip/libpsp_syntax.so
|
||||
lib/partysip/libpsp_udp.a
|
||||
lib/partysip/libpsp_udp.so
|
||||
@dirrm lib/partysip
|
Loading…
Reference in a new issue