- Add grib_api 1.12.3

The ECMWF GRIB API is an application program interface accessible from C,
FORTRAN and Python programs developed for encoding and decoding WMO FM-92 GRIB
edition 1 and edition 2 messages. A useful set of command line tools is also
provided to give quick access to GRIB messages.

WWW: https://software.ecmwf.int/wiki/display/GRIB/Home
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2014-08-29 17:31:42 +00:00
parent 8bf6fc38b1
commit d5a68cc00b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366539
8 changed files with 2943 additions and 0 deletions

View file

@ -61,6 +61,7 @@
SUBDIR += ghmm
SUBDIR += gnudatalanguage
SUBDIR += gramps
SUBDIR += grib_api
SUBDIR += gromacs
SUBDIR += gsmc
SUBDIR += gtamsanalyzer

34
science/grib_api/Makefile Normal file
View file

@ -0,0 +1,34 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
PORTNAME= grib_api
PORTVERSION= 1.12.3
CATEGORIES= science
MASTER_SITES= https://software.ecmwf.int/wiki/download/attachments/3473437/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= ECMWF API for WMO FM-92 GRIB messages
LICENSE= APACHE20
LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf \
libpng.so:${PORTSDIR}/graphics/png
OPTIONS_SINGLE= JPEG
OPTIONS_SINGLE_JPEG= JASPER OPENJPEG
OPTIONS_DEFAULT=OPENJPEG
CONFIGURE_ARGS= --enable-pthread --with-netcdf=${LOCALBASE} --with-png-support
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool pathfix
JASPER_CONFIGURE_ON= --with-jasper=${LOCALBASE}
JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper
OPENJPEG_CONFIGURE_ON= --with-openjpeg=${LOCALBASE}
OPENJPEG_LIB_DEPENDS= libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/tools/grib1to2 ${STAGEDIR}${PREFIX}/bin/grib1to2
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (grib_api-1.12.3.tar.gz) = 2d4b05432c981dcc2b59607d50eeb214afedc394491354e4222123050cc4576c
SIZE (grib_api-1.12.3.tar.gz) = 14638304

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig 2014-07-07 19:30:11.000000000 +0800
+++ Makefile.in 2014-08-26 23:53:36.193299212 +0800
@@ -750,7 +750,7 @@
-rm -f libtool config.lt
install-pkgconfigDATA: $(pkgconfig_DATA)
@$(NORMAL_INSTALL)
- test -z "$(pkgconfigdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgconfigdir)"
+ test -z "$(DESTDIR)$(pkgconfigdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgconfigdir)"
@list='$(pkgconfig_DATA)'; test -n "$(pkgconfigdir)" || list=; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \

View file

@ -0,0 +1,24 @@
--- src/Makefile.in.orig 2014-07-07 19:30:11.000000000 +0800
+++ src/Makefile.in 2014-08-26 23:55:31.371292955 +0800
@@ -847,8 +847,8 @@
-rm -f config.h stamp-h1
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
@$(NORMAL_INSTALL)
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
- @list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
+ @list='$(lib_LTLIBRARIES)'; test -n "$(DESTDIR)$(libdir)" || list=; \
list2=; for p in $$list; do \
if test -f $$p; then \
list2="$$list2 $$p"; \
@@ -1191,8 +1191,8 @@
-rm -rf .libs _libs
install-includeHEADERS: $(include_HEADERS)
@$(NORMAL_INSTALL)
- test -z "$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
- @list='$(include_HEADERS)'; test -n "$(includedir)" || list=; \
+ test -z "$(DESTDIR)$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
+ @list='$(include_HEADERS)'; test -n "$(DESTDIR)$(includedir)" || list=; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \

View file

@ -0,0 +1,15 @@
--- tools/Makefile.in.orig 2014-07-07 19:30:11.000000000 +0800
+++ tools/Makefile.in 2014-08-27 01:01:05.658020559 +0800
@@ -45,10 +45,10 @@
grib_cmp$(EXEEXT) grib_convert$(EXEEXT) grib_distance$(EXEEXT) \
grib_corruption_check$(EXEEXT) grib_compare$(EXEEXT) \
grib_list_keys$(EXEEXT) parser$(EXEEXT) grib_count$(EXEEXT) \
- grib_index_build$(EXEEXT) grib1to2$(EXEEXT) \
+ grib_index_build$(EXEEXT) \
gg_sub_area_check$(EXEEXT) grib_moments$(EXEEXT) \
grib_to_netcdf$(EXEEXT) grib_to_json$(EXEEXT)
-noinst_PROGRAMS = gaussian$(EXEEXT) grib_diff$(EXEEXT) \
+noinst_PROGRAMS = gaussian$(EXEEXT) grib_diff$(EXEEXT) grib1to2$(EXEEXT) \
mars_request$(EXEEXT) xref$(EXEEXT) all_keys$(EXEEXT)
subdir = tools
DIST_COMMON = $(noinst_HEADERS) $(srcdir)/Makefile.am \

View file

@ -0,0 +1,6 @@
The ECMWF GRIB API is an application program interface accessible from C,
FORTRAN and Python programs developed for encoding and decoding WMO FM-92 GRIB
edition 1 and edition 2 messages. A useful set of command line tools is also
provided to give quick access to GRIB messages.
WWW: https://software.ecmwf.int/wiki/display/GRIB/Home

2850
science/grib_api/pkg-plist Normal file

File diff suppressed because it is too large Load diff