security/openssl: Major version update to 3.0
* OpenSSL 1.1.1 is EoL, update to new LTS version * Aligns with upcoming OpenSSL version in 14.0
This commit is contained in:
parent
eb45600f80
commit
d5ec2e12f3
14 changed files with 652 additions and 3358 deletions
17
UPDATING
17
UPDATING
|
@ -5,6 +5,23 @@ they are unavoidable.
|
|||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20231014:
|
||||
AFFECTS: users of security/openssl and security/openssl30
|
||||
AUTHOR: brnrd@FreeBSD.org
|
||||
|
||||
The openssl port was renamed to openssl111 and subsequently the
|
||||
openssl30 port was renamed to openssl.
|
||||
|
||||
The shared library version of OpenSSL has been bumped.
|
||||
|
||||
Users of DEFAULT_VERSIONS= ssl=openssl30 must update this to
|
||||
ssl=openssl.
|
||||
Users of DEFAULT_VERSIONS= ssl=openssl should not change this unless
|
||||
they use ports that require the deprecated OpenSSL 1.1.1 version.
|
||||
|
||||
You must rebuild all ports that depend on OpenSSL if you use OpenSSL
|
||||
from ports.
|
||||
|
||||
20231011:
|
||||
AFFECTS: users of www/caddy
|
||||
AUTHOR: adamw@FreeBSD.org
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= openssl
|
||||
PORTVERSION= 1.1.1w
|
||||
PORTVERSION= 3.0.11
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= https://www.openssl.org/source/ \
|
||||
|
@ -9,10 +9,16 @@ MAINTAINER= brnrd@FreeBSD.org
|
|||
COMMENT= TLSv1.3 capable SSL and crypto library
|
||||
WWW= https://www.openssl.org/
|
||||
|
||||
LICENSE= OpenSSL
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl3[012] openssl-quictls
|
||||
#EXPIRES= 2025-03-25
|
||||
|
||||
CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl111 openssl3[12] openssl-quictls
|
||||
|
||||
USES= cpe perl5
|
||||
USE_PERL5= build
|
||||
TEST_TARGET= test
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= config
|
||||
|
@ -20,32 +26,27 @@ CONFIGURE_ENV= PERL="${PERL}"
|
|||
CONFIGURE_ARGS= --openssldir=${OPENSSLDIR} \
|
||||
--prefix=${PREFIX}
|
||||
|
||||
USES= cpe perl5
|
||||
USE_PERL5= build
|
||||
TEST_TARGET= test
|
||||
|
||||
LDFLAGS_i386= -Wl,-znotext
|
||||
|
||||
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive CNF_LDFLAGS="${LDFLAGS}"
|
||||
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
|
||||
|
||||
OPTIONS_GROUP= CIPHERS HASHES OPTIMIZE PROTOCOLS
|
||||
OPTIONS_GROUP= CIPHERS HASHES MODULES OPTIMIZE PROTOCOLS
|
||||
OPTIONS_GROUP_CIPHERS= ARIA DES GOST IDEA SM4 RC2 RC4 RC5 WEAK-SSL-CIPHERS
|
||||
OPTIONS_GROUP_HASHES= MD2 MD4 MDC2 RMD160 SM2 SM3
|
||||
OPTIONS_GROUP_OPTIMIZE= ASM SSE2 THREADS
|
||||
OPTIONS_GROUP_MODULES= FIPS LEGACY
|
||||
OPTIONS_DEFINE_i386= I386
|
||||
OPTIONS_GROUP_PROTOCOLS=NEXTPROTONEG SCTP SSL3 TLS1 TLS1_1 TLS1_2
|
||||
|
||||
OPTIONS_DEFINE= ASYNC CRYPTODEV CT KTLS MAN3 RFC3779 SHARED ZLIB
|
||||
|
||||
OPTIONS_DEFAULT=ASM ASYNC CT GOST DES EC KTLS MAN3 MD4 NEXTPROTONEG RC2 \
|
||||
RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
|
||||
OPTIONS_DEFAULT=ASM ASYNC CT DES EC FIPS GOST KTLS MAN3 MD4 NEXTPROTONEG \
|
||||
RFC3779 RC2 RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
|
||||
|
||||
OPTIONS_EXCLUDE=${${OSVERSION} < 1300042:?KTLS:} \
|
||||
${${OSVERSION} > 1300000:?CRYPTODEV:}
|
||||
|
||||
OPTIONS_GROUP_OPTIMIZE_amd64= EC
|
||||
|
||||
.if ${MACHINE_ARCH} == "amd64"
|
||||
OPTIONS_GROUP_OPTIMIZE+= EC
|
||||
.elif ${MACHINE_ARCH} == "mips64el"
|
||||
|
@ -62,15 +63,18 @@ CRYPTODEV_DESC= /dev/crypto support
|
|||
CT_DESC= Certificate Transparency Support
|
||||
DES_DESC= (Triple) Data Encryption Standard
|
||||
EC_DESC= Optimize NIST elliptic curves
|
||||
FIPS_DESC= Build FIPS provider
|
||||
GOST_DESC= GOST (Russian standard)
|
||||
HASHES_DESC= Hash Function Support
|
||||
I386_DESC= i386 (instead of i486+)
|
||||
IDEA_DESC= International Data Encryption Algorithm
|
||||
KTLS_DESC= Kernel TLS offload
|
||||
KTLS_DESC= Use in-kernel TLS (FreeBSD >13)
|
||||
LEGACY_DESC= Older algorithms
|
||||
MAN3_DESC= Install API manpages (section 3, 7)
|
||||
MD2_DESC= MD2 (obsolete)
|
||||
MD2_DESC= MD2 (obsolete) (requires LEGACY)
|
||||
MD4_DESC= MD4 (unsafe)
|
||||
MDC2_DESC= MDC-2 (patented, requires DES)
|
||||
MODULES_DESC= Provider modules
|
||||
NEXTPROTONEG_DESC= Next Protocol Negotiation (SPDY)
|
||||
OPTIMIZE_DESC= Optimizations
|
||||
PROTOCOLS_DESC= Protocol Support
|
||||
|
@ -92,30 +96,51 @@ TLS1_2_DESC= TLSv1.2
|
|||
WEAK-SSL-CIPHERS_DESC= Weak cipher support (unsafe)
|
||||
|
||||
# Upstream default disabled options
|
||||
.for _option in ktls md2 rc5 sctp ssl3 zlib weak-ssl-ciphers
|
||||
.for _option in fips md2 ktls rc5 sctp ssl3 weak-ssl-ciphers zlib
|
||||
${_option:tu}_CONFIGURE_ON= enable-${_option}
|
||||
.endfor
|
||||
|
||||
# Upstream default enabled options
|
||||
.for _option in aria asm async ct des gost idea md4 mdc2 nextprotoneg rc2 rc4 \
|
||||
rfc3779 rmd160 shared sm2 sm3 sm4 sse2 threads tls1 tls1_1 tls1_2
|
||||
.for _option in aria asm async ct des gost idea md4 mdc2 legacy \
|
||||
nextprotoneg rc2 rc4 rfc3779 rmd160 shared sm2 sm3 sm4 sse2 \
|
||||
threads tls1 tls1_1 tls1_2
|
||||
${_option:tu}_CONFIGURE_OFF= no-${_option}
|
||||
.endfor
|
||||
|
||||
MD2_IMPLIES= LEGACY
|
||||
MDC2_IMPLIES= DES
|
||||
TLS1_IMPLIES= TLS1_1
|
||||
TLS1_1_IMPLIES= TLS1_2
|
||||
|
||||
EC_CONFIGURE_ON= enable-ec_nistp_64_gcc_128
|
||||
FIPS_VARS= shlibs+=lib/ossl-modules/fips.so
|
||||
I386_CONFIGURE_ON= 386
|
||||
KTLS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-ktls
|
||||
MAN3_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-util_process__docs.pl
|
||||
LEGACY_VARS= shlibs+=lib/ossl-modules/legacy.so
|
||||
MAN3_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-util_find-doc-nits
|
||||
SHARED_MAKE_ENV= SHLIBVER=${OPENSSL_SHLIBVER}
|
||||
SHARED_PLIST_SUB= SHLIBVER=${OPENSSL_SHLIBVER}
|
||||
SHARED_USE= ldconfig=yes
|
||||
SHARED_VARS= shlibs+="lib/libcrypto.so.${OPENSSL_SHLIBVER} \
|
||||
lib/libssl.so.${OPENSSL_SHLIBVER} \
|
||||
lib/engines-${OPENSSL_SHLIBVER}/capi.so \
|
||||
lib/engines-${OPENSSL_SHLIBVER}/devcrypto.so \
|
||||
lib/engines-${OPENSSL_SHLIBVER}/padlock.so"
|
||||
SSL3_CONFIGURE_ON+= enable-ssl3-method
|
||||
ZLIB_CONFIGURE_ON= zlib-dynamic
|
||||
|
||||
SHLIBS= lib/engines-${OPENSSL_SHLIBVER}/loader_attic.so
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} == powerpc64
|
||||
CONFIGURE_ARGS+= BSD-ppc64
|
||||
.elif ${ARCH} == powerpc64le
|
||||
CONFIGURE_ARGS+= BSD-ppc64le
|
||||
.elif ${ARCH} == riscv64
|
||||
CONFIGURE_ARGS+= BSD-riscv64
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${PREFIX} == /usr
|
||||
IGNORE= the OpenSSL port can not be installed over the base version
|
||||
|
@ -135,35 +160,34 @@ BROKEN_sparc64= option ASM generates illegal instructions
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} \
|
||||
-e 's|^MANDIR=.*$$|MANDIR=$$(INSTALLTOP)/man|' \
|
||||
-e 's| install_html_docs$$||' \
|
||||
-e 's|$$(LIBDIR)/pkgconfig|libdata/pkgconfig|g' \
|
||||
${REINPLACE_CMD} -Ee 's|^MANDIR=.*$$|MANDIR=$$(INSTALLTOP)/man|' \
|
||||
-e 's|^(build\|install)_docs: .*|\1_docs: \1_man_docs|' \
|
||||
${WRKSRC}/Configurations/unix-Makefile.tmpl
|
||||
${REINPLACE_CMD} -e 's|\^GNU ld|GNU|' ${WRKSRC}/Configurations/shared-info.pl
|
||||
${REINPLACE_CMD} 's|SHLIB_VERSION=3|SHLIB_VERSION=${OPENSSL_SHLIBVER}|' \
|
||||
${WRKSRC}/VERSION.dat
|
||||
|
||||
post-configure:
|
||||
( cd ${WRKSRC} ; ${PERL} configdata.pm --dump )
|
||||
|
||||
post-configure-MAN3-off:
|
||||
${REINPLACE_CMD} \
|
||||
-e 's|SHLIB_VERSION_NUMBER=1.1|SHLIB_VERSION_NUMBER=${OPENSSL_SHLIBVER}|' \
|
||||
-e 's|^build_man_docs:.*|build_man_docs: $$(MANDOCS1) $$(MANDOCS5)|' \
|
||||
-e 's|dummy $$(MANDOCS[37]); do |dummy; do |' \
|
||||
${WRKSRC}/Makefile
|
||||
${REINPLACE_CMD} \
|
||||
-e 's|SHLIB_VERSION_NUMBER "1.1"|SHLIB_VERSION_NUMBER "${OPENSSL_SHLIBVER}"|' \
|
||||
${WRKSRC}/include/openssl/opensslv.h
|
||||
|
||||
post-install-SHARED-on:
|
||||
.for i in libcrypto libssl
|
||||
${INSTALL_LIB} ${WRKSRC}/$i.so.${OPENSSL_SHLIBVER} ${STAGEDIR}${PREFIX}/lib
|
||||
${LN} -sf $i.so.${OPENSSL_SHLIBVER} ${STAGEDIR}${PREFIX}/lib/$i.so
|
||||
.endfor
|
||||
.for i in capi padlock
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/engines-1.1/${i}.so
|
||||
.for i in ${SHLIBS}
|
||||
-@${STRIP_CMD} ${STAGEDIR}${PREFIX}/$i
|
||||
.endfor
|
||||
|
||||
post-install-SHARED-off:
|
||||
${RMDIR} ${STAGEDIR}${PREFIX}/lib/engines-12
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/openssl
|
||||
|
||||
post-install-MAN3-on:
|
||||
( cd ${STAGEDIR}/${PREFIX} ; ${FIND} man/man3 man/man7 -not -type d ) | \
|
||||
${SED} 's/$$/.gz/' >>${TMPPLIST}
|
||||
( cd ${STAGEDIR}/${PREFIX} ; ${FIND} man/man3 -not -type d ; \
|
||||
${FIND} man/man7 -not -type d ) | ${SED} 's/$$/.gz/' >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1694449777
|
||||
SHA256 (openssl-1.1.1w.tar.gz) = cf3098950cb4d853ad95c0841f1f9c6d3dc102dccfcacd521d93925208b76ac8
|
||||
SIZE (openssl-1.1.1w.tar.gz) = 9893384
|
||||
TIMESTAMP = 1695134169
|
||||
SHA256 (openssl-3.0.11.tar.gz) = b3425d3bb4a2218d0697eb41f7fc0cdede016ed19ca49d168b78e8d947887f55
|
||||
SIZE (openssl-3.0.11.tar.gz) = 15198318
|
||||
|
|
File diff suppressed because it is too large
Load diff
20
security/openssl/files/extra-patch-util_find-doc-nits
Normal file
20
security/openssl/files/extra-patch-util_find-doc-nits
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- util/find-doc-nits.orig 2023-08-01 13:47:24 UTC
|
||||
+++ util/find-doc-nits
|
||||
@@ -80,7 +80,7 @@ my $temp = '/tmp/docnits.txt';
|
||||
my $OUT;
|
||||
my $status = 0;
|
||||
|
||||
-$opt_m = "man1,man3,man5,man7" unless $opt_m;
|
||||
+$opt_m = "man1,man5" unless $opt_m;
|
||||
die "Argument of -m option may contain only man1, man3, man5, and/or man7"
|
||||
unless $opt_m =~ /^(man[1357][, ]?)*$/;
|
||||
my @sections = ( split /[, ]/, $opt_m );
|
||||
@@ -725,7 +725,7 @@ sub check {
|
||||
next if $target eq ''; # Skip if links within page, or
|
||||
next if $target =~ /::/; # links to a Perl module, or
|
||||
next if $target =~ /^https?:/; # is a URL link, or
|
||||
- next if $target =~ /\([1357]\)$/; # it has a section
|
||||
+ next if $target =~ /\([15]\)$/; # it has a section
|
||||
err($id, "Missing man section number (likely, $mansect) in L<$target>")
|
||||
}
|
||||
# Check for proper links to commands.
|
|
@ -1,20 +0,0 @@
|
|||
--- util/process_docs.pl.orig 2018-09-11 12:48:25 UTC
|
||||
+++ util/process_docs.pl
|
||||
@@ -43,7 +43,7 @@ GetOptions(\%options,
|
||||
);
|
||||
|
||||
unless ($options{section}) {
|
||||
- $options{section} = [ 1, 3, 5, 7 ];
|
||||
+ $options{section} = [ 1, 5 ];
|
||||
}
|
||||
unless ($options{sourcedir}) {
|
||||
$options{sourcedir} = catdir($config{sourcedir}, "doc");
|
||||
@@ -98,7 +98,7 @@ foreach my $section (sort @{$options{sec
|
||||
my $suffix = { man => ".$podinfo{section}".($options{suffix} // ""),
|
||||
html => ".html" } -> {$options{type}};
|
||||
my $generate = { man => "pod2man --name=$name --section=$podinfo{section} --center=OpenSSL --release=$config{version} \"$podpath\"",
|
||||
- html => "pod2html \"--podroot=$options{sourcedir}\" --htmldir=$updir --podpath=man1:man3:man5:man7 \"--infile=$podpath\" \"--title=$podname\" --quiet"
|
||||
+ html => "pod2html \"--podroot=$options{sourcedir}\" --htmldir=$updir --podpath=man1:man5 \"--infile=$podpath\" \"--title=$podname\" --quiet"
|
||||
} -> {$options{type}};
|
||||
my $output_dir = catdir($options{destdir}, "man$podinfo{section}");
|
||||
my $output_file = $podname . $suffix;
|
35
security/openssl/files/patch-Configurations_10-main.conf
Normal file
35
security/openssl/files/patch-Configurations_10-main.conf
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- Configurations/10-main.conf.orig 2022-04-12 16:29:42 UTC
|
||||
+++ Configurations/10-main.conf
|
||||
@@ -1069,6 +1069,32 @@ my %targets = (
|
||||
perlasm_scheme => "linux64",
|
||||
},
|
||||
|
||||
+ "BSD-ppc" => {
|
||||
+ inherit_from => [ "BSD-generic32" ],
|
||||
+ asm_arch => 'ppc32',
|
||||
+ perlasm_scheme => "linux32",
|
||||
+ lib_cppflags => add("-DB_ENDIAN"),
|
||||
+ },
|
||||
+
|
||||
+ "BSD-ppc64" => {
|
||||
+ inherit_from => [ "BSD-generic64" ],
|
||||
+ cflags => add("-m64"),
|
||||
+ cxxflags => add("-m64"),
|
||||
+ lib_cppflags => add("-DB_ENDIAN"),
|
||||
+ asm_arch => 'ppc64',
|
||||
+ perlasm_scheme => "linux64",
|
||||
+ },
|
||||
+
|
||||
+ "BSD-ppc64le" => {
|
||||
+ inherit_from => [ "BSD-generic64" ],
|
||||
+ cflags => add("-m64"),
|
||||
+ cxxflags => add("-m64"),
|
||||
+ lib_cppflags => add("-DL_ENDIAN"),
|
||||
+ asm_arch => 'ppc64',
|
||||
+ perlasm_scheme => "linux64le",
|
||||
+ },
|
||||
+
|
||||
+
|
||||
"bsdi-elf-gcc" => {
|
||||
inherit_from => [ "BASE_unix" ],
|
||||
CC => "gcc",
|
11
security/openssl/files/patch-Configure
Normal file
11
security/openssl/files/patch-Configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Configure.orig 2022-04-12 16:30:34 UTC
|
||||
+++ Configure
|
||||
@@ -1549,7 +1549,7 @@ my %predefined_CXX = $config{CXX}
|
||||
|
||||
unless ($disabled{asm}) {
|
||||
# big endian systems can use ELFv2 ABI
|
||||
- if ($target eq "linux-ppc64") {
|
||||
+ if ($target eq "linux-ppc64" || $target eq "BSD-ppc64") {
|
||||
$target{perlasm_scheme} = "linux64v2" if ($predefined_C{_CALL_ELF} == 2);
|
||||
}
|
||||
}
|
34
security/openssl/files/patch-crypto_ppccap.c
Normal file
34
security/openssl/files/patch-crypto_ppccap.c
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- crypto/ppccap.c.orig 2022-04-12 16:31:27 UTC
|
||||
+++ crypto/ppccap.c
|
||||
@@ -117,14 +117,18 @@ static unsigned long getauxval(unsigned long key)
|
||||
#endif
|
||||
|
||||
/* I wish <sys/auxv.h> was universally available */
|
||||
-#define HWCAP 16 /* AT_HWCAP */
|
||||
+#ifndef AT_HWCAP
|
||||
+# define AT_HWCAP 16 /* AT_HWCAP */
|
||||
+#endif
|
||||
#define HWCAP_PPC64 (1U << 30)
|
||||
#define HWCAP_ALTIVEC (1U << 28)
|
||||
#define HWCAP_FPU (1U << 27)
|
||||
#define HWCAP_POWER6_EXT (1U << 9)
|
||||
#define HWCAP_VSX (1U << 7)
|
||||
|
||||
-#define HWCAP2 26 /* AT_HWCAP2 */
|
||||
+#ifndef AT_HWCAP2
|
||||
+# define AT_HWCAP2 26 /* AT_HWCAP2 */
|
||||
+#endif
|
||||
#define HWCAP_VEC_CRYPTO (1U << 25)
|
||||
#define HWCAP_ARCH_3_00 (1U << 23)
|
||||
|
||||
@@ -215,8 +219,8 @@ void OPENSSL_cpuid_setup(void)
|
||||
|
||||
#ifdef OSSL_IMPLEMENT_GETAUXVAL
|
||||
{
|
||||
- unsigned long hwcap = getauxval(HWCAP);
|
||||
- unsigned long hwcap2 = getauxval(HWCAP2);
|
||||
+ unsigned long hwcap = getauxval(AT_HWCAP);
|
||||
+ unsigned long hwcap2 = getauxval(AT_HWCAP2);
|
||||
|
||||
if (hwcap & HWCAP_FPU) {
|
||||
OPENSSL_ppccap_P |= PPC_FPU;
|
13
security/openssl/files/patch-crypto_threads__pthread.c
Normal file
13
security/openssl/files/patch-crypto_threads__pthread.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- crypto/threads_pthread.c.orig 2022-11-01 14:14:36 UTC
|
||||
+++ crypto/threads_pthread.c
|
||||
@@ -29,6 +29,10 @@
|
||||
#define BROKEN_CLANG_ATOMICS
|
||||
#endif
|
||||
|
||||
+#if defined(__FreeBSD__) && defined(__i386__)
|
||||
+#define BROKEN_CLANG_ATOMICS
|
||||
+#endif
|
||||
+
|
||||
#if defined(OPENSSL_THREADS) && !defined(CRYPTO_TDEBUG) && !defined(OPENSSL_SYS_WINDOWS)
|
||||
|
||||
# if defined(OPENSSL_SYS_UNIX)
|
14
security/openssl/files/patch-util_perl_OpenSSL_config.pm
Normal file
14
security/openssl/files/patch-util_perl_OpenSSL_config.pm
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- util/perl/OpenSSL/config.pm.orig 2022-04-12 16:34:06 UTC
|
||||
+++ util/perl/OpenSSL/config.pm
|
||||
@@ -747,8 +747,9 @@ EOF
|
||||
disable => [ 'sse2' ] } ],
|
||||
[ 'alpha.*-.*-.*bsd.*', { target => "BSD-generic64",
|
||||
defines => [ 'L_ENDIAN' ] } ],
|
||||
- [ 'powerpc64-.*-.*bsd.*', { target => "BSD-generic64",
|
||||
- defines => [ 'B_ENDIAN' ] } ],
|
||||
+ [ 'powerpc-.*-.*bsd.*', { target => "BSD-ppc" } ],
|
||||
+ [ 'powerpc64-.*-.*bsd.*', { target => "BSD-ppc64" } ],
|
||||
+ [ 'powerpc64le-.*-.*bsd.*', { target => "BSD-ppc64le" } ],
|
||||
[ 'riscv64-.*-.*bsd.*', { target => "BSD-riscv64" } ],
|
||||
[ 'sparc64-.*-.*bsd.*', { target => "BSD-sparc64" } ],
|
||||
[ 'ia64-.*-.*bsd.*', { target => "BSD-ia64" } ],
|
|
@ -1,8 +0,0 @@
|
|||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
Copy %%PREFIX%%/openssl/openssl.cnf.sample to %%PREFIX%%/openssl/openssl.cnf
|
||||
and edit it to fit your needs.
|
||||
EOM
|
||||
}
|
||||
]
|
|
@ -17,6 +17,9 @@ include/openssl/buffererr.h
|
|||
include/openssl/camellia.h
|
||||
include/openssl/cast.h
|
||||
include/openssl/cmac.h
|
||||
include/openssl/cmp.h
|
||||
include/openssl/cmp_util.h
|
||||
include/openssl/cmperr.h
|
||||
include/openssl/cms.h
|
||||
include/openssl/cmserr.h
|
||||
include/openssl/comp.h
|
||||
|
@ -24,10 +27,21 @@ include/openssl/comperr.h
|
|||
include/openssl/conf.h
|
||||
include/openssl/conf_api.h
|
||||
include/openssl/conferr.h
|
||||
include/openssl/configuration.h
|
||||
include/openssl/conftypes.h
|
||||
include/openssl/core.h
|
||||
include/openssl/core_dispatch.h
|
||||
include/openssl/core_names.h
|
||||
include/openssl/core_object.h
|
||||
include/openssl/crmf.h
|
||||
include/openssl/crmferr.h
|
||||
include/openssl/crypto.h
|
||||
include/openssl/cryptoerr.h
|
||||
include/openssl/cryptoerr_legacy.h
|
||||
include/openssl/ct.h
|
||||
include/openssl/cterr.h
|
||||
include/openssl/decoder.h
|
||||
include/openssl/decodererr.h
|
||||
include/openssl/des.h
|
||||
include/openssl/dh.h
|
||||
include/openssl/dherr.h
|
||||
|
@ -40,16 +54,25 @@ include/openssl/ec.h
|
|||
include/openssl/ecdh.h
|
||||
include/openssl/ecdsa.h
|
||||
include/openssl/ecerr.h
|
||||
include/openssl/encoder.h
|
||||
include/openssl/encodererr.h
|
||||
include/openssl/engine.h
|
||||
include/openssl/engineerr.h
|
||||
include/openssl/err.h
|
||||
include/openssl/ess.h
|
||||
include/openssl/esserr.h
|
||||
include/openssl/evp.h
|
||||
include/openssl/evperr.h
|
||||
include/openssl/fips_names.h
|
||||
include/openssl/fipskey.h
|
||||
include/openssl/hmac.h
|
||||
include/openssl/http.h
|
||||
include/openssl/httperr.h
|
||||
include/openssl/idea.h
|
||||
include/openssl/kdf.h
|
||||
include/openssl/kdferr.h
|
||||
include/openssl/lhash.h
|
||||
include/openssl/macros.h
|
||||
include/openssl/md2.h
|
||||
include/openssl/md4.h
|
||||
include/openssl/md5.h
|
||||
|
@ -63,6 +86,8 @@ include/openssl/ocsperr.h
|
|||
include/openssl/opensslconf.h
|
||||
include/openssl/opensslv.h
|
||||
include/openssl/ossl_typ.h
|
||||
include/openssl/param_build.h
|
||||
include/openssl/params.h
|
||||
include/openssl/pem.h
|
||||
include/openssl/pem2.h
|
||||
include/openssl/pemerr.h
|
||||
|
@ -70,8 +95,10 @@ include/openssl/pkcs12.h
|
|||
include/openssl/pkcs12err.h
|
||||
include/openssl/pkcs7.h
|
||||
include/openssl/pkcs7err.h
|
||||
include/openssl/prov_ssl.h
|
||||
include/openssl/proverr.h
|
||||
include/openssl/provider.h
|
||||
include/openssl/rand.h
|
||||
include/openssl/rand_drbg.h
|
||||
include/openssl/randerr.h
|
||||
include/openssl/rc2.h
|
||||
include/openssl/rc4.h
|
||||
|
@ -81,6 +108,7 @@ include/openssl/rsa.h
|
|||
include/openssl/rsaerr.h
|
||||
include/openssl/safestack.h
|
||||
include/openssl/seed.h
|
||||
include/openssl/self_test.h
|
||||
include/openssl/sha.h
|
||||
include/openssl/srp.h
|
||||
include/openssl/srtp.h
|
||||
|
@ -88,14 +116,17 @@ include/openssl/ssl.h
|
|||
include/openssl/ssl2.h
|
||||
include/openssl/ssl3.h
|
||||
include/openssl/sslerr.h
|
||||
include/openssl/sslerr_legacy.h
|
||||
include/openssl/stack.h
|
||||
include/openssl/store.h
|
||||
include/openssl/storeerr.h
|
||||
include/openssl/symhacks.h
|
||||
include/openssl/tls1.h
|
||||
include/openssl/trace.h
|
||||
include/openssl/ts.h
|
||||
include/openssl/tserr.h
|
||||
include/openssl/txt_db.h
|
||||
include/openssl/types.h
|
||||
include/openssl/ui.h
|
||||
include/openssl/uierr.h
|
||||
include/openssl/whrlpool.h
|
||||
|
@ -104,123 +135,141 @@ include/openssl/x509_vfy.h
|
|||
include/openssl/x509err.h
|
||||
include/openssl/x509v3.h
|
||||
include/openssl/x509v3err.h
|
||||
%%SHARED%%lib/engines-1.1/capi.so
|
||||
%%SHARED%%lib/engines-1.1/padlock.so
|
||||
%%SHARED%%lib/engines-%%SHLIBVER%%/capi.so
|
||||
%%CRYPTODEV%%%%SHARED%%lib/engines-%%SHLIBVER%%/devcrypto.so
|
||||
%%SHARED%%lib/engines-%%SHLIBVER%%/loader_attic.so
|
||||
%%SHARED%%lib/engines-%%SHLIBVER%%/padlock.so
|
||||
lib/libcrypto.a
|
||||
%%SHARED%%lib/libcrypto.so
|
||||
%%SHARED%%lib/libcrypto.so.%%SHLIBVER%%
|
||||
lib/libssl.a
|
||||
%%SHARED%%lib/libssl.so
|
||||
%%SHARED%%lib/libssl.so.%%SHLIBVER%%
|
||||
%%FIPS%%%%SHARED%%lib/ossl-modules/fips.so
|
||||
%%LEGACY%%%%SHARED%%lib/ossl-modules/legacy.so
|
||||
libdata/pkgconfig/libcrypto.pc
|
||||
libdata/pkgconfig/libssl.pc
|
||||
libdata/pkgconfig/openssl.pc
|
||||
man/man1/CA.pl.1.gz
|
||||
man/man1/asn1parse.1.gz
|
||||
man/man1/c_rehash.1.gz
|
||||
man/man1/ca.1.gz
|
||||
man/man1/ciphers.1.gz
|
||||
man/man1/cms.1.gz
|
||||
man/man1/crl.1.gz
|
||||
man/man1/crl2pkcs7.1.gz
|
||||
man/man1/dgst.1.gz
|
||||
man/man1/dhparam.1.gz
|
||||
man/man1/dsa.1.gz
|
||||
man/man1/dsaparam.1.gz
|
||||
man/man1/ec.1.gz
|
||||
man/man1/ecparam.1.gz
|
||||
man/man1/enc.1.gz
|
||||
man/man1/engine.1.gz
|
||||
man/man1/errstr.1.gz
|
||||
man/man1/gendsa.1.gz
|
||||
man/man1/genpkey.1.gz
|
||||
man/man1/genrsa.1.gz
|
||||
man/man1/list.1.gz
|
||||
man/man1/nseq.1.gz
|
||||
man/man1/ocsp.1.gz
|
||||
man/man1/openssl-asn1parse.1.gz
|
||||
man/man1/openssl-c_rehash.1.gz
|
||||
man/man1/openssl-ca.1.gz
|
||||
man/man1/openssl-ciphers.1.gz
|
||||
man/man1/openssl-cms.1.gz
|
||||
man/man1/openssl-crl.1.gz
|
||||
man/man1/openssl-crl2pkcs7.1.gz
|
||||
man/man1/openssl-dgst.1.gz
|
||||
man/man1/openssl-dhparam.1.gz
|
||||
man/man1/openssl-dsa.1.gz
|
||||
man/man1/openssl-dsaparam.1.gz
|
||||
man/man1/openssl-ec.1.gz
|
||||
man/man1/openssl-ecparam.1.gz
|
||||
man/man1/openssl-enc.1.gz
|
||||
man/man1/openssl-engine.1.gz
|
||||
man/man1/openssl-errstr.1.gz
|
||||
man/man1/openssl-gendsa.1.gz
|
||||
man/man1/openssl-genpkey.1.gz
|
||||
man/man1/openssl-genrsa.1.gz
|
||||
man/man1/openssl-list.1.gz
|
||||
man/man1/openssl-nseq.1.gz
|
||||
man/man1/openssl-ocsp.1.gz
|
||||
man/man1/openssl-passwd.1.gz
|
||||
man/man1/openssl-pkcs12.1.gz
|
||||
man/man1/openssl-pkcs7.1.gz
|
||||
man/man1/openssl-pkcs8.1.gz
|
||||
man/man1/openssl-pkey.1.gz
|
||||
man/man1/openssl-pkeyparam.1.gz
|
||||
man/man1/openssl-pkeyutl.1.gz
|
||||
man/man1/openssl-prime.1.gz
|
||||
man/man1/openssl-rand.1.gz
|
||||
man/man1/openssl-rehash.1.gz
|
||||
man/man1/openssl-req.1.gz
|
||||
man/man1/openssl-rsa.1.gz
|
||||
man/man1/openssl-rsautl.1.gz
|
||||
man/man1/openssl-s_client.1.gz
|
||||
man/man1/openssl-s_server.1.gz
|
||||
man/man1/openssl-s_time.1.gz
|
||||
man/man1/openssl-sess_id.1.gz
|
||||
man/man1/openssl-smime.1.gz
|
||||
man/man1/openssl-speed.1.gz
|
||||
man/man1/openssl-spkac.1.gz
|
||||
man/man1/openssl-srp.1.gz
|
||||
man/man1/openssl-storeutl.1.gz
|
||||
man/man1/openssl-ts.1.gz
|
||||
man/man1/openssl-tsget.1.gz
|
||||
man/man1/openssl-verify.1.gz
|
||||
man/man1/openssl-version.1.gz
|
||||
man/man1/openssl-x509.1.gz
|
||||
man/man1/openssl.1.gz
|
||||
man/man1/passwd.1.gz
|
||||
man/man1/pkcs12.1.gz
|
||||
man/man1/pkcs7.1.gz
|
||||
man/man1/pkcs8.1.gz
|
||||
man/man1/pkey.1.gz
|
||||
man/man1/pkeyparam.1.gz
|
||||
man/man1/pkeyutl.1.gz
|
||||
man/man1/prime.1.gz
|
||||
man/man1/rand.1.gz
|
||||
man/man1/rehash.1.gz
|
||||
man/man1/req.1.gz
|
||||
man/man1/rsa.1.gz
|
||||
man/man1/rsautl.1.gz
|
||||
man/man1/s_client.1.gz
|
||||
man/man1/s_server.1.gz
|
||||
man/man1/s_time.1.gz
|
||||
man/man1/sess_id.1.gz
|
||||
man/man1/smime.1.gz
|
||||
man/man1/speed.1.gz
|
||||
man/man1/spkac.1.gz
|
||||
man/man1/srp.1.gz
|
||||
man/man1/storeutl.1.gz
|
||||
man/man1/ts.1.gz
|
||||
man/man1/tsget.1.gz
|
||||
man/man1/verify.1.gz
|
||||
man/man1/version.1.gz
|
||||
man/man1/x509.1.gz
|
||||
man/man5/config.5.gz
|
||||
man/man5/x509v3_config.5.gz
|
||||
man/man1/CA.pl.1ossl.gz
|
||||
man/man1/asn1parse.1ossl.gz
|
||||
man/man1/c_rehash.1ossl.gz
|
||||
man/man1/ca.1ossl.gz
|
||||
man/man1/ciphers.1ossl.gz
|
||||
man/man1/cmp.1ossl.gz
|
||||
man/man1/cms.1ossl.gz
|
||||
man/man1/crl.1ossl.gz
|
||||
man/man1/crl2pkcs7.1ossl.gz
|
||||
man/man1/dgst.1ossl.gz
|
||||
man/man1/dhparam.1ossl.gz
|
||||
man/man1/dsa.1ossl.gz
|
||||
man/man1/dsaparam.1ossl.gz
|
||||
man/man1/ec.1ossl.gz
|
||||
man/man1/ecparam.1ossl.gz
|
||||
man/man1/enc.1ossl.gz
|
||||
man/man1/engine.1ossl.gz
|
||||
man/man1/errstr.1ossl.gz
|
||||
man/man1/gendsa.1ossl.gz
|
||||
man/man1/genpkey.1ossl.gz
|
||||
man/man1/genrsa.1ossl.gz
|
||||
man/man1/info.1ossl.gz
|
||||
man/man1/kdf.1ossl.gz
|
||||
man/man1/mac.1ossl.gz
|
||||
man/man1/nseq.1ossl.gz
|
||||
man/man1/ocsp.1ossl.gz
|
||||
man/man1/openssl-asn1parse.1ossl.gz
|
||||
man/man1/openssl-ca.1ossl.gz
|
||||
man/man1/openssl-ciphers.1ossl.gz
|
||||
man/man1/openssl-cmds.1ossl.gz
|
||||
man/man1/openssl-cmp.1ossl.gz
|
||||
man/man1/openssl-cms.1ossl.gz
|
||||
man/man1/openssl-crl.1ossl.gz
|
||||
man/man1/openssl-crl2pkcs7.1ossl.gz
|
||||
man/man1/openssl-dgst.1ossl.gz
|
||||
man/man1/openssl-dhparam.1ossl.gz
|
||||
man/man1/openssl-dsa.1ossl.gz
|
||||
man/man1/openssl-dsaparam.1ossl.gz
|
||||
man/man1/openssl-ec.1ossl.gz
|
||||
man/man1/openssl-ecparam.1ossl.gz
|
||||
man/man1/openssl-enc.1ossl.gz
|
||||
man/man1/openssl-engine.1ossl.gz
|
||||
man/man1/openssl-errstr.1ossl.gz
|
||||
man/man1/openssl-fipsinstall.1ossl.gz
|
||||
man/man1/openssl-format-options.1ossl.gz
|
||||
man/man1/openssl-gendsa.1ossl.gz
|
||||
man/man1/openssl-genpkey.1ossl.gz
|
||||
man/man1/openssl-genrsa.1ossl.gz
|
||||
man/man1/openssl-info.1ossl.gz
|
||||
man/man1/openssl-kdf.1ossl.gz
|
||||
man/man1/openssl-list.1ossl.gz
|
||||
man/man1/openssl-mac.1ossl.gz
|
||||
man/man1/openssl-namedisplay-options.1ossl.gz
|
||||
man/man1/openssl-nseq.1ossl.gz
|
||||
man/man1/openssl-ocsp.1ossl.gz
|
||||
man/man1/openssl-passphrase-options.1ossl.gz
|
||||
man/man1/openssl-passwd.1ossl.gz
|
||||
man/man1/openssl-pkcs12.1ossl.gz
|
||||
man/man1/openssl-pkcs7.1ossl.gz
|
||||
man/man1/openssl-pkcs8.1ossl.gz
|
||||
man/man1/openssl-pkey.1ossl.gz
|
||||
man/man1/openssl-pkeyparam.1ossl.gz
|
||||
man/man1/openssl-pkeyutl.1ossl.gz
|
||||
man/man1/openssl-prime.1ossl.gz
|
||||
man/man1/openssl-rand.1ossl.gz
|
||||
man/man1/openssl-rehash.1ossl.gz
|
||||
man/man1/openssl-req.1ossl.gz
|
||||
man/man1/openssl-rsa.1ossl.gz
|
||||
man/man1/openssl-rsautl.1ossl.gz
|
||||
man/man1/openssl-s_client.1ossl.gz
|
||||
man/man1/openssl-s_server.1ossl.gz
|
||||
man/man1/openssl-s_time.1ossl.gz
|
||||
man/man1/openssl-sess_id.1ossl.gz
|
||||
man/man1/openssl-smime.1ossl.gz
|
||||
man/man1/openssl-speed.1ossl.gz
|
||||
man/man1/openssl-spkac.1ossl.gz
|
||||
man/man1/openssl-srp.1ossl.gz
|
||||
man/man1/openssl-storeutl.1ossl.gz
|
||||
man/man1/openssl-ts.1ossl.gz
|
||||
man/man1/openssl-verification-options.1ossl.gz
|
||||
man/man1/openssl-verify.1ossl.gz
|
||||
man/man1/openssl-version.1ossl.gz
|
||||
man/man1/openssl-x509.1ossl.gz
|
||||
man/man1/openssl.1ossl.gz
|
||||
man/man1/passwd.1ossl.gz
|
||||
man/man1/pkcs12.1ossl.gz
|
||||
man/man1/pkcs7.1ossl.gz
|
||||
man/man1/pkcs8.1ossl.gz
|
||||
man/man1/pkey.1ossl.gz
|
||||
man/man1/pkeyparam.1ossl.gz
|
||||
man/man1/pkeyutl.1ossl.gz
|
||||
man/man1/prime.1ossl.gz
|
||||
man/man1/rand.1ossl.gz
|
||||
man/man1/rehash.1ossl.gz
|
||||
man/man1/req.1ossl.gz
|
||||
man/man1/rsa.1ossl.gz
|
||||
man/man1/rsautl.1ossl.gz
|
||||
man/man1/s_client.1ossl.gz
|
||||
man/man1/s_server.1ossl.gz
|
||||
man/man1/s_time.1ossl.gz
|
||||
man/man1/sess_id.1ossl.gz
|
||||
man/man1/smime.1ossl.gz
|
||||
man/man1/speed.1ossl.gz
|
||||
man/man1/spkac.1ossl.gz
|
||||
man/man1/srp.1ossl.gz
|
||||
man/man1/storeutl.1ossl.gz
|
||||
man/man1/ts.1ossl.gz
|
||||
man/man1/tsget.1ossl.gz
|
||||
man/man1/verify.1ossl.gz
|
||||
man/man1/version.1ossl.gz
|
||||
man/man1/x509.1ossl.gz
|
||||
man/man5/config.5ossl.gz
|
||||
man/man5/fips_config.5ossl.gz
|
||||
man/man5/x509v3_config.5ossl.gz
|
||||
%%OPENSSLDIR%%/misc/CA.pl
|
||||
%%OPENSSLDIR%%/misc/tsget
|
||||
@comment %%OPENSSLDIR%%/misc/tsget.pl
|
||||
@sample %%OPENSSLDIR%%/openssl.cnf.dist %%OPENSSLDIR%%/openssl.cnf
|
||||
%%OPENSSLDIR%%/misc/tsget
|
||||
@sample %%OPENSSLDIR%%/ct_log_list.cnf.dist %%OPENSSLDIR%%/ct_log_list.cnf
|
||||
%%FIPS%%%%OPENSSLDIR%%/fipsmodule.cnf
|
||||
@sample %%OPENSSLDIR%%/openssl.cnf.dist %%OPENSSLDIR%%/openssl.cnf
|
||||
@dir lib/ossl-modules
|
||||
@dir %%OPENSSLDIR%%/private
|
||||
@dir %%OPENSSLDIR%%/certs
|
||||
|
|
|
@ -1 +1 @@
|
|||
OPENSSL_SHLIBVER?= 11
|
||||
OPENSSL_SHLIBVER?= 12
|
||||
|
|
Loading…
Reference in a new issue