Add linux-jdk14 , sun's Java Developers Kit for Linux, version 1.4.
PR: 27644 Submitted by: Ernst de Haan <ernst@jollem.com>
This commit is contained in:
parent
e3433b69f0
commit
d60a2edb4e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43055
15 changed files with 2515 additions and 0 deletions
|
@ -31,6 +31,7 @@
|
|||
SUBDIR += kaffe
|
||||
SUBDIR += linux-jdk
|
||||
SUBDIR += linux-jdk13
|
||||
SUBDIR += linux-jdk14
|
||||
SUBDIR += netrexx
|
||||
SUBDIR += openjit
|
||||
SUBDIR += orion
|
||||
|
|
59
java/linux-jdk14/Makefile
Normal file
59
java/linux-jdk14/Makefile
Normal file
|
@ -0,0 +1,59 @@
|
|||
# New ports collection makefile for: Sun Linux JDK 1.4.x
|
||||
# Date created: 25 May 2001
|
||||
# Whom: Ernst de Haan <ernst@jollem.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= jdk
|
||||
PORTVERSION= ${JDK_VERSION:S/-//g}
|
||||
CATEGORIES= java devel
|
||||
MASTER_SITES= #
|
||||
PKGNAMEPREFIX= linux-
|
||||
DISTNAME= j2sdk-${JDK_VERSION:S/./_/g}-linux-i386
|
||||
EXTRACT_SUFX= .bin
|
||||
|
||||
MAINTAINER= ernst@jollem.com
|
||||
|
||||
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
|
||||
|
||||
NO_CDROM= "License doesn\'t allow distribution with fee"
|
||||
RESTRICTED= "Redistribution of repackaged binaries not permitted"
|
||||
|
||||
.if defined(BATCH) || defined(PACKAGE_BUILDING)
|
||||
IGNORE= "You can not legally distribute binaries"
|
||||
.endif
|
||||
|
||||
EXTRACT_CMD= # empty
|
||||
EXTRACT_BEFORE_ARGS= # empty
|
||||
EXTRACT_AFTER_ARGS= # empty
|
||||
|
||||
WRKSRC= ${WRKDIR}/j2sdk1.4.0
|
||||
PLIST_SUB+= TARGET_PREFIX=${TARGET_PREFIX:S/^${PREFIX}\///}
|
||||
|
||||
NO_BUILD= yes
|
||||
USE_LINUX= yes
|
||||
JDK_VERSION= 1.4.0-beta
|
||||
ONLY_FOR_ARCHS= i386
|
||||
TARGET_PREFIX?= ${PREFIX}/${PKGBASE}${PORTVERSION}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.for file in ${DISTFILES}
|
||||
.if !exists(${DISTDIR}/${file})
|
||||
IGNORE=You must manually fetch the Java 2 Development Kit ${JDK_VERSION} for Linux archive (${DISTFILES}) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again.
|
||||
.endif
|
||||
.endfor
|
||||
|
||||
post-fetch:
|
||||
@${CHMOD} +x ${DISTDIR}/${DISTFILES}
|
||||
|
||||
post-patch:
|
||||
find ${WRKSRC} -name '*.orig' -print | xargs ${RM} -f
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/${PKGNAMEPREFIX}jdk${PORTVERSION}
|
||||
${TAR} -C ${WRKSRC} -cf- . | ${TAR} -C ${PREFIX}/${PKGNAMEPREFIX}jdk${PORTVERSION} -xpf-
|
||||
${LOCALBASE}/bin/registervm "${PREFIX}/linux-jdk${PORTVERSION}/bin/java # Linux-JDK${PORTVERSION}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
java/linux-jdk14/distinfo
Normal file
1
java/linux-jdk14/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (j2sdk-1_4_0-beta-linux-i386.bin) = b4e711b578b953150f5c4c958179b545
|
13
java/linux-jdk14/files/patch-aa
Normal file
13
java/linux-jdk14/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- bin/.java_wrapper.orig Fri May 25 19:52:36 2001
|
||||
+++ bin/.java_wrapper Fri May 25 19:54:12 2001
|
||||
@@ -34,8 +34,8 @@
|
||||
# Resolve symlinks. See 4152645.
|
||||
while [ -L "$PRG" ]; do
|
||||
ls=`ls -ld "$PRG"`
|
||||
- link=`expr "$ls" : '.*-> \(.*\)$'`
|
||||
- if expr "$link" : '/' > /dev/null; then
|
||||
+ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
|
||||
+ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
|
||||
PRG="$link"
|
||||
else
|
||||
PRG="`dirname $PRG`/$link"
|
13
java/linux-jdk14/files/patch-ab
Normal file
13
java/linux-jdk14/files/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- jre/bin/.java_wrapper.orig Fri May 25 19:56:57 2001
|
||||
+++ jre/bin/.java_wrapper Fri May 25 19:57:11 2001
|
||||
@@ -34,8 +34,8 @@
|
||||
# Resolve symlinks. See 4152645.
|
||||
while [ -L "$PRG" ]; do
|
||||
ls=`ls -ld "$PRG"`
|
||||
- link=`expr "$ls" : '.*-> \(.*\)$'`
|
||||
- if expr "$link" : '/' > /dev/null; then
|
||||
+ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
|
||||
+ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
|
||||
PRG="$link"
|
||||
else
|
||||
PRG="`dirname $PRG`/$link"
|
1
java/linux-jdk14/pkg-comment
Normal file
1
java/linux-jdk14/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Sun's Java Developers Kit for Linux, version 1.4
|
3
java/linux-jdk14/pkg-descr
Normal file
3
java/linux-jdk14/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
The Sun Java Development Kit 1.4 for Linux.
|
||||
|
||||
WWW: http://java.sun.com/j2se/1.4/
|
1167
java/linux-jdk14/pkg-plist
Normal file
1167
java/linux-jdk14/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
59
java/linux-sun-jdk14/Makefile
Normal file
59
java/linux-sun-jdk14/Makefile
Normal file
|
@ -0,0 +1,59 @@
|
|||
# New ports collection makefile for: Sun Linux JDK 1.4.x
|
||||
# Date created: 25 May 2001
|
||||
# Whom: Ernst de Haan <ernst@jollem.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= jdk
|
||||
PORTVERSION= ${JDK_VERSION:S/-//g}
|
||||
CATEGORIES= java devel
|
||||
MASTER_SITES= #
|
||||
PKGNAMEPREFIX= linux-
|
||||
DISTNAME= j2sdk-${JDK_VERSION:S/./_/g}-linux-i386
|
||||
EXTRACT_SUFX= .bin
|
||||
|
||||
MAINTAINER= ernst@jollem.com
|
||||
|
||||
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
|
||||
|
||||
NO_CDROM= "License doesn\'t allow distribution with fee"
|
||||
RESTRICTED= "Redistribution of repackaged binaries not permitted"
|
||||
|
||||
.if defined(BATCH) || defined(PACKAGE_BUILDING)
|
||||
IGNORE= "You can not legally distribute binaries"
|
||||
.endif
|
||||
|
||||
EXTRACT_CMD= # empty
|
||||
EXTRACT_BEFORE_ARGS= # empty
|
||||
EXTRACT_AFTER_ARGS= # empty
|
||||
|
||||
WRKSRC= ${WRKDIR}/j2sdk1.4.0
|
||||
PLIST_SUB+= TARGET_PREFIX=${TARGET_PREFIX:S/^${PREFIX}\///}
|
||||
|
||||
NO_BUILD= yes
|
||||
USE_LINUX= yes
|
||||
JDK_VERSION= 1.4.0-beta
|
||||
ONLY_FOR_ARCHS= i386
|
||||
TARGET_PREFIX?= ${PREFIX}/${PKGBASE}${PORTVERSION}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.for file in ${DISTFILES}
|
||||
.if !exists(${DISTDIR}/${file})
|
||||
IGNORE=You must manually fetch the Java 2 Development Kit ${JDK_VERSION} for Linux archive (${DISTFILES}) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again.
|
||||
.endif
|
||||
.endfor
|
||||
|
||||
post-fetch:
|
||||
@${CHMOD} +x ${DISTDIR}/${DISTFILES}
|
||||
|
||||
post-patch:
|
||||
find ${WRKSRC} -name '*.orig' -print | xargs ${RM} -f
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/${PKGNAMEPREFIX}jdk${PORTVERSION}
|
||||
${TAR} -C ${WRKSRC} -cf- . | ${TAR} -C ${PREFIX}/${PKGNAMEPREFIX}jdk${PORTVERSION} -xpf-
|
||||
${LOCALBASE}/bin/registervm "${PREFIX}/linux-jdk${PORTVERSION}/bin/java # Linux-JDK${PORTVERSION}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
java/linux-sun-jdk14/distinfo
Normal file
1
java/linux-sun-jdk14/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (j2sdk-1_4_0-beta-linux-i386.bin) = b4e711b578b953150f5c4c958179b545
|
13
java/linux-sun-jdk14/files/patch-aa
Normal file
13
java/linux-sun-jdk14/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- bin/.java_wrapper.orig Fri May 25 19:52:36 2001
|
||||
+++ bin/.java_wrapper Fri May 25 19:54:12 2001
|
||||
@@ -34,8 +34,8 @@
|
||||
# Resolve symlinks. See 4152645.
|
||||
while [ -L "$PRG" ]; do
|
||||
ls=`ls -ld "$PRG"`
|
||||
- link=`expr "$ls" : '.*-> \(.*\)$'`
|
||||
- if expr "$link" : '/' > /dev/null; then
|
||||
+ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
|
||||
+ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
|
||||
PRG="$link"
|
||||
else
|
||||
PRG="`dirname $PRG`/$link"
|
13
java/linux-sun-jdk14/files/patch-ab
Normal file
13
java/linux-sun-jdk14/files/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- jre/bin/.java_wrapper.orig Fri May 25 19:56:57 2001
|
||||
+++ jre/bin/.java_wrapper Fri May 25 19:57:11 2001
|
||||
@@ -34,8 +34,8 @@
|
||||
# Resolve symlinks. See 4152645.
|
||||
while [ -L "$PRG" ]; do
|
||||
ls=`ls -ld "$PRG"`
|
||||
- link=`expr "$ls" : '.*-> \(.*\)$'`
|
||||
- if expr "$link" : '/' > /dev/null; then
|
||||
+ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
|
||||
+ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
|
||||
PRG="$link"
|
||||
else
|
||||
PRG="`dirname $PRG`/$link"
|
1
java/linux-sun-jdk14/pkg-comment
Normal file
1
java/linux-sun-jdk14/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Sun's Java Developers Kit for Linux, version 1.4
|
3
java/linux-sun-jdk14/pkg-descr
Normal file
3
java/linux-sun-jdk14/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
The Sun Java Development Kit 1.4 for Linux.
|
||||
|
||||
WWW: http://java.sun.com/j2se/1.4/
|
1167
java/linux-sun-jdk14/pkg-plist
Normal file
1167
java/linux-sun-jdk14/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue