audio/moony-lv2: Update 0.22.0 -> 0.26.0
This commit is contained in:
parent
85da5fdcbc
commit
d6d3f2622c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500886
6 changed files with 6 additions and 121 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= moony
|
||||
PORTVERSION= 0.22.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.26.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= https://gitlab.com/OpenMusicKontrollers/moony.lv2/repository/archive.tar.gz?ref=${PORTVERSION}&dummy=/
|
||||
PKGNAMESUFFIX= -lv2
|
||||
|
@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
|
||||
BUILD_DEPENDS= lv2>0:audio/lv2
|
||||
|
||||
USES= cmake compiler:c++11-lang gl pkgconfig
|
||||
USES= compiler:c++11-lang gl meson pkgconfig
|
||||
USE_XORG= x11 xext
|
||||
USE_GL= gl glu
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1502213227
|
||||
SHA256 (moony-0.22.0.tar.gz) = b6c765b05eed0a3a5f5361be5e8debeef44b7d1077a3d7c8b3095804066ad6c6
|
||||
SIZE (moony-0.22.0.tar.gz) = 2257133
|
||||
TIMESTAMP = 1557115489
|
||||
SHA256 (moony-0.26.0.tar.gz) = d53b9905eb57d8c1c05e53a0565e20172868037a6ab6e39b2014dcaf0719e7e4
|
||||
SIZE (moony-0.26.0.tar.gz) = 2580838
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2017-05-16 21:46:21 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -33,6 +33,17 @@ set(CMAKE_C_FLAGS "-Wshadow -Wimplicit-f
|
||||
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
||||
set(CMAKE_MODULE_LINKER_FLAGS "-Wl,-z,defs ${CMAKE_MODULE_LINKER_FLAGS}")
|
||||
set(CMAKE_MODULE_LINKER_FLAGS "-Wl,-z,nodelete ${CMAKE_MODULE_LINKER_FLAGS}")
|
||||
+elseif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
||||
+ # see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221341
|
||||
+ include(CheckLibraryExists)
|
||||
+ check_library_exists(m clog 'complex.h' FreeBSD_CLOG_EXISTS)
|
||||
+ check_library_exists(m cpow 'complex.h' FreeBSD_CPOW_EXISTS)
|
||||
+ if (FreeBSD_CLOG_EXISTS)
|
||||
+ set(CMAKE_C_FLAGS "-DFreeBSD_CLOG_EXISTS ${CMAKE_C_FLAGS}")
|
||||
+ endif()
|
||||
+ if (FreeBSD_CPOW_EXISTS)
|
||||
+ set(CMAKE_C_FLAGS "-DFreeBSD_CPOW_EXISTS ${CMAKE_C_FLAGS}")
|
||||
+ endif()
|
||||
elseif(WIN32)
|
||||
set(CMAKE_C_FLAGS "-mstackrealign ${CMAKE_C_FLAGS}")
|
||||
endif()
|
||||
@@ -350,21 +361,21 @@ if(BUILD_TESTING)
|
||||
endif()
|
||||
set_target_properties(moony_test PROPERTIES INTERPROCEDURAL_OPTIMIZATION true) # -flto
|
||||
target_link_libraries(moony_test ${LIBS})
|
||||
-
|
||||
- add_custom_command(
|
||||
- OUTPUT ${PROJECT_BINARY_DIR}/manual.html
|
||||
- COMMAND ${WINE} ${QEMU} ${PROJECT_BINARY_DIR}/moony_test
|
||||
- ${PROJECT_SOURCE_DIR}/manual/hilight.lua
|
||||
- ">"
|
||||
- ${PROJECT_BINARY_DIR}/manual.html
|
||||
- DEPENDS
|
||||
- moony_test
|
||||
- ${PROJECT_SOURCE_DIR}/plugin/lexer.lua
|
||||
- ${PROJECT_SOURCE_DIR}/plugin/moony.lua
|
||||
- ${PROJECT_SOURCE_DIR}/manual/hilight.lua
|
||||
- ${PROJECT_SOURCE_DIR}/manual/manual.html.in)
|
||||
- add_custom_target(moony_manual ALL DEPENDS ${PROJECT_BINARY_DIR}/manual.html)
|
||||
- install(FILES ${PROJECT_BINARY_DIR}/manual.html DESTINATION ${PLUGIN_DEST})
|
||||
+#
|
||||
+# add_custom_command(
|
||||
+# OUTPUT ${PROJECT_BINARY_DIR}/manual.html
|
||||
+# COMMAND ${WINE} ${QEMU} ${PROJECT_BINARY_DIR}/moony_test
|
||||
+# ${PROJECT_SOURCE_DIR}/manual/hilight.lua
|
||||
+# ">"
|
||||
+# ${PROJECT_BINARY_DIR}/manual.html
|
||||
+# DEPENDS
|
||||
+# moony_test
|
||||
+# ${PROJECT_SOURCE_DIR}/plugin/lexer.lua
|
||||
+# ${PROJECT_SOURCE_DIR}/plugin/moony.lua
|
||||
+# ${PROJECT_SOURCE_DIR}/manual/hilight.lua
|
||||
+# ${PROJECT_SOURCE_DIR}/manual/manual.html.in)
|
||||
+# add_custom_target(moony_manual ALL DEPENDS ${PROJECT_BINARY_DIR}/manual.html)
|
||||
+# install(FILES ${PROJECT_BINARY_DIR}/manual.html DESTINATION ${PLUGIN_DEST})
|
||||
|
||||
add_test(NAME API-Test COMMAND ${WINE} ${QEMU} moony_test ${PROJECT_SOURCE_DIR}/test/moony_test.lua)
|
||||
add_test(NAME Overflow-Test COMMAND ${WINE} ${QEMU} moony_test ${PROJECT_SOURCE_DIR}/test/moony_overflow.lua 0)
|
|
@ -1,47 +0,0 @@
|
|||
--- lcomplex/lcomplex.c.orig 2017-05-16 21:46:21 UTC
|
||||
+++ lcomplex/lcomplex.c
|
||||
@@ -7,6 +7,7 @@
|
||||
*/
|
||||
|
||||
#include <complex.h>
|
||||
+#include <math.h>
|
||||
|
||||
#include "lua.h"
|
||||
#include "lauxlib.h"
|
||||
@@ -78,6 +79,36 @@ static int Ltostring(lua_State *L) /**
|
||||
return 1;
|
||||
}
|
||||
|
||||
+#if !defined(FreeBSD_CLOG_EXISTS)
|
||||
+// Missing C99 functions clog and cpow: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221341
|
||||
+static Complex clog(Complex z) {return log(cabs(z)) + I * carg(z);}
|
||||
+#endif
|
||||
+#if !defined(FreeBSD_CPOW_EXISTS)
|
||||
+// from https://github.com/eblot/newlib/blob/master/newlib/libm/complex/cpow.c
|
||||
+static Complex
|
||||
+cpow(Complex a, Complex z)
|
||||
+{
|
||||
+ double complex w;
|
||||
+ double x, y, r, theta, absa, arga;
|
||||
+
|
||||
+ x = creal(z);
|
||||
+ y = cimag(z);
|
||||
+ absa = cabs(a);
|
||||
+ if (absa == 0.0) {
|
||||
+ return (0.0 + 0.0 * I);
|
||||
+ }
|
||||
+ arga = carg(a);
|
||||
+ r = pow(absa, x);
|
||||
+ theta = x * arga;
|
||||
+ if (y != 0.0) {
|
||||
+ r = r * exp(-y * arga);
|
||||
+ theta = theta + y * log(absa);
|
||||
+ }
|
||||
+ w = r * cos(theta) + (r * sin(theta)) * I;
|
||||
+ return w;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
#define A(f,e) static int L##f(lua_State *L) { return pushcomplex(L,e); }
|
||||
#define B(f) A(f,l_mathop(c##f)(Z(1),Z(2)))
|
||||
#define F(f) A(f,l_mathop(c##f)(Z(1)))
|
|
@ -1,11 +0,0 @@
|
|||
--- pugl/pugl/pugl_x11.c.orig 2017-05-16 21:46:21 UTC
|
||||
+++ pugl/pugl/pugl_x11.c
|
||||
@@ -648,7 +648,7 @@ puglPasteFromClipboard(PuglView* view, s
|
||||
if( (xevent.xselection.selection == impl->clipboard)
|
||||
&& (xevent.xselection.target == impl->utf8_string)
|
||||
&& (xevent.xselection.property == XA_PRIMARY) ) {
|
||||
- ulong nitems, rem;
|
||||
+ uint32_t nitems, rem;
|
||||
int format;
|
||||
uint8_t* data;
|
||||
Atom type;
|
|
@ -9,6 +9,7 @@ lib/lv2/moony.lv2/house.png
|
|||
lib/lv2/moony.lv2/layers.png
|
||||
lib/lv2/moony.lv2/lexer.lua
|
||||
lib/lv2/moony.lv2/manifest.ttl
|
||||
lib/lv2/moony.lv2/manual.html
|
||||
lib/lv2/moony.lv2/menu.png
|
||||
lib/lv2/moony.lv2/moony.lua
|
||||
lib/lv2/moony.lv2/moony.so
|
||||
|
|
Loading…
Reference in a new issue