cleanup: Remove expired ports:

2021-12-27 sysutils/asmon: Fails to build on modern FreeBSD
This commit is contained in:
Rene Ladan 2021-12-27 12:58:44 +01:00
parent 8a910d277f
commit d6ed974ce8
6 changed files with 1 additions and 58 deletions

1
MOVED
View file

@ -16700,3 +16700,4 @@ www/rubygem-rack20|www/rubygem-rack|2021-12-21|Remove obsoleted port. Use www/ru
www/rubygem-redis-rack1|www/rubygem-redis-rack|2021-12-21|Remove obsoleted port. Use www/rubygem-redis-rack instead
x11-toolkits/rubygem-gtksourceview2|x11-toolkits/rubygem-gtksourceview3|2021-12-21|Remove obsoleted port. Use x11-toolkits/rubygem-gtksourceview3 instead
x11-toolkits/rubygem-vte|x11-toolkits/rubygem-vte3|2021-12-21|Remove obsoleted port. Use x11-toolkits/rubygem-vte3 instead
sysutils/asmon||2021-12-27|Has expired: Fails to build on modern FreeBSD

View file

@ -59,7 +59,6 @@
SUBDIR += asfsm
SUBDIR += asmctl
SUBDIR += asmem
SUBDIR += asmon
SUBDIR += asusoled
SUBDIR += atf-fvp
SUBDIR += atf-master

View file

@ -1,41 +0,0 @@
# Created by: jack
PORTNAME= asmon
PORTVERSION= 0.61
PORTREVISION= 3
CATEGORIES= sysutils afterstep
MASTER_SITES= AFTERSTEP/apps/asmon
MAINTAINER= ports@FreeBSD.org
COMMENT= Swallowable applet monitors the CPU usage, memory, and swap, etc
LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_FreeBSD_13= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_FreeBSD_14= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_mips= fails to compile: asmon.c: storage size of 'sum' isn't known
BROKEN_mips64= fails to compile: asmon.c: storage size of 'sum' isn't known
DEPRECATED= Fails to build on modern FreeBSD
EXPIRATION_DATE= 2021-12-27
USES= gmake xorg
USE_CSTD= gnu89
USE_XORG= xpm x11
BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/asmon
CFLAGS+= -I${LOCALBASE}/include
ALL_TARGET= asmon
MAKE_ARGS+= LIBDIR="-L${LOCALBASE}/lib" \
SOLARIS_LIBS=-lkvm
PLIST_FILES= "@(,kmem,) bin/asmon"
post-patch:
${REINPLACE_CMD} -e 's:gcc:${CC} ${CFLAGS}:' ${BUILD_WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/asmon/asmon ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (asmon-0.61.tar.gz) = 27464768e267ea7985322ce03781edfdcd0a2c609667f06670338a2c8dfe4f94
SIZE (asmon-0.61.tar.gz) = 29602

View file

@ -1,11 +0,0 @@
--- asmon/asmon.c.orig 2000-07-20 11:08:47 UTC
+++ asmon/asmon.c
@@ -990,7 +990,7 @@ void DrawXmem(int Xpid, float total)
kproc = kvm_getprocs(kd, KERN_PROC_PID, Xpid, &kcnt);
- Xsize = kproc->kp_eproc.e_vm.vm_map.size / 1024;
+ Xsize = kproc->ki_size / 1024;
#endif
if(old_Xsize!=Xsize)
{

View file

@ -1,3 +0,0 @@
The asmon tool is an AfterStep look-n-feel memory, swap, cpu, and load
average monitor for X Windows. "Lights" indicate swap and vm paging.
Also displays system uptime or X memory usage.