sysutils/puppet: update to 3.8.2
unbreak on Ruby 2.2 [1] Approved by: swills (maintainer) Obtained from: safe_yaml upstream (commit e281053e) [1]
This commit is contained in:
parent
48ef6aa21d
commit
d7517bd832
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=393745
3 changed files with 14 additions and 9 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= puppet
|
||||
PORTVERSION= 3.8.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 3.8.2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
|
||||
|
||||
|
@ -52,11 +51,6 @@ BROKEN= PACKAGE_ROOT option patch is incompatible with PACKAGE_ORIGIN patch.
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# puppet 4.x should support ruby 2.2.x
|
||||
.if ${RUBY_VER} >= 2.2
|
||||
BROKEN= Does not work with Ruby 2.2
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPACKAGE_ORIGIN}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_origin
|
||||
RUN_DEPENDS+= rubygem-bzip2-ruby>=0:${PORTSDIR}/archivers/rubygem-bzip2-ruby
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (puppet-3.8.1.tar.gz) = 033d99125276c7062fa5928e3de38c5e487b406530b3c50e84027b3abfd945a8
|
||||
SIZE (puppet-3.8.1.tar.gz) = 2633982
|
||||
SHA256 (puppet-3.8.2.tar.gz) = 5a89c623f22fc96a2919801ff874b10f8f1a66e95c09976c73b257b8bbc39986
|
||||
SIZE (puppet-3.8.2.tar.gz) = 2637591
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb.orig 2015-08-06 16:17:42 UTC
|
||||
+++ lib/puppet/vendor/safe_yaml/lib/safe_yaml.rb
|
||||
@@ -3,7 +3,7 @@ require "yaml"
|
||||
# This needs to be defined up front in case any internal classes need to base
|
||||
# their behavior off of this.
|
||||
module SafeYAML
|
||||
- YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : "syck"
|
||||
+ YAML_ENGINE = defined?(YAML::ENGINE) ? YAML::ENGINE.yamler : (defined?(Psych) && YAML == Psych ? "psych" : "syck")
|
||||
end
|
||||
|
||||
require "set"
|
Loading…
Reference in a new issue