A mail reader for gnome. It supports local mail, pop3, and IMAP.
It can view mail files in mbox, maildir, and mh format. PR: ports/9007 Submitted by: Glenn Johnson <gljohns@bellsouth.net>
This commit is contained in:
parent
614a496483
commit
d76b7d3474
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15217
12 changed files with 224 additions and 0 deletions
30
mail/balsa/Makefile
Normal file
30
mail/balsa/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: balsa
|
||||
# Version required: 0.4.6.2
|
||||
# Date created: 02 December 1998
|
||||
# Whom: Glenn Johnson <gljohns@bellsouth.net>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= balsa-0.4.6.2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.balsa.net/dist/
|
||||
|
||||
MAINTAINER= gljohns@bellsouth.net
|
||||
|
||||
LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs \
|
||||
PropListgnome.1:${PORTSDIR}/devel/libPropListgnome
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
|
||||
--datadir=${PREFIX}/share/gnome \
|
||||
--with-gnome=${X11BASE}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
|
||||
-I${X11BASE}/include" \
|
||||
GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
|
||||
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
|
||||
|
||||
MAN1= balsa.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
mail/balsa/distinfo
Normal file
1
mail/balsa/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (balsa-0.4.6.2.tar.gz) = 08e1995aedc27b701b39df6082dd2a02
|
60
mail/balsa/files/patch-ab
Normal file
60
mail/balsa/files/patch-ab
Normal file
|
@ -0,0 +1,60 @@
|
|||
--- configure.orig Sat Oct 17 09:06:56 1998
|
||||
+++ configure Sun Dec 6 23:12:45 1998
|
||||
@@ -939,12 +939,12 @@
|
||||
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:944: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:944: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
|
||||
- . $gnome_prefix/gnomeConf.sh
|
||||
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
|
||||
+ . $prefix/share/gnome/gnomeConf.sh
|
||||
|
||||
else
|
||||
echo "$ac_t""not found" 1>&6
|
||||
@@ -2307,14 +2307,14 @@
|
||||
LDFLAGS="$LDFLAGS `echo $GTK_LIBS | sed 's/\(.*\)\(-lgtk.*\)/\1/'`"
|
||||
LIBS="$LIBS $GTK_LIBS"
|
||||
|
||||
-echo $ac_n "checking for PLGetProplistWithPath in -lPropList""... $ac_c" 1>&6
|
||||
-echo "configure:2312: checking for PLGetProplistWithPath in -lPropList" >&5
|
||||
-ac_lib_var=`echo PropList'_'PLGetProplistWithPath | sed 'y%./+-%__p_%'`
|
||||
+echo $ac_n "checking for PLGetProplistWithPath in -lPropListgnome""... $ac_c" 1>&6
|
||||
+echo "configure:2312: checking for PLGetProplistWithPath in -lPropListgnome" >&5
|
||||
+ac_lib_var=`echo PropListgnome'_'PLGetProplistWithPath | sed 'y%./+-%__p_%'`
|
||||
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lPropList $LIBS"
|
||||
+LIBS="-lPropListgnome $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 2320 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -2342,17 +2342,17 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
echo "$ac_t""yes" 1>&6
|
||||
- ac_tr_lib=HAVE_LIB`echo PropList | sed -e 's/[^a-zA-Z0-9_]/_/g' \
|
||||
+ ac_tr_lib=HAVE_LIB`echo PropListgnome | sed -e 's/[^a-zA-Z0-9_]/_/g' \
|
||||
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
|
||||
cat >> confdefs.h <<EOF
|
||||
#define $ac_tr_lib 1
|
||||
EOF
|
||||
|
||||
- LIBS="-lPropList $LIBS"
|
||||
+ LIBS="-lPropListgnome $LIBS"
|
||||
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
-{ echo "configure: error: *** libPropList not found. Please check http://www.balsa.net for information on the required files." 1>&2; exit 1; }
|
||||
+{ echo "configure: error: *** libPropListgnome not found. Please check http://www.balsa.net for information on the required files." 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
|
1
mail/balsa/pkg-comment
Normal file
1
mail/balsa/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A mail reader for the gnome interface.
|
10
mail/balsa/pkg-descr
Normal file
10
mail/balsa/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
A mail reader for gnome. It supports local mail, pop3, and IMAP. It can
|
||||
view mail files in mbox, maildir, and mh format. However, MIME is not
|
||||
working yet and you cannot use attachments.
|
||||
|
||||
The pop3 support is not complete. All mail retrieved will be left on the
|
||||
server, and hence retrieved again if not deleted through some other pop3
|
||||
client. I would recommend using fetchmail to retrieve pop3 mail.
|
||||
|
||||
Website:
|
||||
* http://www.balsa.net/
|
10
mail/balsa/pkg-plist
Normal file
10
mail/balsa/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
bin/balsa
|
||||
share/gnome/pixmaps/balsa/attachment.png
|
||||
share/gnome/pixmaps/balsa/balsa_logo.png
|
||||
share/gnome/pixmaps/balsa/balsa_icon.png
|
||||
share/locale/de/LC_MESSAGES/balsa.mo
|
||||
share/locale/fi/LC_MESSAGES/balsa.mo
|
||||
share/locale/fr/LC_MESSAGES/balsa.mo
|
||||
share/locale/ga/LC_MESSAGES/balsa.mo
|
||||
share/locale/ko/LC_MESSAGES/balsa.mo
|
||||
@dirrm share/gnome/pixmaps/balsa
|
30
mail/balsa2/Makefile
Normal file
30
mail/balsa2/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: balsa
|
||||
# Version required: 0.4.6.2
|
||||
# Date created: 02 December 1998
|
||||
# Whom: Glenn Johnson <gljohns@bellsouth.net>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= balsa-0.4.6.2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.balsa.net/dist/
|
||||
|
||||
MAINTAINER= gljohns@bellsouth.net
|
||||
|
||||
LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs \
|
||||
PropListgnome.1:${PORTSDIR}/devel/libPropListgnome
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
|
||||
--datadir=${PREFIX}/share/gnome \
|
||||
--with-gnome=${X11BASE}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
|
||||
-I${X11BASE}/include" \
|
||||
GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
|
||||
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
|
||||
|
||||
MAN1= balsa.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
mail/balsa2/distinfo
Normal file
1
mail/balsa2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (balsa-0.4.6.2.tar.gz) = 08e1995aedc27b701b39df6082dd2a02
|
60
mail/balsa2/files/patch-ab
Normal file
60
mail/balsa2/files/patch-ab
Normal file
|
@ -0,0 +1,60 @@
|
|||
--- configure.orig Sat Oct 17 09:06:56 1998
|
||||
+++ configure Sun Dec 6 23:12:45 1998
|
||||
@@ -939,12 +939,12 @@
|
||||
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:944: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:944: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
|
||||
- . $gnome_prefix/gnomeConf.sh
|
||||
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
|
||||
+ . $prefix/share/gnome/gnomeConf.sh
|
||||
|
||||
else
|
||||
echo "$ac_t""not found" 1>&6
|
||||
@@ -2307,14 +2307,14 @@
|
||||
LDFLAGS="$LDFLAGS `echo $GTK_LIBS | sed 's/\(.*\)\(-lgtk.*\)/\1/'`"
|
||||
LIBS="$LIBS $GTK_LIBS"
|
||||
|
||||
-echo $ac_n "checking for PLGetProplistWithPath in -lPropList""... $ac_c" 1>&6
|
||||
-echo "configure:2312: checking for PLGetProplistWithPath in -lPropList" >&5
|
||||
-ac_lib_var=`echo PropList'_'PLGetProplistWithPath | sed 'y%./+-%__p_%'`
|
||||
+echo $ac_n "checking for PLGetProplistWithPath in -lPropListgnome""... $ac_c" 1>&6
|
||||
+echo "configure:2312: checking for PLGetProplistWithPath in -lPropListgnome" >&5
|
||||
+ac_lib_var=`echo PropListgnome'_'PLGetProplistWithPath | sed 'y%./+-%__p_%'`
|
||||
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lPropList $LIBS"
|
||||
+LIBS="-lPropListgnome $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 2320 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -2342,17 +2342,17 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
echo "$ac_t""yes" 1>&6
|
||||
- ac_tr_lib=HAVE_LIB`echo PropList | sed -e 's/[^a-zA-Z0-9_]/_/g' \
|
||||
+ ac_tr_lib=HAVE_LIB`echo PropListgnome | sed -e 's/[^a-zA-Z0-9_]/_/g' \
|
||||
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
|
||||
cat >> confdefs.h <<EOF
|
||||
#define $ac_tr_lib 1
|
||||
EOF
|
||||
|
||||
- LIBS="-lPropList $LIBS"
|
||||
+ LIBS="-lPropListgnome $LIBS"
|
||||
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
-{ echo "configure: error: *** libPropList not found. Please check http://www.balsa.net for information on the required files." 1>&2; exit 1; }
|
||||
+{ echo "configure: error: *** libPropListgnome not found. Please check http://www.balsa.net for information on the required files." 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
|
1
mail/balsa2/pkg-comment
Normal file
1
mail/balsa2/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A mail reader for the gnome interface.
|
10
mail/balsa2/pkg-descr
Normal file
10
mail/balsa2/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
A mail reader for gnome. It supports local mail, pop3, and IMAP. It can
|
||||
view mail files in mbox, maildir, and mh format. However, MIME is not
|
||||
working yet and you cannot use attachments.
|
||||
|
||||
The pop3 support is not complete. All mail retrieved will be left on the
|
||||
server, and hence retrieved again if not deleted through some other pop3
|
||||
client. I would recommend using fetchmail to retrieve pop3 mail.
|
||||
|
||||
Website:
|
||||
* http://www.balsa.net/
|
10
mail/balsa2/pkg-plist
Normal file
10
mail/balsa2/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
bin/balsa
|
||||
share/gnome/pixmaps/balsa/attachment.png
|
||||
share/gnome/pixmaps/balsa/balsa_logo.png
|
||||
share/gnome/pixmaps/balsa/balsa_icon.png
|
||||
share/locale/de/LC_MESSAGES/balsa.mo
|
||||
share/locale/fi/LC_MESSAGES/balsa.mo
|
||||
share/locale/fr/LC_MESSAGES/balsa.mo
|
||||
share/locale/ga/LC_MESSAGES/balsa.mo
|
||||
share/locale/ko/LC_MESSAGES/balsa.mo
|
||||
@dirrm share/gnome/pixmaps/balsa
|
Loading…
Reference in a new issue