- fix OpenSSL handling

- add SIZE
- fix a minor configure warning

PR:		64389
Submitted by:	marius
Reminded by:	marius
Approved by:	maintainer
This commit is contained in:
Alexander Leidinger 2004-07-02 10:03:36 +00:00
parent cea7e62674
commit d77249ca37
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112769
10 changed files with 142 additions and 0 deletions

View file

@ -17,5 +17,6 @@ COMMENT= BitTorrent Client written in C for FreeBSD and Linux
GNU_CONFIGURE= yes
PLIST_FILES= bin/ctorrent
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (ctorrent-1.3.2.tar.gz) = 1bc787df91285a9cec8509617c3152d6
SIZE (ctorrent-1.3.2.tar.gz) = 87195

View file

@ -0,0 +1,14 @@
--- btcontent.cpp.orig Sun Feb 1 06:18:07 2004
+++ btcontent.cpp Fri Feb 13 03:09:22 2004
@@ -8,7 +8,11 @@
#else
#include <unistd.h>
#include <sys/param.h>
+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
+#include <sha.h>
+#elif defined(HAVE_LIBSSL)
#include <openssl/sha.h>
+#endif
#endif
#include <time.h>

View file

@ -0,0 +1,14 @@
--- btfiles.cpp.orig Sun Feb 1 06:33:16 2004
+++ btfiles.cpp Fri Feb 13 03:10:57 2004
@@ -8,7 +8,11 @@
#include <unistd.h>
#include <dirent.h>
#include <sys/param.h>
+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
+#include <sha.h>
+#elif defined(HAVE_LIBSSL)
#include <openssl/sha.h>
+#endif
#endif
#include <time.h>

View file

@ -0,0 +1,41 @@
--- configure.orig Sun Feb 1 07:15:43 2004
+++ configure Fri Feb 13 03:04:21 2004
@@ -2851,7 +2851,7 @@
int
main ()
{
-SHA1_Init ();
+XXXSHA1_Init ();
;
return 0;
}
@@ -2915,7 +2915,7 @@
int
main ()
{
-SHA1_Init ();
+XXXSHA1_Init ();
;
return 0;
}
@@ -3814,13 +3814,13 @@
echo "${ECHO_T}$ac_cv_header_openssl_sha_h" >&6
fi
-if test $ac_cv_header_openssl_sha_h = yes; then
- :
-else
- { { echo "$as_me:$LINENO: error: Error, OpenSSL header file sha.h not found." >&5
-echo "$as_me: error: Error, OpenSSL header file sha.h not found." >&2;}
- { (exit 1); exit 1; }; }
-fi
+#if test $ac_cv_header_openssl_sha_h = yes; then
+# :
+#else
+# { { echo "$as_me:$LINENO: error: Error, OpenSSL header file sha.h not found." >&5
+#echo "$as_me: error: Error, OpenSSL header file sha.h not found." >&2;}
+# { (exit 1); exit 1; }; }
+#fi

View file

@ -17,5 +17,6 @@ COMMENT= BitTorrent Client written in C for FreeBSD and Linux
GNU_CONFIGURE= yes
PLIST_FILES= bin/ctorrent
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (ctorrent-1.3.2.tar.gz) = 1bc787df91285a9cec8509617c3152d6
SIZE (ctorrent-1.3.2.tar.gz) = 87195

View file

@ -0,0 +1,14 @@
--- btcontent.cpp.orig Sun Feb 1 06:18:07 2004
+++ btcontent.cpp Fri Feb 13 03:09:22 2004
@@ -8,7 +8,11 @@
#else
#include <unistd.h>
#include <sys/param.h>
+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
+#include <sha.h>
+#elif defined(HAVE_LIBSSL)
#include <openssl/sha.h>
+#endif
#endif
#include <time.h>

View file

@ -0,0 +1,14 @@
--- btfiles.cpp.orig Sun Feb 1 06:33:16 2004
+++ btfiles.cpp Fri Feb 13 03:10:57 2004
@@ -8,7 +8,11 @@
#include <unistd.h>
#include <dirent.h>
#include <sys/param.h>
+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
+#include <sha.h>
+#elif defined(HAVE_LIBSSL)
#include <openssl/sha.h>
+#endif
#endif
#include <time.h>

View file

@ -0,0 +1,41 @@
--- configure.orig Sun Feb 1 07:15:43 2004
+++ configure Fri Feb 13 03:04:21 2004
@@ -2851,7 +2851,7 @@
int
main ()
{
-SHA1_Init ();
+XXXSHA1_Init ();
;
return 0;
}
@@ -2915,7 +2915,7 @@
int
main ()
{
-SHA1_Init ();
+XXXSHA1_Init ();
;
return 0;
}
@@ -3814,13 +3814,13 @@
echo "${ECHO_T}$ac_cv_header_openssl_sha_h" >&6
fi
-if test $ac_cv_header_openssl_sha_h = yes; then
- :
-else
- { { echo "$as_me:$LINENO: error: Error, OpenSSL header file sha.h not found." >&5
-echo "$as_me: error: Error, OpenSSL header file sha.h not found." >&2;}
- { (exit 1); exit 1; }; }
-fi
+#if test $ac_cv_header_openssl_sha_h = yes; then
+# :
+#else
+# { { echo "$as_me:$LINENO: error: Error, OpenSSL header file sha.h not found." >&5
+#echo "$as_me: error: Error, OpenSSL header file sha.h not found." >&2;}
+# { (exit 1); exit 1; }; }
+#fi