cad/kicad-devel: use wx 32
PR: 265093
This commit is contained in:
parent
d5bd9f5d05
commit
d775565a3b
3 changed files with 55 additions and 2 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= kicad
|
||||
DISTVERSION= r${GIT_SRC_DATE}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= cad
|
||||
PKGNAMESUFFIX= -devel
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
@ -42,7 +42,7 @@ GL_ACCOUNT= kicad/code
|
|||
GL_PROJECT= kicad
|
||||
GL_COMMIT= ${GIT_SRC_HASH}
|
||||
USE_GL= gl glew glu glut
|
||||
USE_WX= 3.1
|
||||
USE_WX= 3.2
|
||||
WX_COMPS= wx python:lib
|
||||
USE_GNOME= atk cairo gtk30 gdkpixbuf2 pango
|
||||
USE_XORG+= ice pixman x11 xext
|
||||
|
|
|
@ -0,0 +1,23 @@
|
|||
--- eeschema/sim/sim_plot_frame.cpp.orig 2022-09-14 16:35:24 UTC
|
||||
+++ eeschema/sim/sim_plot_frame.cpp
|
||||
@@ -167,15 +167,15 @@ SIM_PLOT_FRAME::SIM_PLOT_FRAME( KIWAY* aKiway, wxWindo
|
||||
Bind( EVT_SIM_CURSOR_UPDATE, &SIM_PLOT_FRAME::onCursorUpdate, this );
|
||||
|
||||
// Toolbar buttons
|
||||
- m_toolSimulate = m_toolBar->AddTool( ID_SIM_RUN, _( "Run/Stop Simulation" ),
|
||||
+ m_toolSimulate = m_toolBar->AddTool( ID_SIM_RUN, wxEmptyString,
|
||||
KiBitmap( BITMAPS::sim_run ), _( "Run Simulation" ), wxITEM_NORMAL );
|
||||
- m_toolAddSignals = m_toolBar->AddTool( ID_SIM_ADD_SIGNALS, _( "Add Signals" ),
|
||||
+ m_toolAddSignals = m_toolBar->AddTool( ID_SIM_ADD_SIGNALS, wxEmptyString,
|
||||
KiBitmap( BITMAPS::sim_add_signal ), _( "Add signals to plot" ), wxITEM_NORMAL );
|
||||
- m_toolProbe = m_toolBar->AddTool( ID_SIM_PROBE, _( "Probe" ),
|
||||
+ m_toolProbe = m_toolBar->AddTool( ID_SIM_PROBE, wxEmptyString,
|
||||
KiBitmap( BITMAPS::sim_probe ), _( "Probe signals on the schematic" ), wxITEM_NORMAL );
|
||||
- m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, _( "Tune" ),
|
||||
+ m_toolTune = m_toolBar->AddTool( ID_SIM_TUNE, wxEmptyString,
|
||||
KiBitmap( BITMAPS::sim_tune ), _( "Tune component values" ), wxITEM_NORMAL );
|
||||
- m_toolSettings = m_toolBar->AddTool( wxID_ANY, _( "Sim Parameters" ),
|
||||
+ m_toolSettings = m_toolBar->AddTool( wxID_ANY, wxEmptyString,
|
||||
KiBitmap( BITMAPS::config ), _( "Simulation parameters and settings" ), wxITEM_NORMAL );
|
||||
|
||||
// Start all toolbar buttons except settings as disabled
|
|
@ -0,0 +1,30 @@
|
|||
--- thirdparty/nanodbc/CMakeLists.txt.orig 2022-09-14 12:06:32 UTC
|
||||
+++ thirdparty/nanodbc/CMakeLists.txt
|
||||
@@ -165,16 +165,11 @@ elseif(MINGW)
|
||||
endif()
|
||||
|
||||
########################################
|
||||
-## Mac OS X specifics for targets
|
||||
+## FreeBSD specifics for targets
|
||||
########################################
|
||||
-if(APPLE)
|
||||
- set(CMAKE_MACOSX_RPATH ON)
|
||||
- message(STATUS "Use rpaths on Mac OS X - ${CMAKE_MACOSX_RPATH}")
|
||||
-
|
||||
- # AppleClang complains of unused `-I/path/` arguments.
|
||||
- # These are harmless and can be safely ignored.
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-command-line-argument")
|
||||
-endif()
|
||||
+# Clang complains of unused `-I/path/` arguments.
|
||||
+# These are harmless and can be safely ignored.
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-command-line-argument")
|
||||
|
||||
########################################
|
||||
## library target
|
||||
@@ -202,4 +197,4 @@ endif()
|
||||
if(NANODBC_ENABLE_UNICODE)
|
||||
add_compile_definitions(NANODBC_ENABLE_UNICODE)
|
||||
target_compile_definitions(nanodbc PUBLIC NANODBC_ENABLE_UNICODE)
|
||||
-endif()
|
||||
\ No newline at end of file
|
||||
+endif()
|
Loading…
Reference in a new issue