Unbreak video recording.
Since I'm here, make some cleaning and add some explicit dependencies. PR: 235951 Submitted by: romain
This commit is contained in:
parent
5ad3870d32
commit
d77fc6ab70
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493711
3 changed files with 44 additions and 14 deletions
|
@ -3,7 +3,7 @@
|
||||||
|
|
||||||
PORTNAME= xvidcap
|
PORTNAME= xvidcap
|
||||||
PORTVERSION= 1.1.7
|
PORTVERSION= 1.1.7
|
||||||
PORTREVISION= 9
|
PORTREVISION= 10
|
||||||
PORTEPOCH= 1
|
PORTEPOCH= 1
|
||||||
CATEGORIES= sysutils multimedia
|
CATEGORIES= sysutils multimedia
|
||||||
MASTER_SITES= SF
|
MASTER_SITES= SF
|
||||||
|
@ -15,22 +15,26 @@ LICENSE= GPLv3
|
||||||
|
|
||||||
BUILD_DEPENDS= xml2po:textproc/gnome-doc-utils \
|
BUILD_DEPENDS= xml2po:textproc/gnome-doc-utils \
|
||||||
scrollkeeper-config:textproc/rarian
|
scrollkeeper-config:textproc/rarian
|
||||||
LIB_DEPENDS= libswscale.so:multimedia/ffmpeg \
|
LIB_DEPENDS= libdbus-1.so:devel/dbus \
|
||||||
|
libfreetype.so:print/freetype2 \
|
||||||
|
libswscale.so:multimedia/ffmpeg \
|
||||||
libdbus-glib-1.so:devel/dbus-glib \
|
libdbus-glib-1.so:devel/dbus-glib \
|
||||||
|
libfontconfig.so:x11-fonts/fontconfig \
|
||||||
libmp3lame.so:audio/lame
|
libmp3lame.so:audio/lame
|
||||||
RUN_DEPENDS= animate:graphics/ImageMagick6 \
|
RUN_DEPENDS= animate:graphics/ImageMagick6 \
|
||||||
gimp:graphics/gimp-app
|
gimp:graphics/gimp-app
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
# --export-dynamic fixes libglade problems
|
|
||||||
LDFLAGS+= -Wl,--export-dynamic
|
|
||||||
|
|
||||||
USE_GNOME= glib20 libglade2 intltool
|
|
||||||
USES= gettext gmake gnome localbase pkgconfig
|
USES= gettext gmake gnome localbase pkgconfig
|
||||||
USE_XORG= x11 xmu ice xfixes xdamage
|
|
||||||
|
USE_GNOME= cairo gdkpixbuf2 glib20 libglade2 intltool
|
||||||
|
USE_XORG= x11 xext xmu ice xfixes xdamage
|
||||||
INSTALLS_OMF= yes
|
INSTALLS_OMF= yes
|
||||||
MANLANG= "" de es it
|
MANLANG= "" de es it
|
||||||
|
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
# --export-dynamic fixes libglade problems
|
||||||
|
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--export-dynamic -lz
|
||||||
|
|
||||||
.if !defined(CFLAGS) || ${CFLAGS:M-fno-strict-aliasing*} == ""
|
.if !defined(CFLAGS) || ${CFLAGS:M-fno-strict-aliasing*} == ""
|
||||||
CFLAGS+= -O2 -fno-strict-aliasing
|
CFLAGS+= -O2 -fno-strict-aliasing
|
||||||
.endif
|
.endif
|
||||||
|
@ -40,12 +44,14 @@ NULLDOCS= COPYING
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
post-patch:
|
pre-configure:
|
||||||
${REINPLACE_CMD} -e 's|/bin/bash | /bin/sh|' ${WRKSRC}/ppm2mpeg.sh
|
${REINPLACE_CMD} -e 's|/bin/bash | /bin/sh|' ${WRKSRC}/ppm2mpeg.sh
|
||||||
@${REINPLACE_CMD} '/^xvidcap_LDADD =/s/$$/ -lXext -lX11/' \
|
${REINPLACE_CMD} '/^xvidcap_LDADD =/s/$$/ -lXext -lX11/' \
|
||||||
${WRKSRC}/src/Makefile.in
|
${WRKSRC}/src/Makefile.in
|
||||||
|
${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||||
|
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||||
|
|
||||||
post-patch-DOCS-on:
|
pre-configure-DOCS-on:
|
||||||
${REINPLACE_CMD} -e 's|pkgdataDATA install-xvidcapdocDATA|pkgdataDATA|' \
|
${REINPLACE_CMD} -e 's|pkgdataDATA install-xvidcapdocDATA|pkgdataDATA|' \
|
||||||
${WRKSRC}/Makefile.in
|
${WRKSRC}/Makefile.in
|
||||||
|
|
||||||
|
|
24
sysutils/xvidcap/files/patch-configure
Normal file
24
sysutils/xvidcap/files/patch-configure
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
--- configure.orig 2008-07-09 07:28:25 UTC
|
||||||
|
+++ configure
|
||||||
|
@@ -11280,7 +11280,7 @@ if ( `test \( \( x${ac_cv_lib_avutil_av_rescale+set} =
|
||||||
|
# build embedded ffmpeg
|
||||||
|
echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && \
|
||||||
|
( cd ./ffmpeg/ && \
|
||||||
|
- ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lib_switch} --enable-pthreads --enable-swscale --disable-ffserver --disable-ffplay && \
|
||||||
|
+ ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lib_switch} --enable-pthreads --enable-swscale --disable-ffserver --disable-ffplay --extra-cflags=-I%%LOCALBASE%%/include --extra-ldflags=-L%%LOCALBASE%%/lib --disable-demuxer=v4l2 --disable-mmx && \
|
||||||
|
ln -s libavcodec/avcodec.h ./ && \
|
||||||
|
ln -s libavcodec/dsputil.h ./ && \
|
||||||
|
ln -s libavformat/avformat.h ./ && \
|
||||||
|
@@ -11296,10 +11296,10 @@ if ( `test \( \( x${ac_cv_lib_avutil_av_rescale+set} =
|
||||||
|
ln -s libswscale/swscale.h ./ && \
|
||||||
|
ln -s libswscale/rgb2rgb.h ./ && \
|
||||||
|
ln -s libavdevice/avdevice.h ./ && \
|
||||||
|
- ${MAKE-make} )
|
||||||
|
+ ${MAKE-gmake} )
|
||||||
|
# try to link it statically, or reset cache, set static_avcodec=no
|
||||||
|
top_srcdir=`pwd`
|
||||||
|
- ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="${LDFLAGS} -L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale -L$top_srcdir/ffmpeg/libavdevice"
|
||||||
|
+ ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="-L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale -L$top_srcdir/ffmpeg/libavdevice ${LDFLAGS}"
|
||||||
|
ac_my_cflags_save=${CFLAGS} ; CFLAGS="${CFLAGS} -I $top_srcdir -I$top_srcdir/ffmpeg/libavcodec -I$top_srcdir/ffmpeg/libavformat -I$top_srcdir/ffmpeg/libavutil -I$top_srcdir/ffmpeg/libswscale -I$top_srcdir/ffmpeg/libavdevice"
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- ./src/gnome_ui.c.orig 2008-06-12 22:48:03.000000000 +0200
|
--- src/gnome_ui.c.orig 2008-06-12 20:48:03 UTC
|
||||||
+++ ./src/gnome_ui.c 2014-04-30 22:44:15.000000000 +0200
|
+++ src/gnome_ui.c
|
||||||
@@ -1679,7 +1679,7 @@
|
@@ -1679,7 +1679,7 @@ xvc_init_pre (int argc, char **argv)
|
||||||
{
|
{
|
||||||
#define DEBUGFUNCTION "xvc_init_pre()"
|
#define DEBUGFUNCTION "xvc_init_pre()"
|
||||||
g_thread_init (NULL);
|
g_thread_init (NULL);
|
Loading…
Reference in a new issue