french/gibi: IGNORE for more than 6 months
This commit is contained in:
parent
293b2ff20c
commit
d7927a5ef6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=314594
10 changed files with 1 additions and 178 deletions
1
LEGAL
1
LEGAL
|
@ -108,7 +108,6 @@ fvcom/sourcecode1.tar.gz science/fvcom* Requires (free) registration
|
|||
fwtk/* security/fwtk No redistribution allowed
|
||||
gamess.*/gamess* science/gamess No Redistribution
|
||||
giac-* math/giacxcas The french documentation is for non commercial only use
|
||||
gibi-* french/gibi Only free for use in conjunction with french/aster. For any other purpose, you have to acquire a license
|
||||
giftool* graphics/giftool Do not redistribute for profit
|
||||
glimpse-* textproc/glimpse Do not sell for profit
|
||||
gnome2/mcitymicrogui-default* x11-themes/metacity-theme-microgui Themes may contain artwork not done by the author. Keep FreeBSD safe if the theme author violated copyrights
|
||||
|
|
1
MOVED
1
MOVED
|
@ -4170,3 +4170,4 @@ net-mgmt/zabbix-proxy|net-mgmt/zabbix2-proxy|2013-03-15|Has expired: no longer s
|
|||
net-mgmt/zabbix-server|net-mgmt/zabbix2-server|2013-03-15|Has expired: no longer supported by upstream
|
||||
dns/h2n||2013-03-17|Removed: legally questionable and obsolete
|
||||
sysutils/facter|sysutils/rubygem-facter|2013-03-17|Renamed to match naming convention for rubygems
|
||||
french/gibi||2013-03-18|Removed: IGNORE for more than 6 months
|
||||
|
|
|
@ -18,7 +18,6 @@
|
|||
SUBDIR += fortune-mod-zarathoustra
|
||||
SUBDIR += geonext
|
||||
SUBDIR += gfaim
|
||||
SUBDIR += gibi
|
||||
SUBDIR += gimp-help
|
||||
SUBDIR += homard
|
||||
SUBDIR += hunspell
|
||||
|
|
|
@ -1,114 +0,0 @@
|
|||
# Created by: Thierry Thomas <thierry@pompo.net>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gibi
|
||||
DISTVERSION= 2003-2
|
||||
DISTVERSIONSUFFIX= .i386
|
||||
PORTREVISION= 19
|
||||
CATEGORIES= french cad linux
|
||||
MASTER_SITES= http://www.code-aster.org/V2/UPLOAD/DOC/Telechargement/
|
||||
EXTRACT_SUFX= .tar
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GIBI est la partie mailleur et post de CASTEM
|
||||
|
||||
#-----------------------------------------------------------------------
|
||||
# You may define these options:
|
||||
#
|
||||
# - WITH_ZSH or WITH_BASH or WITH_KSH: select a shell among
|
||||
# zsh (default), bash or ksh.
|
||||
#-----------------------------------------------------------------------
|
||||
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/aster/${vaster}/asteru:${PORTSDIR}/french/aster
|
||||
RUN_DEPENDS+= ${LOCALBASE}/aster/${vaster}/asteru:${PORTSDIR}/french/aster \
|
||||
${SHELL_RUN_GIBI}:${PORTSDIR}/shells/${SHRGDEP}
|
||||
|
||||
# you can only use the GIBI software with Code_Aster.
|
||||
# All other usage requires a special license.
|
||||
RESTRICTED= Toute personne chargeant le logiciel GIBI s'engage à ne\
|
||||
l'utiliser qu'en couplage avec le logiciel Code_Aster. Pour\
|
||||
tout autre usage, un droit de licence est nécessaire.
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_LINUX= yes
|
||||
USE_LINUX_APPS= libg2c
|
||||
REINPLACE_ARGS= -i ""
|
||||
NO_BUILD= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
|
||||
|
||||
.if defined(WITH_ZSH)
|
||||
SHRG= zsh
|
||||
.elif defined(WITH_BASH)
|
||||
SHRG= bash
|
||||
.elif defined(WITH_KSH)
|
||||
SHRG= ksh93
|
||||
.elif exists(${LOCALBASE}/bin/zsh)
|
||||
SHRG= zsh
|
||||
.elif exists(${LOCALBASE}/bin/bash)
|
||||
SHRG= bash
|
||||
.elif exists(${LOCALBASE}/bin/ksh93)
|
||||
SHRG= ksh93
|
||||
.else
|
||||
SHRG= zsh
|
||||
.endif
|
||||
SHRGDEP= ${SHRG}
|
||||
SHELL_RUN_GIBI= ${LOCALBASE}/bin/${SHRG}
|
||||
|
||||
LGIBIDIR?= apps/${PORTNAME}
|
||||
GIBIDIR= ${PREFIX}/${LGIBIDIR}
|
||||
ASTER_VER= 10.6
|
||||
vaster= STA${ASTER_VER}
|
||||
ASTER_TOOLS= ${LOCALBASE}/aster/outils
|
||||
KERVER= 2.4.1
|
||||
ARCHIVER= PCLinuxK${KERVER:R}_${PORTVERSION:R}
|
||||
KINSTALL= kinstall_PC_Linux_${PORTVERSION:R}
|
||||
GIBIBIN= ${PORTNAME}${PORTVERSION:R}
|
||||
|
||||
INST_ENV= LD_ASSUME_KERNEL=${KERVER} CASTEM="${GIBIDIR}" \
|
||||
ESOPE_PARAM='ESOPE=30000000,NTRK=50000,LTRK=1048576' \
|
||||
MIF_PATH=${GIBIDIR}/header CASTEM_ERREUR=${GIBIDIR}/GIBI.ERREUR \
|
||||
CASTEM_NOTICE=${GIBIDIR}/GIBI.MASTER CPU=16 ESOPE_TEMP='/tmp' \
|
||||
CASTEM_PROC=${GIBIDIR}/GIBI.PROC
|
||||
|
||||
PLIST_SUB= GIBIDIR=${LGIBIDIR} ASTER_TOOLS=${ASTER_TOOLS} \
|
||||
GIBIVER=${PORTVERSION:R} KERVER=${KERVER:R}
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e "s|/usr/local/apps/gibi|${GIBIDIR}|" \
|
||||
-e "s|/bin/bash|${SHELL_RUN_GIBI}|" \
|
||||
${WRKSRC}/${GIBIBIN}
|
||||
${REINPLACE_CMD} -e "s|?PYTHON_EXE?|/usr/bin/env python|" \
|
||||
-e "s|?HOME_GIBI?|${GIBIDIR}|" \
|
||||
${WRKSRC}/gibi_aster.py
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${GIBIDIR}
|
||||
.for FICH in GIBI.ERREUR GIBI.MASTER GIBI.PROC USRDAT header
|
||||
${CP} -Rp ${WRKSRC}/${FICH} ${GIBIDIR}
|
||||
.endfor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${GIBIBIN} ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${ARCHIVER} ${GIBIDIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${KINSTALL} ${GIBIDIR}
|
||||
${BRANDELF} -t Linux ${GIBIDIR}/${PORTNAME}${ARCHIVER}
|
||||
${BRANDELF} -t Linux ${GIBIDIR}/${KINSTALL}
|
||||
(cd ${GIBIDIR} \
|
||||
&& ${INST_ENV} ./${KINSTALL} < ${FILESDIR}/clef \
|
||||
&& ${CHMOD} 666 USRDAT)
|
||||
${RM} ${GIBIDIR}/${KINSTALL}
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${GIBIDIR}
|
||||
${LN} -fs ${PREFIX}/bin/${GIBIBIN} ${ASTER_TOOLS}/${PORTNAME}
|
||||
${LN} -fs ${PREFIX}/bin/${GIBIBIN} ${ASTER_TOOLS}
|
||||
|
||||
post-install:
|
||||
@${ECHO_MSG}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_MSG}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} > 800079
|
||||
IGNORE= the port can't be used with the default linux base port (linux_base-f10)
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (gibi-2003-2.i386.tar) = 6964b600c8ae721a941092e57312746f707e3f61d5bcb3a8814ce044facb7d1e
|
||||
SIZE (gibi-2003-2.i386.tar) = 8057892
|
|
@ -1,8 +0,0 @@
|
|||
y
|
||||
2011
|
||||
12
|
||||
31
|
||||
11
|
||||
1
|
||||
0
|
||||
3818255
|
|
@ -1,10 +0,0 @@
|
|||
--- gibi2003.orig Mon Mar 14 16:51:57 2005
|
||||
+++ gibi2003 Mon Jul 3 23:48:46 2006
|
||||
@@ -5,6 +5,7 @@
|
||||
# variable(s) a mettre a jour pour la version a creer
|
||||
castemscript='gibi2003'
|
||||
castX='gibiPCLinuxK2.4_2003'
|
||||
+export CASTEM='/usr/local/apps/gibi'
|
||||
DIR=$CASTEM
|
||||
|
||||
if [[ $DIR = "" ]] ; then
|
|
@ -1,6 +0,0 @@
|
|||
GIBI est la partie mailleur et post de CAST3M.
|
||||
|
||||
Code_Aster sait relire les fichiers de maillage issus de GIBI, et produit
|
||||
des résultats pour un post-traitement dans GIBI.
|
||||
|
||||
WWW: http://www.code-aster.org/outils/gibi/
|
|
@ -1,19 +0,0 @@
|
|||
Avertissement
|
||||
=============
|
||||
|
||||
Toute personne chargeant le logiciel GIBI s'engage à ne l'utiliser qu'en
|
||||
couplage avec le logiciel Code_ASTER. Pour tout autre usage, un droit de
|
||||
licence est nécessaire.
|
||||
|
||||
Contacter le C.E.A. à l'adresse : <kk2000@semt2.smts.cea.fr>.
|
||||
|
||||
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
|
||||
|
||||
Warning
|
||||
=======
|
||||
|
||||
You can use GIBI freely in conjunction with Code_Aster (i.e. the FreeBSD
|
||||
port french/aster).
|
||||
|
||||
If you want to use GIBI for any other purpose, you have to acquire a
|
||||
license: please contact <kk2000@semt2.smts.cea.fr>.
|
|
@ -1,17 +0,0 @@
|
|||
bin/gibi%%GIBIVER%%
|
||||
%%GIBIDIR%%/GIBI.ERREUR
|
||||
%%GIBIDIR%%/GIBI.MASTER
|
||||
%%GIBIDIR%%/GIBI.PROC
|
||||
%%GIBIDIR%%/USRDAT
|
||||
%%GIBIDIR%%/gibiPCLinuxK%%KERVER%%_%%GIBIVER%%
|
||||
%%GIBIDIR%%/header/color.bw
|
||||
%%GIBIDIR%%/header/color.co
|
||||
%%GIBIDIR%%/header/mifheader.la
|
||||
%%GIBIDIR%%/header/mifheader.po
|
||||
@dirrm %%GIBIDIR%%/header
|
||||
@dirrm %%GIBIDIR%%
|
||||
@exec ln -sf %D/bin/gibi%%GIBIVER%% %%ASTER_TOOLS%%
|
||||
@exec ln -sf %D/bin/gibi%%GIBIVER%% %%ASTER_TOOLS%%/gibi
|
||||
@unexec rm -f %%ASTER_TOOLS%%/gibi
|
||||
@unexec rm -f %%ASTER_TOOLS%%/gibi%%GIBIVER%%
|
||||
@dirrmtry apps
|
Loading…
Reference in a new issue