databases/mariadb55-server: Security update to 5.5.60

- Fix build with aarch64 [1]
 - Remove new ${name}_limits behavior from 11-STABLE [2]

PR:		227628 [1], 227434 [2]
Submitted by:	Naram Qashat <cyberbotx cyberbotx com> [1], 0mp [2]
MFH:		2018Q2
Security:	57aec168-453e-11e8-8777-b499baebfeaf
This commit is contained in:
Bernard Spil 2018-04-23 19:12:24 +00:00
parent 6c726e9d8c
commit d7bc97ea5d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468131
3 changed files with 55 additions and 10 deletions

View file

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME?= mariadb
PORTVERSION= 5.5.59
PORTREVISION?= 2
PORTVERSION= 5.5.60
PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/mariadb/${PORTNAME}-${PORTVERSION}/source/ \
http://mirrors.supportex.net/mariadb/${PORTNAME}-${PORTVERSION}/source/ \
@ -50,7 +50,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
DATADIR= ${PREFIX}/share/mysql
BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_sparc64= Does not compile: Unsupported platform
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct dh_st'
@ -104,11 +103,10 @@ MAXKEY_EXTRA_PATCHES= ${FILESDIR}/extra-patch-include_my__compare.h
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1101514 || \
${OSVERSION} >= 1200000 && ${OSVERSION} < 1200057
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.else
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
.else
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.endif
.include <bsd.port.pre.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1516351401
SHA256 (mariadb-5.5.59.tar.gz) = c3269ce20b45b177239fd1e3d6d9428a94131711f12758ebf5f65222278bb110
SIZE (mariadb-5.5.59.tar.gz) = 45804920
TIMESTAMP = 1524505018
SHA256 (mariadb-5.5.60.tar.gz) = 4d3d444555416028ce39d3fb4cdc9cf6a658fcd4b0d2d0c45a73f9bf01d07929
SIZE (mariadb-5.5.60.tar.gz) = 45822878

View file

@ -0,0 +1,47 @@
https://jira.mariadb.org/browse/MDEV-15961
--- mysys/stacktrace.c.orig 2018-01-18 17:10:31 UTC
+++ mysys/stacktrace.c
@@ -34,19 +34,19 @@
#include <execinfo.h>
#endif
+#ifdef __linux__
#define PTR_SANE(p) ((p) && (char*)(p) >= heap_start && (char*)(p) <= heap_end)
-
static char *heap_start;
-
-#ifdef HAVE_BSS_START
extern char *__bss_start;
-#endif
+#else
+#define PTR_SANE(p) (p)
+#endif /* __linux */
void my_init_stacktrace()
{
-#ifdef HAVE_BSS_START
+#ifdef __linux__
heap_start = (char*) &__bss_start;
-#endif
+#endif /* __linux__ */
}
#ifdef __linux__
@@ -131,14 +131,14 @@ static int safe_print_str(const char *ad
void my_safe_print_str(const char* val, int max_len)
{
+#ifdef __linux__
char *heap_end;
-#ifdef __linux__
if (!safe_print_str(val, max_len))
return;
-#endif
heap_end= (char*) sbrk(0);
+#endif
if (!PTR_SANE(val))
{