- New port: emulators/loemu
Loemu is a free application that provides a simple frontend for various game emulators. Features: - Currently it supports game emulation with xmame, sdlmame and snes9x. - Browse games using dynamic list. This allows to browse in a list generated with some categories (and it has other advantages). - Finds games quickly. Using a specific dialog that looks for a game in all the gamelist. - The generation of the dynamic list filtering the gamelist is very fast. - It has been developed with PyGTK + Glade. - Released under GNU General Public License. The design of loemu allows the support of more emulators adding specific emulator configuration files. WWW: http://loemu.pegueroles.com/
This commit is contained in:
parent
986d069d51
commit
d7f11d8e04
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=186170
6 changed files with 112 additions and 0 deletions
|
@ -77,6 +77,7 @@
|
|||
SUBDIR += linux_base-gentoo-stage1
|
||||
SUBDIR += linux_base-gentoo-stage2
|
||||
SUBDIR += linux_base-gentoo-stage3
|
||||
SUBDIR += loemu
|
||||
SUBDIR += m2000
|
||||
SUBDIR += mame-extras
|
||||
SUBDIR += mastergear
|
||||
|
|
33
emulators/loemu/Makefile
Normal file
33
emulators/loemu/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: loemu
|
||||
# Date created: 2007-02-27
|
||||
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= loemu
|
||||
PORTVERSION= 0.1.0
|
||||
CATEGORIES= emulators python
|
||||
MASTER_SITES= http://loemu.pegueroles.com/dists/
|
||||
|
||||
MAINTAINER= acm@FreeBSD.org
|
||||
COMMENT= Simple frontend for various game emulators
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
|
||||
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
|
||||
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt \
|
||||
xmame:${PORTSDIR}/emulators/xmame
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
post-patch:
|
||||
.for DIRE in config loemu scripts
|
||||
@cd ${WRKSRC}/${DIRE} && \
|
||||
${FIND} * -type f -exec ${REINPLACE_CMD} -i '' -e \
|
||||
's|/share/games/|/share/|g' -e \
|
||||
's|/usr/bin/python|${PYTHON_CMD}|g' "{}" \;
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
3
emulators/loemu/distinfo
Normal file
3
emulators/loemu/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (loemu-0.1.0.tar.gz) = 618f6b6a70185fdecf6771ac5e48903a
|
||||
SHA256 (loemu-0.1.0.tar.gz) = d3572d5ea376760aa686c3b3750c1868d752ff7fd253f21b9899bf6aa68e01df
|
||||
SIZE (loemu-0.1.0.tar.gz) = 41577
|
23
emulators/loemu/files/patch-setup.py
Normal file
23
emulators/loemu/files/patch-setup.py
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- setup.py.orig Tue Feb 27 14:25:52 2007
|
||||
+++ setup.py Tue Feb 27 14:26:23 2007
|
||||
@@ -18,14 +18,14 @@
|
||||
* The generation of subsets of the gamelist is very fast.
|
||||
""",
|
||||
license='GNU GPL',
|
||||
- platforms='linux',
|
||||
+ platforms='FreeBSD',
|
||||
packages=['loemu'],
|
||||
scripts=glob("scripts/*"),
|
||||
data_files=[
|
||||
- ('share/games/loemu/config',glob("config/*")),
|
||||
- ('share/games/loemu/glade',glob("glade/*")),
|
||||
- ('share/games/loemu/roms',''),
|
||||
- ('share/games/loemu/flyers',''),
|
||||
- ('share/games/loemu/snaps',''),
|
||||
+ ('share/loemu/config',glob("config/*")),
|
||||
+ ('share/loemu/glade',glob("glade/*")),
|
||||
+ ('share/loemu/roms',''),
|
||||
+ ('share/loemu/flyers',''),
|
||||
+ ('share/loemu/snaps',''),
|
||||
]
|
||||
)
|
17
emulators/loemu/pkg-descr
Normal file
17
emulators/loemu/pkg-descr
Normal file
|
@ -0,0 +1,17 @@
|
|||
Loemu is a free application that provides a simple frontend for various game
|
||||
emulators.
|
||||
|
||||
Features:
|
||||
- Currently it supports game emulation with xmame, sdlmame and snes9x.
|
||||
- Browse games using dynamic list. This allows to browse in a list generated
|
||||
with some categories (and it has other advantages).
|
||||
- Finds games quickly. Using a specific dialog that looks for a game in all
|
||||
the gamelist.
|
||||
- The generation of the dynamic list filtering the gamelist is very fast.
|
||||
- It has been developed with PyGTK + Glade.
|
||||
- Released under GNU General Public License.
|
||||
|
||||
The design of loemu allows the support of more emulators adding specific
|
||||
emulator configuration files.
|
||||
|
||||
WWW: http://loemu.pegueroles.com/
|
35
emulators/loemu/pkg-plist
Normal file
35
emulators/loemu/pkg-plist
Normal file
|
@ -0,0 +1,35 @@
|
|||
bin/loemu
|
||||
bin/loemu-builder
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Config.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Gamelist.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Loemu.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Preferences.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/SimpleGladeApp.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Config.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Gamelist.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Loemu.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Preferences.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/SimpleGladeApp.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Config.pyo
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Gamelist.pyo
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Loemu.pyo
|
||||
%%PYTHON_SITELIBDIR%%/loemu/Preferences.pyo
|
||||
%%PYTHON_SITELIBDIR%%/loemu/SimpleGladeApp.pyo
|
||||
%%PYTHON_SITELIBDIR%%/loemu/__init__.pyo
|
||||
%%DATADIR%%/config/general
|
||||
%%DATADIR%%/config/mame.xsl
|
||||
%%DATADIR%%/config/sdlmame.conf
|
||||
%%DATADIR%%/config/snes9x.conf
|
||||
%%DATADIR%%/config/xmame.conf
|
||||
%%DATADIR%%/glade/Loemu.glade
|
||||
%%DATADIR%%/glade/Preferences.glade
|
||||
%%DATADIR%%/glade/penguin-revolt-128.png
|
||||
@dirrm %%DATADIR%%/snaps
|
||||
@dirrm %%DATADIR%%/roms
|
||||
@dirrm %%DATADIR%%/glade
|
||||
@dirrm %%DATADIR%%/flyers
|
||||
@dirrm %%DATADIR%%/config
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/loemu
|
Loading…
Reference in a new issue