Respect CC and CFLAGS

This commit is contained in:
Kris Kennaway 2003-10-19 08:59:55 +00:00
parent 473635d704
commit d7fe414482
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91637
5 changed files with 66 additions and 0 deletions

View file

@ -0,0 +1,22 @@
--- Makefile.orig Sun Oct 19 01:56:50 2003
+++ Makefile Sun Oct 19 01:56:43 2003
@@ -5,8 +5,8 @@
# Makefile for LibDS 2.0
#
-CC = cc
-CCOPTFLAGS = -O2
+CC ?= cc
+CCOPTFLAGS = $(CFLAGS)
CCEXTRAFLAGS = -DStandAlone
@@ -42,7 +42,7 @@
$(TARGET)
gcc:
- @-$(MAKE) CC="gcc -pipe" CCWARNFLAGS="-Wall -W -Wshadow \
+ @-$(MAKE) CC=$(CC) CCWARNFLAGS="-Wall -W -Wshadow \
-Wnested-externs -Wwrite-strings -Wpointer-arith \
-Wmissing-declarations -Wredundant-decls -Winline \
-Wstrict-prototypes" SHARED="-shared" release

View file

@ -0,0 +1,11 @@
--- lib/9/Makefile.orig Sun Oct 19 01:51:44 2003
+++ lib/9/Makefile Sun Oct 19 01:51:50 2003
@@ -16,7 +16,7 @@
newprint.o
TARG=../lib9.a
-CFLAGS=-g -I../../include
+CFLAGS+=-g -I../../include
all: $(TARG)

View file

@ -0,0 +1,11 @@
--- lib/bio/Makefile.orig Sun Oct 19 01:51:44 2003
+++ lib/bio/Makefile Sun Oct 19 01:51:55 2003
@@ -12,7 +12,7 @@
OFILES=bflush.o bgetc.o bgetrune.o binit.o bprint.o bputc.o bwrite.o
TARG=../libbio.a
-CFLAGS=-g -I../../include
+CFLAGS+=-g -I../../include
all: $(TARG)

View file

@ -0,0 +1,11 @@
--- lib/regexp/Makefile.orig Sun Oct 19 01:51:44 2003
+++ lib/regexp/Makefile Sun Oct 19 01:51:59 2003
@@ -8,7 +8,7 @@
OFILES=regaux.o regcomp.o regexec.o regsub.o
TARG=../libregexp.a
-CFLAGS=-g -I../../include
+CFLAGS+=-g -I../../include
all: $(TARG)

View file

@ -0,0 +1,11 @@
--- src/Makefile.orig Sun Oct 19 01:50:46 2003
+++ src/Makefile Sun Oct 19 01:50:14 2003
@@ -5,7 +5,7 @@
TARG=../mk
-CFLAGS=-g -I../include
+CFLAGS+=-g -I../include
$(TARG): $(OFILES) ../lib/libregexp.a ../lib/libbio.a ../lib/lib9.a
$(CC) -o $(TARG) $(OFILES) -L../lib -lregexp -lbio -l9