- Remove USE_REINPLACE.

- Install binary as "quake2forge" instead of "q2f".
- Fix OPTIONS handling.
- Remove unavoidable autodetection in OPTIONS.
- Add patch to fix an error by an OpenGL macro redefinition.
- Add patch to fix mouse problems when not using the DGA X11 extension.
- Change pkg-message.

Approved by:	garga (mentor)
This commit is contained in:
Alejandro Pulver 2006-04-12 21:56:09 +00:00
parent e17e2532b9
commit d81a3b6040
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159393
5 changed files with 43 additions and 16 deletions

View file

@ -19,12 +19,11 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= First Person Shooter with many addons available
USE_BZIP2= yes
USE_AUTOTOOLS= autoconf:259 libtool:15
USE_REINPLACE= yes
USE_BZIP2= yes
WANT_SDL= yes
CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/q2f/'
CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/${PORTNAME}/'
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= AO "Enable libao support" off \
@ -41,7 +40,7 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
.if defined(WITH_AO) || exists(${LOCALBASE}/lib/libao.so.3)
.if defined(WITH_AO)
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
PLIST_SUB+= AO=""
@ -50,7 +49,7 @@ CONFIGURE_ARGS+=--without-ao
PLIST_SUB+= AO="@comment "
.endif
.if defined(WITH_GL) || exists(${X11BASE}/lib/libGL.so.1)
.if !defined(WITHOUT_GL)
USE_GL= yes
CONFIGURE_ARGS+=--with-opengl=${X11BASE}
PLIST_SUB+= GL=""
@ -70,7 +69,7 @@ PLIST_SUB+= ROGUE=""
PLIST_SUB+= ROGUE="@comment "
.endif
.if defined(WITH_SDL) || ${HAVE_SDL:Msdl}!=""
.if defined(WITH_SDL)
USE_SDL= yes
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL=""
@ -79,13 +78,13 @@ CONFIGURE_ARGS+=--disable-sdl --disable-sdltest
PLIST_SUB+= SDL="@comment "
.endif
.if defined(WITH_GL) && (defined(WITH_SDL) || ${HAVE_SDL:Msdl}!="")
.if !defined(WITHOUT_GL) && (defined(WITH_SDL)
PLIST_SUB+= SDLGL=""
.else
PLIST_SUB+= SDLGL="@comment "
.endif
.if defined(WITH_SVGA) || exists(${LOCALBASE}/lib/libvga.so.1)
.if defined(WITH_SVGA)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svgalib=${LOCALBASE}
PLIST_SUB+= SVGA=""
@ -94,7 +93,7 @@ CONFIGURE_ARGS+=--with-svgalib=no
PLIST_SUB+= SVGA="@comment "
.endif
.if defined(WITH_X11) || exists(${X11BASE}/lib/libX11.so.6)
.if !defined(WITHOUT_X11)
USE_XLIB= yes
CONFIGURE_ARGS+=--with-x
PLIST_SUB+= X11=""

View file

@ -0,0 +1,11 @@
--- src/gl_fxmesa.c.orig Sat Jul 20 01:30:46 2002
+++ src/gl_fxmesa.c Wed Feb 22 20:24:51 2006
@@ -72,8 +72,6 @@
extern cvar_t *vid_fullscreen;
extern cvar_t *vid_ref;
-#define GLAPI extern
-#define GLAPIENTRY
#define FXMESA_NONE 0 // to terminate attribList
#define FXMESA_DOUBLEBUFFER 10

View file

@ -0,0 +1,11 @@
--- src/gl_glx.c.orig Sun Mar 14 23:25:43 2004
+++ src/gl_glx.c Wed Feb 22 20:20:51 2006
@@ -797,8 +797,6 @@
{
mx += ((int)event.xmotion.x - mwx) * 2;
my += ((int)event.xmotion.y - mwy) * 2;
- mwx = event.xmotion.x;
- mwy = event.xmotion.y;
if (mx || my)
dowarp = true;

View file

@ -1,9 +1,15 @@
============================================================
==============================================================================
If you experience problems with mouse movements when running
in GLX-Mode, try setting in_dgamouse to 1.
Quake2Forge has been installed.
ATTENTION: The Quake2Forge binary now gets installed as q2f
instead of quake2 to avoid conflicting with games/quake2lnx
The Quake2Forge binary now gets installed as "quake2forge" instead of "quake2"
to avoid conflicting with "games/quake2lnx".
============================================================
If you experience problems with mouse movements when running in GLX-Mode, try
setting in_dgamouse to 1 (this is actually for people that use the DGA X11
extension).
You can not change the gamma in SDL-Mode, but you can use "xgamma" to adjust
the gamma before and after running Quake2Forge.
==============================================================================

View file

@ -1,4 +1,4 @@
bin/q2f
bin/quake2forge
lib/quake2forge/baseq2/game.a
lib/quake2forge/baseq2/game.la
lib/quake2forge/baseq2/game.so