TCPSER turns a PC serial port into an emulated Hayes compatible modem that

uses TCP/IP for incoming and outgoing connections.  It can be used to allow
older applications and systems designed for modem use to operate on the
Internet.  TCPSER supports all standard Hayes commands, and understands
extended and vendor proprietary commands (though it does not implement
many of them).  TCPSER can be used for both inbound and outbound connections.

WWW:    http://www.jbrain.com/pub/linux/serial/
This commit is contained in:
Edward Tomasz Napierala 2008-09-24 15:45:45 +00:00
parent acad1f72c7
commit d8b03f6b18
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220702
5 changed files with 57 additions and 0 deletions

View file

@ -126,6 +126,7 @@
SUBDIR += splat
SUBDIR += sredird
SUBDIR += syncterm
SUBDIR += tcpser
SUBDIR += thebridge
SUBDIR += tilp2
SUBDIR += tits

31
comms/tcpser/Makefile Normal file
View file

@ -0,0 +1,31 @@
# New ports collection makefile for: tcpser
# Date created: 2008-09-24
# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= tcpser
DISTVERSION= 1.0rc12
CATEGORIES= comms
MASTER_SITES= http://www.jbrain.com/pub/linux/serial/
MAINTAINER= trasz@FreeBSD.org
COMMENT= TCPSER turns serial port into an emulated Hayes compatible modem
WRKSRC= ${WRKDIR}/tcpser
USE_GMAKE= yes
CFLAGS+= ${PTHREAD_CFLAGS}
MAKE_ENV+= LDFLAGS=${PTHREAD_LIBS}
PORTDOCS= README CHANGES
PLIST_FILES= bin/tcpser
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpser ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/CHANGES ${DOCSDIR}
.endif
.include <bsd.port.mk>

3
comms/tcpser/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (tcpser-1.0rc12.tar.gz) = ab127ae472a3d346dc8a7f53ad2b1a8f
SHA256 (tcpser-1.0rc12.tar.gz) = ff38c6cd575612e084bc08619f19d91b6e77b784269862b4584fc10660fa39b5
SIZE (tcpser-1.0rc12.tar.gz) = 76483

View file

@ -0,0 +1,14 @@
--- Makefile.orig 2008-09-24 16:42:06.000000000 +0200
+++ Makefile 2008-09-24 16:42:35.000000000 +0200
@@ -1,10 +1,8 @@
SRC=src
SRCS = $(SRC)/bridge.c $(SRC)/debug.c $(SRC)/getcmd.c $(SRC)/ip.c $(SRC)/init.c $(SRC)/modem_core.c $(SRC)/nvt.c $(SRC)/serial.c $(SRC)/ip232.c $(SRC)/util.c $(SRC)/phone_book.c $(SRC)/shared.c $(SRC)/tcpser.c $(SRC)/line.c $(SRC)/dce.c
OBJS = $(SRC)/bridge.o $(SRC)/debug.o $(SRC)/getcmd.o $(SRC)/ip.o $(SRC)/init.o $(SRC)/modem_core.o $(SRC)/nvt.o $(SRC)/serial.o $(SRC)/ip232.o $(SRC)/util.o $(SRC)/phone_book.o $(SRC)/shared.o $(SRC)/tcpser.o $(SRC)/dce.o $(SRC)/line.o
-CC = gcc
DEF =
-CFLAGS = -O $(DEF) -Wall
-LDFLAGS = -lpthread
+CFLAGS += $(DEF) -Wall
DEPEND = makedepend $(DEF) $(CFLAGS)
all: tcpser

8
comms/tcpser/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
TCPSER turns a PC serial port into an emulated Hayes compatible modem that
uses TCP/IP for incoming and outgoing connections. It can be used to allow
older applications and systems designed for modem use to operate on the
Internet. TCPSER supports all standard Hayes commands, and understands
extended and vendor proprietary commands (though it does not implement
many of them). TCPSER can be used for both inbound and outbound connections.
WWW: http://www.jbrain.com/pub/linux/serial/