2012-10-20 x11-toolkits/paragui: No more upstream, no ports depending on it
Feature safe: yes
This commit is contained in:
parent
5b4fdb835a
commit
d8b7331a67
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=306425
9 changed files with 1 additions and 168 deletions
1
MOVED
1
MOVED
|
@ -3830,3 +3830,4 @@ x11-toolkits/wxgtk24-docs||2012-10-26|Not supported upstream anymore, consider u
|
|||
x11-toolkits/py-wxPython24||2012-10-26|Not supported upstream anymore, consider using more recent version
|
||||
audio/gogo||2012-10-26|No more public distfiles
|
||||
deskutils/superkaramba-lwp||2012-10-26|Has expired: No more public_distfiles
|
||||
x11-toolkits/paragui||2012-10-26|Has expired: No more upstream, no ports depending on it
|
||||
|
|
|
@ -186,7 +186,6 @@
|
|||
SUBDIR += pango-reference
|
||||
SUBDIR += pangomm
|
||||
SUBDIR += pangoxsl
|
||||
SUBDIR += paragui
|
||||
SUBDIR += paragui-devel
|
||||
SUBDIR += phat
|
||||
SUBDIR += plib
|
||||
|
|
|
@ -1,53 +0,0 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: paragui
|
||||
# Date Created: Mar 28, 2001
|
||||
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= paragui
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 17
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Cross-platform high-level application framework and GUI library
|
||||
|
||||
DEPRECATED= No more upstream, no ports depending on it
|
||||
EXPIRATION_DATE= 2012-10-20
|
||||
|
||||
LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
|
||||
expat.6:${PORTSDIR}/textproc/expat2
|
||||
|
||||
CONFLICTS= paragui-devel-[0-9]*
|
||||
|
||||
USE_AUTOTOOLS= libtool
|
||||
USE_SDL= sdl image ttf
|
||||
CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
|
||||
LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
SHLIB_VER= 4
|
||||
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
|
||||
|
||||
PORTSCOUT= limit:^1\.0\.
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
@${RM} -f ${WRKSRC}/src/physfs/platform.c
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
|
||||
s|`sdl-config |`\$$\{SDL_CONFIG\} |g' ${WRKSRC}/configure
|
||||
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[$][(]SDL_CFLAGS[)]|\$\(PARAGUI_CFLAGS\)|g ; \
|
||||
s|lib/pkgconfig|libdata/pkgconfig|g ; \
|
||||
s|-L[./]*../src|&/.libs |g ; \
|
||||
s|-release $$(LT_RELEASE)||g'
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (paragui-1.0.4.tar.gz) = b67d9b6f2fd11b8b117566c8c0c8d99f948b1db4e2399a9d407f14085bebb49c
|
||||
SIZE (paragui-1.0.4.tar.gz) = 1089511
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig Mon Jun 10 18:05:42 2002
|
||||
+++ configure Tue Jun 18 20:05:24 2002
|
||||
@@ -5618,6 +5618,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
@ -1,11 +0,0 @@
|
|||
--- ./include/pgtimerobject.h.orig Sat Jan 4 18:13:38 2003
|
||||
+++ ./include/pgtimerobject.h Tue Jun 20 19:37:34 2006
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "paragui.h"
|
||||
#include <map>
|
||||
|
||||
-typedef Uint32 PG_TimerID;
|
||||
+typedef ptrdiff_t PG_TimerID;
|
||||
|
||||
/**
|
||||
@author Alexander Pipelka
|
|
@ -1,11 +0,0 @@
|
|||
--- src/core/pgmsgmap.cpp.orig 2007-08-12 19:41:43.000000000 +0200
|
||||
+++ src/core/pgmsgmap.cpp 2007-08-12 19:42:01.000000000 +0200
|
||||
@@ -83,7 +83,7 @@
|
||||
return;
|
||||
|
||||
for ( li = list->begin() ; li != list->end() ; li++ ) {
|
||||
- PG_LogDBG(" - Message Object: %d Event Handler Data: %d", (int)(*li).first, (int)(*li).second);
|
||||
+ PG_LogDBG(" - Message Object: %d Event Handler Data: %d", (intptr_t)(*li).first, (intptr_t)(*li).second);
|
||||
}
|
||||
}
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
ParaGUI is a cross-platform high-level application framework and GUI
|
||||
(graphical user interface) library. It can be compiled on various platforms.
|
||||
|
||||
ParaGUI's cross-platform nature is completely based on the Simple DirectMedia
|
||||
Layer (SDL).
|
||||
|
||||
Highlights of the library:
|
||||
|
||||
- published under LGPL
|
||||
- straight forward C++ class-design (see the API documentation)
|
||||
- XML configuration of the new style engine
|
||||
- asynchronous messagehandling (messageposts between objects)
|
||||
- multithreaded
|
||||
- highly customizable widgets (background gradients, background images,
|
||||
transparency, colors, fonts)
|
||||
- many standard widgets already implemented (buttons, labels, scrollbars,
|
||||
progressbars, windows ...)
|
||||
- create your own widgets (subclass an existing widget)
|
||||
|
||||
WWW: http://www.paragui.org/
|
|
@ -1,60 +0,0 @@
|
|||
bin/paragui-config
|
||||
include/paragui/paraconfig.h
|
||||
include/paragui/paraconfig_gnu.h
|
||||
include/paragui/paragui.h
|
||||
include/paragui/paragui_types.h
|
||||
include/paragui/pgapplication.h
|
||||
include/paragui/pgbutton.h
|
||||
include/paragui/pgcheckbutton.h
|
||||
include/paragui/pgcolors.h
|
||||
include/paragui/pgcolumnitem.h
|
||||
include/paragui/pgcompat.h
|
||||
include/paragui/pgdatacontainer.h
|
||||
include/paragui/pgdraw.h
|
||||
include/paragui/pgdropdown.h
|
||||
include/paragui/pgeventobject.h
|
||||
include/paragui/pgtimerobject.h
|
||||
include/paragui/pgfile.h
|
||||
include/paragui/pgfilearchive.h
|
||||
include/paragui/pgfont.h
|
||||
include/paragui/pgimage.h
|
||||
include/paragui/pginfo.h
|
||||
include/paragui/pglabel.h
|
||||
include/paragui/pglayout.h
|
||||
include/paragui/pglineedit.h
|
||||
include/paragui/pglistbox.h
|
||||
include/paragui/pglistboxbaseitem.h
|
||||
include/paragui/pglistboxitem.h
|
||||
include/paragui/pglog.h
|
||||
include/paragui/pgmaskedit.h
|
||||
include/paragui/pgmenubar.h
|
||||
include/paragui/pgmessagebox.h
|
||||
include/paragui/pgmessageobject.h
|
||||
include/paragui/pgnavigator.h
|
||||
include/paragui/pgpopupmenu.h
|
||||
include/paragui/pgprogressbar.h
|
||||
include/paragui/pgradiobutton.h
|
||||
include/paragui/pgrect.h
|
||||
include/paragui/pgrectlist.h
|
||||
include/paragui/pgrichedit.h
|
||||
include/paragui/pgscrollbar.h
|
||||
include/paragui/pgslider.h
|
||||
include/paragui/pgspinnerbox.h
|
||||
include/paragui/pgsurfacecache.h
|
||||
include/paragui/pgtheme.h
|
||||
include/paragui/pgthemewidget.h
|
||||
include/paragui/pgwidget.h
|
||||
include/paragui/pgwidgetdnd.h
|
||||
include/paragui/pgwidgetlist.h
|
||||
include/paragui/pgwidgetlistex.h
|
||||
include/paragui/pgwindow.h
|
||||
lib/libparagui.a
|
||||
lib/libparagui.la
|
||||
lib/libparagui.so
|
||||
lib/libparagui.so.%%SHLIB_VER%%
|
||||
libdata/pkgconfig/paragui.pc
|
||||
share/aclocal/paragui.m4
|
||||
%%DATADIR%%/default.zip
|
||||
%%DATADIR%%/simple.zip
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm include/paragui
|
Loading…
Reference in a new issue