Update to version 1.4.6

PR:		ports/77977
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2005-02-25 14:02:40 +00:00
parent 8fedfe8b03
commit d8d33fdfca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129762
12 changed files with 118 additions and 72 deletions

View file

@ -24,14 +24,14 @@ CONFLICTS= fox-1.0.*
LATEST_LINK= fox-devel
MAJORVER= 1.2
SHVER= 11
MAJORVER= 1.4
SHVER= 6
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
USE_GNOME= lthack
USE_GL= yes
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
INSTALLS_SHLIB= yes

View file

@ -1,2 +1,2 @@
MD5 (fox-1.2.11.tar.gz) = cbe15ef87f6ad815689b3ca7322eb8c5
SIZE (fox-1.2.11.tar.gz) = 3770933
MD5 (fox-1.4.6.tar.gz) = 96b85c3e25f0e238e190c63242f2deef
SIZE (fox-1.4.6.tar.gz) = 3922948

View file

@ -1,10 +1,10 @@
--- configure.orig Tue Feb 4 18:33:38 2003
+++ configure Tue Feb 4 18:34:51 2003
@@ -7498,7 +7498,7 @@
--- configure.orig Tue Feb 8 15:20:38 2005
+++ configure Wed Feb 9 16:04:31 2005
@@ -24927,7 +24927,7 @@
if test "x$enable_release" = "xyes" ; then
CXXFLAGS="${CXXFLAGS} -O2 -DNDEBUG"
if test "${GXX}" = "yes" ; then
-CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
-CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -fstrict-aliasing -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
+CXXFLAGS="${CXXFLAGS} -Wuninitialized"
fi
fi

View file

@ -1,6 +1,15 @@
--- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
+++ src/FXFile.cpp Sat May 22 13:13:48 2004
@@ -159,7 +159,7 @@
--- src/FXFile.cpp.orig Sat Feb 5 13:10:50 2005
+++ src/FXFile.cpp Wed Feb 9 17:40:15 2005
@@ -102,7 +102,7 @@
// Get current user name
FXString FXFile::getCurrentUserName(){
#ifndef WIN32
-#ifdef FOX_THREAD_SAFE
+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
struct passwd pwdresult,*pwd;
char buffer[1024];
if(getpwuid_r(geteuid(),&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
@@ -180,7 +180,7 @@
// Get home directory for a given user
FXString FXFile::getUserDirectory(const FXString& user){
#ifndef WIN32
@ -9,7 +18,7 @@
struct passwd pwdresult,*pwd;
char buffer[1024];
if(user.empty()){
@@ -1032,7 +1032,7 @@
@@ -1059,7 +1059,7 @@
FXString FXFile::owner(FXuint uid){
FXchar result[64];
#ifndef WIN32
@ -18,7 +27,7 @@
struct passwd pwdresult,*pwd;
char buffer[1024];
if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
@@ -1050,7 +1050,7 @@
@@ -1077,7 +1077,7 @@
FXString FXFile::group(FXuint gid){
FXchar result[64];
#ifndef WIN32
@ -27,3 +36,12 @@
::group grpresult;
::group *grp;
char buffer[1024];
@@ -1435,7 +1435,7 @@
// Convert file time to string as per strftime format
FXString FXFile::time(const FXchar *format,FXTime filetime){
#ifndef WIN32
-#ifdef FOX_THREAD_SAFE
+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
time_t tmp=(time_t)FXMAX(filetime,0);
struct tm tmresult;
FXchar buffer[512];

View file

@ -1,11 +0,0 @@
--- utils/Makefile.in.orig Sun Aug 15 11:30:45 2004
+++ utils/Makefile.in Sun Aug 15 11:30:55 2004
@@ -106,7 +106,7 @@
DEFS = @DEFS@ -I. -I$(srcdir)
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lX11 -lXext
X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
X_EXTRA_LIBS = @X_EXTRA_LIBS@

View file

@ -1,9 +1,11 @@
%%APPS%%bin/PathFinder
%%APPS%%bin/adie
%%APPS%%bin/calculator
bin/fox-config
bin/reswrap
bin/shutterbug
include/fox-%%MAJORVER%%/FX4Splitter.h
include/fox-%%MAJORVER%%/FX7Segment.h
include/fox-%%MAJORVER%%/FXAccelTable.h
include/fox-%%MAJORVER%%/FXApp.h
include/fox-%%MAJORVER%%/FXArray.h
@ -17,8 +19,8 @@ include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCharset.h
include/fox-%%MAJORVER%%/FXCheckButton.h
include/fox-%%MAJORVER%%/FXChoiceBox.h
include/fox-%%MAJORVER%%/FXColorBar.h
include/fox-%%MAJORVER%%/FXColorDialog.h
include/fox-%%MAJORVER%%/FXColorSelector.h
@ -41,6 +43,10 @@ include/fox-%%MAJORVER%%/FXDirBox.h
include/fox-%%MAJORVER%%/FXDirDialog.h
include/fox-%%MAJORVER%%/FXDirList.h
include/fox-%%MAJORVER%%/FXDirSelector.h
include/fox-%%MAJORVER%%/FXDockBar.h
include/fox-%%MAJORVER%%/FXDockHandler.h
include/fox-%%MAJORVER%%/FXDockSite.h
include/fox-%%MAJORVER%%/FXDockTitle.h
include/fox-%%MAJORVER%%/FXDocument.h
include/fox-%%MAJORVER%%/FXDragCorner.h
include/fox-%%MAJORVER%%/FXDrawable.h
@ -72,6 +78,7 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
include/fox-%%MAJORVER%%/FXGUISignal.h
include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
@ -80,8 +87,12 @@ include/fox-%%MAJORVER%%/FXHeader.h
include/fox-%%MAJORVER%%/FXHorizontalFrame.h
include/fox-%%MAJORVER%%/FXICOIcon.h
include/fox-%%MAJORVER%%/FXICOImage.h
include/fox-%%MAJORVER%%/FXIFFIcon.h
include/fox-%%MAJORVER%%/FXIFFImage.h
include/fox-%%MAJORVER%%/FXIcon.h
include/fox-%%MAJORVER%%/FXIconDict.h
include/fox-%%MAJORVER%%/FXIconList.h
include/fox-%%MAJORVER%%/FXIconSource.h
include/fox-%%MAJORVER%%/FXId.h
include/fox-%%MAJORVER%%/FXImage.h
include/fox-%%MAJORVER%%/FXImageFrame.h
@ -101,6 +112,7 @@ include/fox-%%MAJORVER%%/FXMat3f.h
include/fox-%%MAJORVER%%/FXMat4d.h
include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMatrix.h
include/fox-%%MAJORVER%%/FXMemMap.h
include/fox-%%MAJORVER%%/FXMemoryStream.h
include/fox-%%MAJORVER%%/FXMenuBar.h
include/fox-%%MAJORVER%%/FXMenuButton.h
@ -131,6 +143,8 @@ include/fox-%%MAJORVER%%/FXProgressBar.h
include/fox-%%MAJORVER%%/FXProgressDialog.h
include/fox-%%MAJORVER%%/FXQuatd.h
include/fox-%%MAJORVER%%/FXQuatf.h
include/fox-%%MAJORVER%%/FXRASIcon.h
include/fox-%%MAJORVER%%/FXRASImage.h
include/fox-%%MAJORVER%%/FXRGBIcon.h
include/fox-%%MAJORVER%%/FXRGBImage.h
include/fox-%%MAJORVER%%/FXRadioButton.h
@ -160,6 +174,7 @@ include/fox-%%MAJORVER%%/FXSlider.h
include/fox-%%MAJORVER%%/FXSphered.h
include/fox-%%MAJORVER%%/FXSpheref.h
include/fox-%%MAJORVER%%/FXSpinner.h
include/fox-%%MAJORVER%%/FXSplashWindow.h
include/fox-%%MAJORVER%%/FXSplitter.h
include/fox-%%MAJORVER%%/FXSpring.h
include/fox-%%MAJORVER%%/FXStatusBar.h
@ -203,7 +218,6 @@ include/fox-%%MAJORVER%%/FXVec4d.h
include/fox-%%MAJORVER%%/FXVec4f.h
include/fox-%%MAJORVER%%/FXVerticalFrame.h
include/fox-%%MAJORVER%%/FXVisual.h
include/fox-%%MAJORVER%%/FXWString.h
include/fox-%%MAJORVER%%/FXWindow.h
include/fox-%%MAJORVER%%/FXWizard.h
include/fox-%%MAJORVER%%/FXXBMIcon.h
@ -280,10 +294,17 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/glview.png
%%PORTDOCS%%%%DOCSDIR%%/html/goals.html
%%PORTDOCS%%%%DOCSDIR%%/html/goggles.png
%%PORTDOCS%%%%DOCSDIR%%/html/gpgkey.html
%%PORTDOCS%%%%DOCSDIR%%/html/guiupdate.html
%%PORTDOCS%%%%DOCSDIR%%/html/header.html
%%PORTDOCS%%%%DOCSDIR%%/html/home.html
%%PORTDOCS%%%%DOCSDIR%%/html/icons.html
%%PORTDOCS%%%%DOCSDIR%%/html/iims1.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims1_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims2.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims2_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims3.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims3_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ill.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ilr.gif
%%PORTDOCS%%%%DOCSDIR%%/html/imagedebugger.gif
@ -303,7 +324,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
%%PORTDOCS%%%%DOCSDIR%%/html/news2.html
%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
%%PORTDOCS%%%%DOCSDIR%%/html/opengl_logo.png
@ -313,6 +334,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/page.css
%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.html
%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.png
%%PORTDOCS%%%%DOCSDIR%%/html/pdiary.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/printdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/progress.png
%%PORTDOCS%%%%DOCSDIR%%/html/projects.html
@ -329,18 +351,11 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
%%PORTDOCS%%%%DOCSDIR%%/html/slingerzbutton1.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ss1.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss1_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss2.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss2_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss3.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss3_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
%%PORTDOCS%%%%DOCSDIR%%/html/table.png
%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/top.html
%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg
@ -361,6 +376,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/xfe.png
%%PORTDOCS%%%%DOCSDIR%%/html/xfe_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/xml.html
%%PORTDOCS%%%%DOCSDIR%%/html/xtc.gif
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/fox-%%MAJORVER%%/chart

View file

@ -24,14 +24,14 @@ CONFLICTS= fox-1.0.*
LATEST_LINK= fox-devel
MAJORVER= 1.2
SHVER= 11
MAJORVER= 1.4
SHVER= 6
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
USE_GNOME= lthack
USE_GL= yes
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
INSTALLS_SHLIB= yes

View file

@ -1,2 +1,2 @@
MD5 (fox-1.2.11.tar.gz) = cbe15ef87f6ad815689b3ca7322eb8c5
SIZE (fox-1.2.11.tar.gz) = 3770933
MD5 (fox-1.4.6.tar.gz) = 96b85c3e25f0e238e190c63242f2deef
SIZE (fox-1.4.6.tar.gz) = 3922948

View file

@ -1,10 +1,10 @@
--- configure.orig Tue Feb 4 18:33:38 2003
+++ configure Tue Feb 4 18:34:51 2003
@@ -7498,7 +7498,7 @@
--- configure.orig Tue Feb 8 15:20:38 2005
+++ configure Wed Feb 9 16:04:31 2005
@@ -24927,7 +24927,7 @@
if test "x$enable_release" = "xyes" ; then
CXXFLAGS="${CXXFLAGS} -O2 -DNDEBUG"
if test "${GXX}" = "yes" ; then
-CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
-CXXFLAGS="${CXXFLAGS} -Wuninitialized -ffast-math -fstrict-aliasing -finline-functions -fomit-frame-pointer -fexpensive-optimizations"
+CXXFLAGS="${CXXFLAGS} -Wuninitialized"
fi
fi

View file

@ -1,6 +1,15 @@
--- src/FXFile.cpp.orig Fri Apr 16 23:25:33 2004
+++ src/FXFile.cpp Sat May 22 13:13:48 2004
@@ -159,7 +159,7 @@
--- src/FXFile.cpp.orig Sat Feb 5 13:10:50 2005
+++ src/FXFile.cpp Wed Feb 9 17:40:15 2005
@@ -102,7 +102,7 @@
// Get current user name
FXString FXFile::getCurrentUserName(){
#ifndef WIN32
-#ifdef FOX_THREAD_SAFE
+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
struct passwd pwdresult,*pwd;
char buffer[1024];
if(getpwuid_r(geteuid(),&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
@@ -180,7 +180,7 @@
// Get home directory for a given user
FXString FXFile::getUserDirectory(const FXString& user){
#ifndef WIN32
@ -9,7 +18,7 @@
struct passwd pwdresult,*pwd;
char buffer[1024];
if(user.empty()){
@@ -1032,7 +1032,7 @@
@@ -1059,7 +1059,7 @@
FXString FXFile::owner(FXuint uid){
FXchar result[64];
#ifndef WIN32
@ -18,7 +27,7 @@
struct passwd pwdresult,*pwd;
char buffer[1024];
if(getpwuid_r(uid,&pwdresult,buffer,sizeof(buffer),&pwd)==0 && pwd) return pwd->pw_name;
@@ -1050,7 +1050,7 @@
@@ -1077,7 +1077,7 @@
FXString FXFile::group(FXuint gid){
FXchar result[64];
#ifndef WIN32
@ -27,3 +36,12 @@
::group grpresult;
::group *grp;
char buffer[1024];
@@ -1435,7 +1435,7 @@
// Convert file time to string as per strftime format
FXString FXFile::time(const FXchar *format,FXTime filetime){
#ifndef WIN32
-#ifdef FOX_THREAD_SAFE
+#if defined(FOX_THREAD_SAFE) && !defined(__FreeBSD__)
time_t tmp=(time_t)FXMAX(filetime,0);
struct tm tmresult;
FXchar buffer[512];

View file

@ -1,11 +0,0 @@
--- utils/Makefile.in.orig Sun Aug 15 11:30:45 2004
+++ utils/Makefile.in Sun Aug 15 11:30:55 2004
@@ -106,7 +106,7 @@
DEFS = @DEFS@ -I. -I$(srcdir)
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lX11 -lXext
X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
X_EXTRA_LIBS = @X_EXTRA_LIBS@

View file

@ -1,9 +1,11 @@
%%APPS%%bin/PathFinder
%%APPS%%bin/adie
%%APPS%%bin/calculator
bin/fox-config
bin/reswrap
bin/shutterbug
include/fox-%%MAJORVER%%/FX4Splitter.h
include/fox-%%MAJORVER%%/FX7Segment.h
include/fox-%%MAJORVER%%/FXAccelTable.h
include/fox-%%MAJORVER%%/FXApp.h
include/fox-%%MAJORVER%%/FXArray.h
@ -17,8 +19,8 @@ include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCharset.h
include/fox-%%MAJORVER%%/FXCheckButton.h
include/fox-%%MAJORVER%%/FXChoiceBox.h
include/fox-%%MAJORVER%%/FXColorBar.h
include/fox-%%MAJORVER%%/FXColorDialog.h
include/fox-%%MAJORVER%%/FXColorSelector.h
@ -41,6 +43,10 @@ include/fox-%%MAJORVER%%/FXDirBox.h
include/fox-%%MAJORVER%%/FXDirDialog.h
include/fox-%%MAJORVER%%/FXDirList.h
include/fox-%%MAJORVER%%/FXDirSelector.h
include/fox-%%MAJORVER%%/FXDockBar.h
include/fox-%%MAJORVER%%/FXDockHandler.h
include/fox-%%MAJORVER%%/FXDockSite.h
include/fox-%%MAJORVER%%/FXDockTitle.h
include/fox-%%MAJORVER%%/FXDocument.h
include/fox-%%MAJORVER%%/FXDragCorner.h
include/fox-%%MAJORVER%%/FXDrawable.h
@ -72,6 +78,7 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
include/fox-%%MAJORVER%%/FXGUISignal.h
include/fox-%%MAJORVER%%/FXGZStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
@ -80,8 +87,12 @@ include/fox-%%MAJORVER%%/FXHeader.h
include/fox-%%MAJORVER%%/FXHorizontalFrame.h
include/fox-%%MAJORVER%%/FXICOIcon.h
include/fox-%%MAJORVER%%/FXICOImage.h
include/fox-%%MAJORVER%%/FXIFFIcon.h
include/fox-%%MAJORVER%%/FXIFFImage.h
include/fox-%%MAJORVER%%/FXIcon.h
include/fox-%%MAJORVER%%/FXIconDict.h
include/fox-%%MAJORVER%%/FXIconList.h
include/fox-%%MAJORVER%%/FXIconSource.h
include/fox-%%MAJORVER%%/FXId.h
include/fox-%%MAJORVER%%/FXImage.h
include/fox-%%MAJORVER%%/FXImageFrame.h
@ -101,6 +112,7 @@ include/fox-%%MAJORVER%%/FXMat3f.h
include/fox-%%MAJORVER%%/FXMat4d.h
include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMatrix.h
include/fox-%%MAJORVER%%/FXMemMap.h
include/fox-%%MAJORVER%%/FXMemoryStream.h
include/fox-%%MAJORVER%%/FXMenuBar.h
include/fox-%%MAJORVER%%/FXMenuButton.h
@ -131,6 +143,8 @@ include/fox-%%MAJORVER%%/FXProgressBar.h
include/fox-%%MAJORVER%%/FXProgressDialog.h
include/fox-%%MAJORVER%%/FXQuatd.h
include/fox-%%MAJORVER%%/FXQuatf.h
include/fox-%%MAJORVER%%/FXRASIcon.h
include/fox-%%MAJORVER%%/FXRASImage.h
include/fox-%%MAJORVER%%/FXRGBIcon.h
include/fox-%%MAJORVER%%/FXRGBImage.h
include/fox-%%MAJORVER%%/FXRadioButton.h
@ -160,6 +174,7 @@ include/fox-%%MAJORVER%%/FXSlider.h
include/fox-%%MAJORVER%%/FXSphered.h
include/fox-%%MAJORVER%%/FXSpheref.h
include/fox-%%MAJORVER%%/FXSpinner.h
include/fox-%%MAJORVER%%/FXSplashWindow.h
include/fox-%%MAJORVER%%/FXSplitter.h
include/fox-%%MAJORVER%%/FXSpring.h
include/fox-%%MAJORVER%%/FXStatusBar.h
@ -203,7 +218,6 @@ include/fox-%%MAJORVER%%/FXVec4d.h
include/fox-%%MAJORVER%%/FXVec4f.h
include/fox-%%MAJORVER%%/FXVerticalFrame.h
include/fox-%%MAJORVER%%/FXVisual.h
include/fox-%%MAJORVER%%/FXWString.h
include/fox-%%MAJORVER%%/FXWindow.h
include/fox-%%MAJORVER%%/FXWizard.h
include/fox-%%MAJORVER%%/FXXBMIcon.h
@ -280,10 +294,17 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/glview.png
%%PORTDOCS%%%%DOCSDIR%%/html/goals.html
%%PORTDOCS%%%%DOCSDIR%%/html/goggles.png
%%PORTDOCS%%%%DOCSDIR%%/html/gpgkey.html
%%PORTDOCS%%%%DOCSDIR%%/html/guiupdate.html
%%PORTDOCS%%%%DOCSDIR%%/html/header.html
%%PORTDOCS%%%%DOCSDIR%%/html/home.html
%%PORTDOCS%%%%DOCSDIR%%/html/icons.html
%%PORTDOCS%%%%DOCSDIR%%/html/iims1.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims1_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims2.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims2_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims3.png
%%PORTDOCS%%%%DOCSDIR%%/html/iims3_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ill.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ilr.gif
%%PORTDOCS%%%%DOCSDIR%%/html/imagedebugger.gif
@ -303,7 +324,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/nerd_inside.gif
%%PORTDOCS%%%%DOCSDIR%%/html/news.html
%%PORTDOCS%%%%DOCSDIR%%/html/news1.html
%%PORTDOCS%%%%DOCSDIR%%/html/oldfox.html
%%PORTDOCS%%%%DOCSDIR%%/html/news2.html
%%PORTDOCS%%%%DOCSDIR%%/html/oll.gif
%%PORTDOCS%%%%DOCSDIR%%/html/olr.gif
%%PORTDOCS%%%%DOCSDIR%%/html/opengl_logo.png
@ -313,6 +334,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/page.css
%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.html
%%PORTDOCS%%%%DOCSDIR%%/html/pathfinder.png
%%PORTDOCS%%%%DOCSDIR%%/html/pdiary.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/printdialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/progress.png
%%PORTDOCS%%%%DOCSDIR%%/html/projects.html
@ -329,18 +351,11 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/serialization.html
%%PORTDOCS%%%%DOCSDIR%%/html/sgitextedit.png
%%PORTDOCS%%%%DOCSDIR%%/html/slingerzbutton1.gif
%%PORTDOCS%%%%DOCSDIR%%/html/ss1.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss1_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss2.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss2_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss3.png
%%PORTDOCS%%%%DOCSDIR%%/html/ss3_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
%%PORTDOCS%%%%DOCSDIR%%/html/table.png
%%PORTDOCS%%%%DOCSDIR%%/html/timers.html
%%PORTDOCS%%%%DOCSDIR%%/html/tmp_vision_snap.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/top.html
%%PORTDOCS%%%%DOCSDIR%%/html/tux.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/tux_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/udine_physics.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/vorhour1.jpg
@ -361,6 +376,7 @@ lib/libFOX-%%MAJORVER%%.so.%%SHVER%%
%%PORTDOCS%%%%DOCSDIR%%/html/xfe.png
%%PORTDOCS%%%%DOCSDIR%%/html/xfe_small.png
%%PORTDOCS%%%%DOCSDIR%%/html/xml.html
%%PORTDOCS%%%%DOCSDIR%%/html/xtc.gif
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/fox-%%MAJORVER%%/chart