audio/mp3unicode:

- Update to 1.2.1
- Remove patch for DOCS option, which no longer needed in STAGEDIR era \o/
This commit is contained in:
Max Brazhnikov 2014-05-20 18:55:12 +00:00
parent cca41554b6
commit d9056fd9eb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=354667
4 changed files with 10 additions and 31 deletions

View file

@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= mp3unicode
PORTVERSION= 1.2
PORTREVISION= 3
PORTVERSION= 1.2.1
CATEGORIES= audio
MASTER_SITES= SF
MASTER_SITES= http://github.com/downloads/alonbl/mp3unicode/
MAINTAINER= makc@FreeBSD.org
COMMENT= ID3 tags charset converter
@ -22,11 +21,4 @@ PORTDOCS= COPYING README
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
pre-configure:
.if !${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/^install-data-am/s|install-dist_docDATA||' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (mp3unicode-1.2.tar.bz2) = 7788dde056204d003f32f07aa99ed46b1599ecfc0e9e12c8b559fa1072ffb74b
SIZE (mp3unicode-1.2.tar.bz2) = 95372
SHA256 (mp3unicode-1.2.1.tar.bz2) = 375b432ce784407e74fceb055d115bf83b1bd04a83b95256171e1a36e00cfe07
SIZE (mp3unicode-1.2.1.tar.bz2) = 101593

View file

@ -1,12 +0,0 @@
--- ./Makefile.in.orig 2007-09-28 23:07:40.000000000 +0400
+++ ./Makefile.in 2008-05-26 21:32:34.000000000 +0400
@@ -757,8 +757,7 @@
info-am:
-install-data-am: install-dist_docDATA install-man \
- install-nodist_htmlDATA
+install-data-am: install-dist_docDATA install-man
install-dvi: install-dvi-recursive

View file

@ -1,12 +1,11 @@
--- ./mp3unicode.cpp.orig 2007-09-25 14:57:33.000000000 +0400
+++ ./mp3unicode.cpp 2007-09-29 15:16:49.000000000 +0400
@@ -200,9 +200,6 @@
--- ./mp3unicode.cpp.orig 2012-05-07 12:03:19.000000000 +0000
+++ ./mp3unicode.cpp 2014-05-13 20:16:40.053475428 +0000
@@ -229,7 +229,7 @@
if (
iconv (
cd,
-#if !defined(_LIBICONV_VERSION) || _LIBICONV_VERSION < 0x010B
- (char **)
-#endif
&from,
- (char **)&from,
+ &from,
&from_size,
&to,
&to_size