Fix pkgconfig.

Reported by:	Reid Linnemann <reidl (at) spectralogic.com>
This commit is contained in:
Thierry Thomas 2019-02-20 18:27:57 +00:00
parent 8c28e6b793
commit d914593af2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493430
3 changed files with 16 additions and 6 deletions

View file

@ -3,6 +3,7 @@
PORTNAME= tidy-html5
PORTVERSION= 5.6.0
PORTREVISION= 1
CATEGORIES= www
MAINTAINER= thierry@FreeBSD.org
@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/README/LICENSE.md
USE_GITHUB= yes
GH_ACCOUNT= htacg
USES= cmake
USES= cmake gnome
USE_GNOME= libxslt
USE_LDCONFIG= yes

View file

@ -1,11 +1,11 @@
--- CMakeLists.txt.orig 2015-11-18 19:02:54 UTC
--- CMakeLists.txt.orig 2017-11-25 13:54:41 UTC
+++ CMakeLists.txt
@@ -42,7 +42,7 @@ option( BUILD_SHARED_LIB "Set OFF to NOT
option( BUILD_TAB2SPACE "Set ON to build utility app, tab2space" OFF )
option( BUILD_SAMPLE_CODE "Set ON to build the sample code" OFF )
@@ -102,7 +102,7 @@ option( TIDY_COMPAT_HEADERS "Set ON to include compati
# Allow building with non-default man page directory.
#------------------------------------------------------------------------
if (NOT MAN_INSTALL_DIR)
- set(MAN_INSTALL_DIR share/man/man1)
+ set(MAN_INSTALL_DIR man/man1)
endif ()
option( BUILD_DOCUMENTATION "Set ON to build the documentation" OFF )

View file

@ -0,0 +1,9 @@
--- tidy.pc.cmake.in.orig 2017-11-25 13:54:41 UTC
+++ tidy.pc.cmake.in
@@ -7,5 +7,5 @@ Name: @LIB_NAME@
Description: @LIBTIDY_DESCRIPTION@
URL: @LIBTIDY_URL@
Version: @LIBTIDY_VERSION@
-Libs: -L${libdir} -l@LIB_NAME@
+Libs: -L${libdir} -l@LIB_NAME@5
Cflags: -I${includedir}