- Update graphics/wxsvg to 1.0.5 and wx 2.8 which thus needs an Mk/bsd.wx.mk
change. - Update multimedia/dvdstyler to 1.8.1 which seems to be the only port in the tree using wxsvg. Approved by: kwm (for -multimedia), portmgr (pav, for Mk/bsd.wx.mk)
This commit is contained in:
parent
61b31f74b4
commit
d939de5440
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259319
8 changed files with 88 additions and 60 deletions
|
@ -164,9 +164,6 @@ _WX_LIB_contrib_2.6= wx_gtk2${_WX_UC}_animate-2.6
|
|||
_WX_PORT_python_2.6= x11-toolkits/py-wxPython26${_WX_UCL}
|
||||
_WX_FILE_python_2.6= ${PYTHON_SITELIBDIR}/wx-2.6-gtk2${_WX_PYSUFX}/wx/__init__.py
|
||||
|
||||
_WX_PORT_svg_2.6= graphics/wxsvg
|
||||
_WX_LIB_svg_2.6= wxsvg
|
||||
|
||||
# wxgtk 2.8
|
||||
_WX_PORT_wx_2.8= x11-toolkits/wxgtk28${_WX_UCL}
|
||||
_WX_LIB_wx_2.8= wx_base${_WX_UC}-2.8
|
||||
|
@ -177,6 +174,9 @@ _WX_LIB_contrib_2.8= wx_gtk2${_WX_UC}_fl-2.8
|
|||
_WX_PORT_python_2.8= x11-toolkits/py-wxPython28${_WX_UCL}
|
||||
_WX_FILE_python_2.8= ${PYTHON_SITELIBDIR}/wx-2.8-gtk2${_WX_PYSUFX}/wx/__init__.py
|
||||
|
||||
_WX_PORT_svg_2.8= graphics/wxsvg
|
||||
_WX_LIB_svg_2.8= wxsvg
|
||||
|
||||
# Set _WX_SHVER_comp_ver to 0 and _WX_FILE_comp_ver for libs appropiately.
|
||||
# Set _WX_DEPTYPE_comp_ver for "python" to "run", and others to "lib".
|
||||
|
||||
|
|
|
@ -6,20 +6,24 @@
|
|||
# $MCom: ports/graphics/wxsvg/Makefile,v 1.1 2006/09/22 01:48:33 ahze Exp $
|
||||
|
||||
PORTNAME= wxsvg
|
||||
DISTVERSION= 1.0b7_2
|
||||
PORTREVISION= 5
|
||||
DISTVERSION= 1.0.5
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/OldFiles
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= C++ library to create, manipulate, and render SVG files
|
||||
|
||||
AUTOMAKE_ARGS= --add-missing
|
||||
LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_AUTOTOOLS= libtool:22 automake:15 autoconf:262
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-wx-config=${LOCALBASE}/bin/wxgtk2-2.8-config
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GNOME= libartlgpl2
|
||||
USE_GMAKE= yes
|
||||
USE_WX= 2.6
|
||||
USE_WX= 2.8
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC} && \
|
||||
|
@ -27,8 +31,4 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|WX_CONFIG_NAME=wx-config|WX_CONFIG_NAME=${WX_CONFIG}|' \
|
||||
${WRKSRC}/*.m4
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I .; \
|
||||
${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (wxsvg-1.0b7_2.tar.gz) = 5700d30555a6459377c87b817b3276d7
|
||||
SHA256 (wxsvg-1.0b7_2.tar.gz) = 463ae9b3bbc4a67bc206885c7522c072ab38c0293553cbf0f9b981e94d9b1360
|
||||
SIZE (wxsvg-1.0b7_2.tar.gz) = 592442
|
||||
MD5 (wxsvg-1.0.5.tar.bz2) = 27ead41fa22fc70fc490983c6bd217cf
|
||||
SHA256 (wxsvg-1.0.5.tar.bz2) = 816ee1922b11edab450903c99ba46cd49fdc4991c2f493e3d4470b14df11871b
|
||||
SIZE (wxsvg-1.0.5.tar.bz2) = 639450
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig Thu Feb 22 18:29:47 2007
|
||||
+++ configure.in Thu Feb 22 18:30:09 2007
|
||||
@@ -3,7 +3,7 @@
|
||||
dnl initialization
|
||||
AC_PREREQ(2.57)
|
||||
AC_INIT([wxsvgtest], [1.0], [wx-svg-users@lists.sourceforge.net])
|
||||
-AM_INIT_AUTOMAKE
|
||||
+AM_INIT_AUTOMAKE(wxsvg, 1.0b7)
|
||||
AM_MAINTAINER_MODE
|
||||
|
||||
dnl options
|
|
@ -11,6 +11,7 @@ include/wxSVG/ElementTimeControl.h
|
|||
include/wxSVG/EventTarget.h
|
||||
include/wxSVG/GetSVGDocument.h
|
||||
include/wxSVG/NodeList.h
|
||||
include/wxSVG/NodeListCls.h
|
||||
include/wxSVG/RGBColor.h
|
||||
include/wxSVG/SVGAElement.h
|
||||
include/wxSVG/SVGAltGlyphDefElement.h
|
||||
|
@ -176,15 +177,16 @@ include/wxSVG/SVGViewElement.h
|
|||
include/wxSVG/SVGViewSpec.h
|
||||
include/wxSVG/SVGZoomAndPan.h
|
||||
include/wxSVG/SVGZoomEvent.h
|
||||
include/wxSVG/String.h
|
||||
include/wxSVG/String_wxsvg.h
|
||||
include/wxSVG/ViewCSS.h
|
||||
include/wxSVG/mediadec_ffmpeg.h
|
||||
include/wxSVG/svg.h
|
||||
include/wxSVG/svgctrl.h
|
||||
include/wxXML/xml.h
|
||||
include/wxXML/xmlhelpr.h
|
||||
include/wxSVGXML/svgxml.h
|
||||
include/wxSVGXML/svgxmlhelpr.h
|
||||
lib/libwxsvg.a
|
||||
lib/libwxsvg.la
|
||||
lib/libwxsvg.so
|
||||
lib/libwxsvg.so.0
|
||||
@dirrm include/wxXML
|
||||
@dirrm include/wxSVGXML
|
||||
@dirrm include/wxSVG
|
||||
|
|
|
@ -6,11 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= dvdstyler
|
||||
DISTVERSION= 1.5.1_2
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 1.8.1
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.5.1
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
|
||||
DISTNAME= DVDStyler-${DISTVERSION}
|
||||
|
||||
MAINTAINER= multimedia@FreeBSD.org
|
||||
|
@ -18,16 +17,18 @@ COMMENT= WXGTK2 front end to dvd recoding and authoring programs
|
|||
|
||||
BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
|
||||
mplex:${PORTSDIR}/multimedia/mjpegtools \
|
||||
jpegtopnm:${PORTSDIR}/graphics/netpbm \
|
||||
mpgtx:${PORTSDIR}/multimedia/mpgtx \
|
||||
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
|
||||
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
|
||||
xmlto:${PORTSDIR}/textproc/xmlto \
|
||||
zip:${PORTSDIR}/archivers/zip
|
||||
RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
|
||||
mplex:${PORTSDIR}/multimedia/mjpegtools \
|
||||
jpegtopnm:${PORTSDIR}/graphics/netpbm \
|
||||
mpgtx:${PORTSDIR}/multimedia/mpgtx \
|
||||
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
|
||||
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
|
||||
xmlto:${PORTSDIR}/textproc/xmlto
|
||||
LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg \
|
||||
exif:${PORTSDIR}/graphics/libexif
|
||||
|
||||
USE_WX= 2.6
|
||||
USE_BZIP2= yes
|
||||
USE_WX= 2.8
|
||||
WX_COMPS= wx svg
|
||||
WX_CONF_ARGS= absolute
|
||||
USE_GMAKE= yes
|
||||
|
@ -38,6 +39,7 @@ USE_CDRTOOLS= yes # dvdstyler needs mkisofs
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
MAN1= dvdstyler.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (DVDStyler-1.5.1_2.tar.gz) = 6cbb02a5b1853aaf0623205a3724cc83
|
||||
SHA256 (DVDStyler-1.5.1_2.tar.gz) = e3d2c60834b611d26fd8ae9d8bd20785a65878014a42e10669668a844403f740
|
||||
SIZE (DVDStyler-1.5.1_2.tar.gz) = 834479
|
||||
MD5 (DVDStyler-1.8.1.tar.bz2) = 076bd95e15912c1c0f7f9165d0ea5632
|
||||
SHA256 (DVDStyler-1.8.1.tar.bz2) = 5dcc38cd1560bf2ccfed66b93de620f63cb4aab7e46bd45fa1b32e22424e8c1c
|
||||
SIZE (DVDStyler-1.8.1.tar.bz2) = 1845503
|
||||
|
|
|
@ -5,10 +5,10 @@ share/applications/dvdstyler.desktop
|
|||
%%DOCSDIR%%/ChangeLog
|
||||
%%DOCSDIR%%/INSTALL
|
||||
%%DOCSDIR%%/README
|
||||
%%DATADIR%%/backgrounds/01_autobahn.jpg
|
||||
%%DATADIR%%/backgrounds/02_bi_domrep.jpg
|
||||
%%DATADIR%%/backgrounds/03_creta.jpg
|
||||
%%DATADIR%%/backgrounds/04_kiel_kanal.jpg
|
||||
%%DATADIR%%/backgrounds/05_easyblue.jpg
|
||||
%%DATADIR%%/backgrounds/10_turbulence_blue.jpg
|
||||
%%DATADIR%%/backgrounds/11_turbulence_green.jpg
|
||||
%%DATADIR%%/backgrounds/15_bordes_blue.jpg
|
||||
|
@ -19,72 +19,107 @@ share/applications/dvdstyler.desktop
|
|||
%%DATADIR%%/backgrounds/23_lava.jpg
|
||||
%%DATADIR%%/backgrounds/30_brushed_aluminiun.jpg
|
||||
%%DATADIR%%/backgrounds/31_texture_border.jpg
|
||||
%%DATADIR%%/buttons/arrow-down.xml
|
||||
%%DATADIR%%/buttons/arrow-left.xml
|
||||
%%DATADIR%%/buttons/arrow-next.xml
|
||||
%%DATADIR%%/buttons/arrow-right.xml
|
||||
%%DATADIR%%/buttons/arrow-up.xml
|
||||
%%DATADIR%%/backgrounds/32_blue_fractal.jpg
|
||||
%%DATADIR%%/backgrounds/40_swans.jpg
|
||||
%%DATADIR%%/backgrounds/45_nevado.jpg
|
||||
%%DATADIR%%/backgrounds/46_paisaje.jpg
|
||||
%%DATADIR%%/buttons/arrow-star.xml
|
||||
%%DATADIR%%/buttons/arrow.xml
|
||||
%%DATADIR%%/buttons/arrow2-down.xml
|
||||
%%DATADIR%%/buttons/arrow2-left.xml
|
||||
%%DATADIR%%/buttons/arrow2-right.xml
|
||||
%%DATADIR%%/buttons/arrow2-up.xml
|
||||
%%DATADIR%%/buttons/arrow2.xml
|
||||
%%DATADIR%%/buttons/arrow3.xml
|
||||
%%DATADIR%%/buttons/buttons.lst
|
||||
%%DATADIR%%/buttons/cancel.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow-down.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow-left.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow-next.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow-right.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow-up.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow2-down.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow2-left.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow2-right.xml
|
||||
%%DATADIR%%/buttons/deprecated/arrow2-up.xml
|
||||
%%DATADIR%%/buttons/deprecated/text-shadow.xml
|
||||
%%DATADIR%%/buttons/deprecated/text-underlined.xml
|
||||
%%DATADIR%%/buttons/deprecated/text.xml
|
||||
%%DATADIR%%/buttons/ellipse.xml
|
||||
%%DATADIR%%/buttons/frame.xml
|
||||
%%DATADIR%%/buttons/ok.xml
|
||||
%%DATADIR%%/buttons/pill.xml
|
||||
%%DATADIR%%/buttons/text-circle.xml
|
||||
%%DATADIR%%/buttons/text-shadow.xml
|
||||
%%DATADIR%%/buttons/text.xml
|
||||
%%DATADIR%%/buttons/text-square.xml
|
||||
%%DATADIR%%/buttons/text-underlined-v2.xml
|
||||
%%DATADIR%%/buttons/text-v2.xml
|
||||
%%DATADIR%%/data/empty_ntsc_ac3.mpg
|
||||
%%DATADIR%%/data/empty_ntsc_mp2.mpg
|
||||
%%DATADIR%%/data/empty_pal_ac3.mpg
|
||||
%%DATADIR%%/data/empty_pal_mp2.mpg
|
||||
%%DATADIR%%/data/silence.ac3
|
||||
%%DATADIR%%/data/silence.mp2
|
||||
%%DATADIR%%/data/subtitles.rgb
|
||||
%%DATADIR%%/docs/help_de.zip
|
||||
%%DATADIR%%/docs/help_en.zip
|
||||
%%DATADIR%%/docs/help_ja.zip
|
||||
%%DATADIR%%/docs/help_nb.zip
|
||||
%%DATADIR%%/docs/help_ru.zip
|
||||
%%DATADIR%%/objects/ellipse.xml
|
||||
%%DATADIR%%/objects/frame.xml
|
||||
%%DATADIR%%/objects/image.xml
|
||||
%%DATADIR%%/objects/rectangle.xml
|
||||
%%DATADIR%%/objects/text-shadow.xml
|
||||
%%DATADIR%%/objects/text.xml
|
||||
%%DATADIR%%/rc/add.png
|
||||
%%DATADIR%%/rc/dvdstyler.png
|
||||
%%DATADIR%%/rc/files.png
|
||||
%%DATADIR%%/rc/folder1.png
|
||||
%%DATADIR%%/rc/folder2.png
|
||||
%%DATADIR%%/rc/logo.png
|
||||
%%DATADIR%%/rc/logoSmall.png
|
||||
%%DATADIR%%/rc/minus.png
|
||||
%%DATADIR%%/rc/move.cur
|
||||
%%DATADIR%%/rc/nesw.cur
|
||||
%%DATADIR%%/rc/new.png
|
||||
%%DATADIR%%/rc/noaudio.png
|
||||
%%DATADIR%%/rc/nwse.cur
|
||||
%%DATADIR%%/rc/open.png
|
||||
%%DATADIR%%/rc/plus.png
|
||||
%%DATADIR%%/rc/preferences.png
|
||||
%%DATADIR%%/rc/remove.png
|
||||
%%DATADIR%%/rc/run.png
|
||||
%%DATADIR%%/rc/save.png
|
||||
share/locale/ca/LC_MESSAGES/dvdstyler.mo
|
||||
%%DATADIR%%/templates/blue.dvdt
|
||||
%%DATADIR%%/templates/blue.png
|
||||
%%DATADIR%%/templates/travel.dvdt
|
||||
%%DATADIR%%/templates/travel.png
|
||||
%%DATADIR%%/templates/turbulence.dvdt
|
||||
%%DATADIR%%/templates/turbulence.png
|
||||
share/locale/cs/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/da/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/de/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/el/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/es/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/eu/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/fr/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/hu/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/hy/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/it/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/ja/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/ko/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/mk/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/nb/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/nl/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/pl/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/pt/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/ru/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/sk/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/sl/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/sr/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/sv/LC_MESSAGES/dvdstyler.mo
|
||||
share/locale/vi/LC_MESSAGES/dvdstyler.mo
|
||||
share/pixmaps/dvdstyler.png
|
||||
@dirrm %%DATADIR%%/templates
|
||||
@dirrm %%DATADIR%%/rc
|
||||
@dirrm %%DATADIR%%/objects
|
||||
@dirrm %%DATADIR%%/docs
|
||||
@dirrm %%DATADIR%%/data
|
||||
@dirrm %%DATADIR%%/buttons/deprecated
|
||||
@dirrm %%DATADIR%%/buttons
|
||||
@dirrm %%DATADIR%%/backgrounds
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue