Finally it seems that the base Gcc is sufficient: only -Wtype-limits is
newer and can be removed. Submitted by: danfe
This commit is contained in:
parent
ba4d09242d
commit
d97131927f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383475
2 changed files with 13 additions and 10 deletions
|
@ -26,12 +26,6 @@ PRFX2FIX= src/makefile.bsd usrshare/conf_user/xinitrc.mined \
|
|||
src/minedaux.c man/mined.1 src/mkinclud.mak \
|
||||
src/makefile.gcc
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000000
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
.for FILE in ${PRFX2FIX}
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/${FILE}
|
||||
|
@ -55,4 +49,4 @@ post-install:
|
|||
@${RM} -rf ${STAGEDIR}${DOCSDIR}/CHANGES ${STAGEDIR}${DOCSDIR}/LICENCE.GPL
|
||||
@${RM} -rf ${STAGEDIR}${DATADIR}/doc_user ${STAGEDIR}${DATADIR}/package_doc
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,15 @@
|
|||
--- src/mkinclud.gcc.orig 2011-07-20 00:00:00.000000000 +0200
|
||||
+++ src/mkinclud.gcc 2011-11-20 18:44:14.000000000 +0100
|
||||
@@ -48,7 +48,7 @@
|
||||
--- src/mkinclud.gcc.orig 2015-03-08 23:00:00 UTC
|
||||
+++ src/mkinclud.gcc
|
||||
@@ -48,7 +48,7 @@ GFLAGS= -ansi -Waggregate-return -Winlin
|
||||
|
||||
GCC3FLAGS=-Wdeclaration-after-statement -Wno-pragmas
|
||||
# -Wunreachable-code deprecated
|
||||
-GCC4FLAGS=$(GCC3FLAGS) -Wno-pointer-sign -Wtype-limits
|
||||
+GCC4FLAGS=$(GCC3FLAGS) -Wno-pointer-sign
|
||||
|
||||
# Warning options for newer gcc versions:
|
||||
# (additional grep for the sake of MSys sed failing on CRLF from MinGW gcc)
|
||||
@@ -71,7 +71,7 @@ PROTOFLAGS= -Wmissing-prototypes -Wretur
|
||||
# compilation mode options (optimisation and debug)
|
||||
|
||||
# Optimization flag/level:
|
||||
|
|
Loading…
Reference in a new issue