- Add graphics/vpaint: Experimental vector graphics and 2D animation editor

VPaint is an experimental prototype based on the Vector Graphics
Complex (VGC), a technology developed by a collaboration of researchers
at Inria and the University of British Columbia. It allows you to
create resolution-independent illustrations and animations using
innovative techniques.

WWW: https://www.vpaint.org/
This commit is contained in:
Dmitry Marakasov 2020-01-10 11:13:33 +00:00
parent 0d00bfd7e9
commit d9ebd7c5e8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=522565
7 changed files with 120 additions and 0 deletions

View file

@ -1042,6 +1042,7 @@
SUBDIR += vkd3d
SUBDIR += volpack
SUBDIR += vp
SUBDIR += vpaint
SUBDIR += vulkan-loader
SUBDIR += vv
SUBDIR += waffle

57
graphics/vpaint/Makefile Normal file
View file

@ -0,0 +1,57 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
PORTNAME= vpaint
PORTVERSION= 1.7
DISTVERSIONPREFIX= v
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Experimental vector graphics and 2D animation editor
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= dalboris
USES= compiler:c++11-lib eigen:3 gl qmake qt:5
USE_QT= core gui widgets opengl network qmake_build buildtools_build
USE_GL= gl glu glew
QMAKE_SOURCE_PATH= ${WRKSRC}/src/Gui
CXXFLAGS+= -isystem ${LOCALBASE}/include/eigen3
PORTDOCS= *
PORTEXAMPLES= *
DESKTOP_ENTRIES="VPaint" \
"Vector-Based Animation Editor" \
"VPaint" \
"VPaint" \
"Graphics;" \
""
OPTIONS_DEFINE= DOCS EXAMPLES
post-extract:
@${RM} -r ${WRKSRC}/src/Third
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/VPaint ${STAGEDIR}${PREFIX}/bin
.for s in 16 32 48 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}
${INSTALL_DATA} ${WRKSRC}/src/Gui/images/icon-${s}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/VPaint.png
.endfor
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.vec ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

3
graphics/vpaint/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1578600227
SHA256 (dalboris-vpaint-v1.7_GH0.tar.gz) = 0e3fcad20bcd662c9fe341ea8f98277223bc5f4bbc372f846d99bf38b4c0d156
SIZE (dalboris-vpaint-v1.7_GH0.tar.gz) = 2254345

View file

@ -0,0 +1,37 @@
--- src/Gui/Gui.pro.orig 2020-01-07 15:06:58 UTC
+++ src/Gui/Gui.pro
@@ -65,7 +65,7 @@ win32 {
}
# GLU
-unix:!macx: LIBS += -lGLU
+unix:!macx: LIBS += -lGLU -lGLEW
win32 {
LIBS += glu32.lib
}
@@ -73,25 +73,6 @@ win32 {
###############################################################################
# SHIPPED EXTERNAL LIBRARIES
-# Add shipped external libraries to includepath and dependpath
-INCLUDEPATH += $$PWD/../Third/
-DEPENDPATH += $$PWD/../Third/
-!win32: QMAKE_CXXFLAGS += $$QMAKE_CFLAGS_ISYSTEM $$PWD/../Third/
-
-# Define RELEASE_OR_DEBUG convenient variable
-CONFIG(release, debug|release): RELEASE_OR_DEBUG = release
-CONFIG(debug, debug|release): RELEASE_OR_DEBUG = debug
-
-# GLEW
-win32 {
- LIBS += -L$$OUT_PWD/../Third/GLEW/$$RELEASE_OR_DEBUG/ -lGLEW
- win32-g++: PRE_TARGETDEPS += $$OUT_PWD/../Third/GLEW/$$RELEASE_OR_DEBUG/libGLEW.a
- else: PRE_TARGETDEPS += $$OUT_PWD/../Third/GLEW/$$RELEASE_OR_DEBUG/GLEW.lib
-}
-else:unix {
- LIBS += -L$$OUT_PWD/../Third/GLEW/ -lGLEW
- PRE_TARGETDEPS += $$OUT_PWD/../Third/GLEW/libGLEW.a
-}
###############################################################################

View file

@ -0,0 +1,10 @@
--- src/VPaint.pro.orig 2020-01-07 15:06:58 UTC
+++ src/VPaint.pro
@@ -18,7 +18,5 @@
TEMPLATE = subdirs
SUBDIRS += \
- Third/GLEW \
Gui
-Gui.depends = Third/GLEW

View file

@ -0,0 +1,7 @@
VPaint is an experimental prototype based on the Vector Graphics
Complex (VGC), a technology developed by a collaboration of researchers
at Inria and the University of British Columbia. It allows you to
create resolution-independent illustrations and animations using
innovative techniques.
WWW: https://www.vpaint.org/

View file

@ -0,0 +1,5 @@
bin/VPaint
share/icons/hicolor/16x16/VPaint.png
share/icons/hicolor/256x256/VPaint.png
share/icons/hicolor/32x32/VPaint.png
share/icons/hicolor/48x48/VPaint.png