GNU binutils for PowerPC/RS6000 cross-development.
Prerequisite for the GCC for PowerPC/RS6000 cross-compilation environment. WWW: http://sources.redhat.com/binutils/ PR: ports/94681 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
This commit is contained in:
parent
25eff2e149
commit
da35e9ab9a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=167518
6 changed files with 206 additions and 0 deletions
|
@ -1507,6 +1507,7 @@
|
|||
SUBDIR += portmk
|
||||
SUBDIR += porttools
|
||||
SUBDIR += poslib
|
||||
SUBDIR += powerpc-binutils
|
||||
SUBDIR += powerpc-rtems-binutils
|
||||
SUBDIR += powerpc-rtems-g77
|
||||
SUBDIR += powerpc-rtems-gcc
|
||||
|
|
70
devel/powerpc-binutils/Makefile
Normal file
70
devel/powerpc-binutils/Makefile
Normal file
|
@ -0,0 +1,70 @@
|
|||
# New ports collection makefile for: powerpc-binutils
|
||||
# Date created: 9 Marth 2006
|
||||
# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= binutils
|
||||
PORTVERSION= 2.16.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
|
||||
MASTER_SITE_SUBDIR= binutils/releases
|
||||
|
||||
MAINTAINER= ssedov@mbsd.msk.ru
|
||||
COMMENT= GNU binutils for PowerPC/RS6000 cross-development
|
||||
|
||||
WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
NO_MTREE= yes
|
||||
|
||||
.if defined(WITH_ABI)
|
||||
OUR_ABI= ${WITH_ABI}
|
||||
.else
|
||||
OUR_ABI= eabi
|
||||
.endif
|
||||
|
||||
OUR_TARGET= powerpc-elf-${OUR_ABI}
|
||||
|
||||
PKGNAMEPREFIX= ${OUR_TARGET}-
|
||||
PLIST_SUB+= TOOLPREFIX=${OUR_TARGET}
|
||||
PREFIX?= ${LOCALBASE}/${OUR_TARGET}
|
||||
CONFIGURE_ARGS= --disable-nls \
|
||||
--target=${OUR_TARGET} \
|
||||
--with-system-zlib \
|
||||
--with-libiconv-prefix=${LOCALDIR} \
|
||||
--libdir=${PREFIX}/lib/gcc/${OUR_TARGET}
|
||||
|
||||
MAN1= ${PKGNAMEPREFIX}addr2line.1 \
|
||||
${PKGNAMEPREFIX}ar.1 \
|
||||
${PKGNAMEPREFIX}as.1 \
|
||||
${PKGNAMEPREFIX}c++filt.1 \
|
||||
${PKGNAMEPREFIX}dlltool.1 \
|
||||
${PKGNAMEPREFIX}ld.1 \
|
||||
${PKGNAMEPREFIX}nlmconv.1 \
|
||||
${PKGNAMEPREFIX}nm.1 \
|
||||
${PKGNAMEPREFIX}objcopy.1 \
|
||||
${PKGNAMEPREFIX}objdump.1 \
|
||||
${PKGNAMEPREFIX}ranlib.1 \
|
||||
${PKGNAMEPREFIX}readelf.1 \
|
||||
${PKGNAMEPREFIX}size.1 \
|
||||
${PKGNAMEPREFIX}strings.1 \
|
||||
${PKGNAMEPREFIX}strip.1 \
|
||||
${PKGNAMEPREFIX}windres.1
|
||||
|
||||
INFO= as binutils ld
|
||||
|
||||
BINARIES= addr2line ar as c++filt ld \
|
||||
nm objcopy objdump ranlib \
|
||||
readelf size strings strip
|
||||
|
||||
post-install:
|
||||
.for F in ${BINARIES}
|
||||
@${LN} -sf ${PREFIX}/bin/${PKGNAMEPREFIX}$F \
|
||||
${PREFIX}/bin/$F
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/powerpc-binutils/distinfo
Normal file
3
devel/powerpc-binutils/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (binutils-2.16.1.tar.bz2) = 6a9d529efb285071dad10e1f3d2b2967
|
||||
SHA256 (binutils-2.16.1.tar.bz2) = 351a6846ee179a37ed87a487971547159a7f4f92a1dec598c727f184a0de61ae
|
||||
SIZE (binutils-2.16.1.tar.bz2) = 12549917
|
48
devel/powerpc-binutils/files/patch-aa
Normal file
48
devel/powerpc-binutils/files/patch-aa
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- libiberty/Makefile.in.orig Tue Mar 8 00:20:07 2005
|
||||
+++ libiberty/Makefile.in Thu Jun 30 22:37:45 2005
|
||||
@@ -270,7 +270,8 @@
|
||||
@MAINT@ echo stamp > stamp-functions
|
||||
|
||||
INSTALL_DEST = @INSTALL_DEST@
|
||||
-install: install_to_$(INSTALL_DEST) install-subdir
|
||||
+#install: install_to_$(INSTALL_DEST) install-subdir
|
||||
+install:
|
||||
|
||||
install_to_libdir: all
|
||||
${mkinstalldirs} $(DESTDIR)$(libdir)$(MULTISUBDIR)
|
||||
--- bfd/Makefile.in.orig Mon May 2 21:45:46 2005
|
||||
+++ bfd/Makefile.in Thu Jun 30 22:39:28 2005
|
||||
@@ -1137,7 +1137,8 @@
|
||||
for dir in "$(DESTDIR)$(bfdlibdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
-install: install-recursive
|
||||
+#install: install-recursive
|
||||
+install:
|
||||
install-exec: install-exec-recursive
|
||||
install-data: install-data-recursive
|
||||
uninstall: uninstall-recursive
|
||||
--- opcodes/Makefile.in.orig Mon Feb 21 12:48:33 2005
|
||||
+++ opcodes/Makefile.in Thu Jun 30 22:39:18 2005
|
||||
@@ -781,7 +781,8 @@
|
||||
for dir in "$(DESTDIR)$(bfdlibdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
-install: install-recursive
|
||||
+#install: install-recursive
|
||||
+install:
|
||||
install-exec: install-exec-recursive
|
||||
install-data: install-data-recursive
|
||||
uninstall: uninstall-recursive
|
||||
--- etc/Makefile.in.orig Thu Jan 2 21:51:02 2003
|
||||
+++ etc/Makefile.in Thu Jun 30 22:37:45 2005
|
||||
@@ -54,7 +54,8 @@
|
||||
all:
|
||||
|
||||
# We want install to imply install-info as per GNU standards.
|
||||
-install: install-info
|
||||
+#install: install-info
|
||||
+install:
|
||||
|
||||
uninstall:
|
||||
|
5
devel/powerpc-binutils/pkg-descr
Normal file
5
devel/powerpc-binutils/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
GNU binutils for PowerPC/RS6000 cross-development.
|
||||
|
||||
Prerequisite for the GCC for PowerPC/RS6000 cross-compilation environment.
|
||||
|
||||
WWW: http://sources.redhat.com/binutils/
|
79
devel/powerpc-binutils/pkg-plist
Normal file
79
devel/powerpc-binutils/pkg-plist
Normal file
|
@ -0,0 +1,79 @@
|
|||
bin/%%TOOLPREFIX%%-addr2line
|
||||
bin/%%TOOLPREFIX%%-ar
|
||||
bin/%%TOOLPREFIX%%-as
|
||||
bin/%%TOOLPREFIX%%-c++filt
|
||||
bin/%%TOOLPREFIX%%-ld
|
||||
bin/%%TOOLPREFIX%%-nm
|
||||
bin/%%TOOLPREFIX%%-objcopy
|
||||
bin/%%TOOLPREFIX%%-objdump
|
||||
bin/%%TOOLPREFIX%%-ranlib
|
||||
bin/%%TOOLPREFIX%%-readelf
|
||||
bin/%%TOOLPREFIX%%-size
|
||||
bin/%%TOOLPREFIX%%-strings
|
||||
bin/%%TOOLPREFIX%%-strip
|
||||
bin/addr2line
|
||||
bin/ar
|
||||
bin/as
|
||||
bin/c++filt
|
||||
bin/ld
|
||||
bin/nm
|
||||
bin/objcopy
|
||||
bin/objdump
|
||||
bin/ranlib
|
||||
bin/readelf
|
||||
bin/size
|
||||
bin/strings
|
||||
bin/strip
|
||||
%%TOOLPREFIX%%/bin/ar
|
||||
%%TOOLPREFIX%%/bin/as
|
||||
%%TOOLPREFIX%%/bin/ld
|
||||
%%TOOLPREFIX%%/bin/nm
|
||||
%%TOOLPREFIX%%/bin/objdump
|
||||
%%TOOLPREFIX%%/bin/ranlib
|
||||
%%TOOLPREFIX%%/bin/strip
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.x
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xbn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xd
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xdc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xdw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xr
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xs
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xsc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xsw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xu
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppc.xw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.x
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xbn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xd
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xdc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xdw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xr
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xs
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xsc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xsw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xu
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppclinux.xw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.x
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xbn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xd
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xdc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xdw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xn
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xr
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xs
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xsc
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xsw
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xu
|
||||
%%TOOLPREFIX%%/lib/ldscripts/elf32ppcsim.xw
|
||||
@dirrm %%TOOLPREFIX%%/bin
|
||||
@dirrm %%TOOLPREFIX%%/lib/ldscripts
|
||||
@dirrm %%TOOLPREFIX%%/lib
|
||||
@dirrm %%TOOLPREFIX%%
|
||||
@dirrm man/man1
|
||||
@dirrm man
|
||||
@dirrm bin
|
Loading…
Reference in a new issue