- Update to 0.9.91

- Adopt maintainship
- Add docs and examples
This commit is contained in:
Pietro Cerutti 2008-05-30 23:20:13 +00:00
parent b02b3fcacc
commit da9ec125f1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213993
4 changed files with 254 additions and 15 deletions

View file

@ -6,29 +6,27 @@
#
PORTNAME= gnocl
PORTVERSION= 0.9.90
PORTVERSION= 0.9.91
PORTREVISION= 3
CATEGORIES= x11-toolkits devel
MASTER_SITES= SF/gnocl
MAINTAINER= ports@FreeBSD.org
MAINTAINER= gahr@FreeBSD.org
COMMENT= GTK+ and Gnome extension for Tcl
BUILD_DEPENDS= ${LOCALBASE}/include/tcl8.4/tcl.h:${PORTSDIR}/lang/tcl84
USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= gtk20
USE_TCL= 84
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src
CFLAGS+= -I${LOCALBASE}/include/tcl8.4
USE_GNOME= gtk20
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
BROKEN= "Does not compile on sparc64 or ia64"
BROKEN= Does not compile on sparc64 or ia64
.endif
.if ${ARCH} == amd64
@ -82,6 +80,13 @@ post-patch:
.if defined(WITHOUT_GNOMEVFS2)
${REINPLACE_CMD} -e 's=^USE_VFS=#USE_VFS=' ${BUILD_WRKSRC}/Makefile
.endif
${FIND} ${WRKSRC}/demos -name "*.tcl" | ${XARGS} \
${REINPLACE_CMD} -i "" -e 's|tclsh|${TCLSH}|g; \
s|package require Gnocl|load ${PREFIX}/lib/libgnocl.so.1; package require Gnocl|g; \
s|package require GnoclCanvas|load ${PREFIX}/lib/libgnoclCanvas.so.1; package require GnoclCanvas|g; \
s|package require GnoclGconf|load ${PREFIX}/lib/libgnoclGconf.so.1; package require GnoclGconf|g; \
s|package require GnoclGnome|load ${PREFIX}/lib/libgnoclGnome.so.1; package require GnoclGnome|g; \
s|package require GnoclVFS|load ${PREFIX}/lib/libgnoclVFS.so.1; package require GnoclVFS|g'
do-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/gnocl.so ${PREFIX}/lib/libgnocl.so.1
@ -98,4 +103,14 @@ do-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/gnoclVFS.so ${PREFIX}/lib/libgnoclVFS.so.1; \
fi; \
post-install:
.if !defined(NOPORTDOCS)
${INSTALL} -d ${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
.if !defined(NOPORTEXAMPLES)
${INSTALL} -d ${EXAMPLESDIR}
(cd ${WRKSRC}/demos && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (gnocl-0.9.90.tar.bz2) = 2458eff0c8a2a21bd4f36a776974ac53
SHA256 (gnocl-0.9.90.tar.bz2) = d15655eb8269dc57123e41406485eb3bbf9817af402096cd3058c01438adb5b5
SIZE (gnocl-0.9.90.tar.bz2) = 552128
MD5 (gnocl-0.9.91.tar.bz2) = 14a8f80b1651f2c4b5c6a3b4e7169775
SHA256 (gnocl-0.9.91.tar.bz2) = 67cf290151ab4abc5c1de9d2b2fd94e53c6def49938ecb9578177782ba8d7f4e
SIZE (gnocl-0.9.91.tar.bz2) = 549134

View file

@ -1,15 +1,20 @@
--- src/Makefile.orig Sun Jul 24 14:40:44 2005
+++ src/Makefile Sun Jul 24 14:41:16 2005
@@ -22,12 +22,12 @@
CFLAGS += -Wall -pedantic -fPIC
--- src/Makefile.orig 2006-02-27 21:27:55.000000000 +0100
+++ src/Makefile 2008-05-30 16:17:43.000000000 +0200
@@ -19,16 +19,16 @@
# for releases use -Os, this makes the lib 15% smaller
# amd64 need -fPIC, x86 works with and without
-CFLAGS += -Wall -pedantic -fPIC
+CFLAGS += -Wall -fPIC
GTK_24 := $(shell pkg-config --atleast-version=2.4 'gtk+-2.0' && echo yes)
GTK_26 := $(shell pkg-config --atleast-version=2.6 'gtk+-2.0' && echo yes)
-TCL_VERSION := $(shell echo 'puts $$tcl_version' | tclsh)
+TCL_VERSION := 84
# this breaks build on GTK 2.4
# -DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED
export ADDCFLAGS := -DVERSION=\"$(VERSION)\" -DUSE_TCL_STUBS $(shell pkg-config --cflags gtk+-2.0)
export ADDCFLAGS := -DVERSION=\"$(VERSION)\" -DUSE_TCL_STUBS $(shell pkg-config --cflags gtk+-2.0) -I/usr/include/tcl$(TCL_VERSION)/
-export LIBS := $(shell pkg-config --libs gtk+-2.0) -ltclstub$(TCL_VERSION)
+export LIBS := $(shell pkg-config --libs gtk+-2.0) -ltclstub$(TCL_VERSION) -L$(LOCALBASE)/lib

View file

@ -3,3 +3,222 @@ lib/libgnocl.so.1
%%GNOCL_GCONF_FILE%%
%%GNOCL_GNOME_FILE%%
%%GNOCL_VFS_FILE%%
%%PORTDOCS%%%%DOCSDIR%%/gnocl/index.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/t118.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/x165.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/x351.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r355.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r408.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r438.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r499.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r547.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r571.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r586.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r796.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1075.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1365.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1461.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1656.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1765.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1926.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r1987.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r2256.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r2464.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r2671.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r2842.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r3025.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r3218.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r3424.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r3625.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r3834.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4259.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4423.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4533.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4668.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4864.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r4983.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5114.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5240.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5400.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5554.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5638.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5768.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r5890.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6060.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6227.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6423.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6543.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6702.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r6897.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r7006.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r7725.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r7760.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r7952.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8030.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8128.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8563.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8704.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8793.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8902.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r8984.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9102.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9219.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9330.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9674.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9824.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r9914.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10031.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10267.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10422.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10639.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10734.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r10843.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/r11010.html
%%PORTDOCS%%%%DOCSDIR%%/gnocl/a11173.html
%%PORTDOCS%%%%DOCSDIR%%/pics/menu.png
%%PORTDOCS%%%%DOCSDIR%%/pics/colorSelection.png
%%PORTDOCS%%%%DOCSDIR%%/pics/optionMenu.png
%%PORTDOCS%%%%DOCSDIR%%/pics/combo.png
%%PORTDOCS%%%%DOCSDIR%%/pics/tree.png
%%PORTDOCS%%%%DOCSDIR%%/pics/list.png
%%PORTDOCS%%%%DOCSDIR%%/pics/menuItem.png
%%PORTDOCS%%%%DOCSDIR%%/pics/eventBox.png
%%PORTDOCS%%%%DOCSDIR%%/pics/appletFactory.png
%%PORTDOCS%%%%DOCSDIR%%/pics/percentString.png
%%PORTDOCS%%%%DOCSDIR%%/pics/expander.png
%%PORTDOCS%%%%DOCSDIR%%/pics/checkButton.png
%%PORTDOCS%%%%DOCSDIR%%/pics/label.png
%%PORTDOCS%%%%DOCSDIR%%/pics/comboEntry.png
%%PORTDOCS%%%%DOCSDIR%%/pics/helloWorld.png
%%PORTDOCS%%%%DOCSDIR%%/pics/spinButton.png
%%PORTDOCS%%%%DOCSDIR%%/pics/stockButtons.png
%%PORTDOCS%%%%DOCSDIR%%/pics/paned.png
%%PORTDOCS%%%%DOCSDIR%%/pics/text.png
%%PORTDOCS%%%%DOCSDIR%%/pics/menuSeparator.png
%%PORTDOCS%%%%DOCSDIR%%/pics/box.png
%%PORTDOCS%%%%DOCSDIR%%/pics/scale.png
%%PORTDOCS%%%%DOCSDIR%%/pics/toolBar.png
%%PORTDOCS%%%%DOCSDIR%%/pics/dialog.png
%%PORTDOCS%%%%DOCSDIR%%/pics/notebook.png
%%PORTDOCS%%%%DOCSDIR%%/pics/fontSelection.png
%%PORTDOCS%%%%DOCSDIR%%/pics/colorButton.png
%%PORTDOCS%%%%DOCSDIR%%/pics/button.png
%%PORTDOCS%%%%DOCSDIR%%/pics/radioButton.png
%%PORTDOCS%%%%DOCSDIR%%/pics/menuRadioItem.png
%%PORTDOCS%%%%DOCSDIR%%/pics/fontButton.png
%%PORTDOCS%%%%DOCSDIR%%/pics/image.png
%%PORTDOCS%%%%DOCSDIR%%/pics/socket.png
%%PORTDOCS%%%%DOCSDIR%%/pics/scrolledWindow.png
%%PORTDOCS%%%%DOCSDIR%%/pics/menuCheckItem.png
%%PORTDOCS%%%%DOCSDIR%%/pics/fileSelection.png
%%PORTDOCS%%%%DOCSDIR%%/pics/canvas.png
%%PORTDOCS%%%%DOCSDIR%%/pics/separator.png
%%PORTDOCS%%%%DOCSDIR%%/pics/entry.png
%%PORTDOCS%%%%DOCSDIR%%/pics/progressBar.png
%%PORTDOCS%%%%DOCSDIR%%/pics/menuBar.png
%%PORTDOCS%%%%DOCSDIR%%/pics/statusBar.png
%%PORTDOCS%%%%DOCSDIR%%/pics/window.png
%%PORTDOCS%%%%DOCSDIR%%/pics/fileChooser.png
%%PORTDOCS%%%%DOCSDIR%%/pics/comboBox.png
%%PORTDOCS%%%%DOCSDIR%%/pics/table.png
%%PORTDOCS%%%%DOCSDIR%%/pics/simple.png
%%PORTDOCS%%%%DOCSDIR%%/xml/manpages.txt
%%PORTDOCS%%%%DOCSDIR%%/xml/gnocl.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/concepts.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/nonwidgetcmds.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/appletfactory.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/file.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/mime.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/sed_cmds
%%PORTDOCS%%%%DOCSDIR%%/xml/txt2xml.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-widget.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-richText.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-polygon.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-lines.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-lines.tcl-bcp20040921
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-affine.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-clipGroup.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-text.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-tags.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/canvas-man.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/canvas/test-canvas-bpath.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/deprecated/test-combo.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/deprecated/test-optionMenu.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/doTests
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/embed-tk.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/embed.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/floppybuddy.gif
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gconf/test-gconf.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnome/gnocl_test_applet.server
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnome/test-session.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnome/gnocl-applet
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnome/canvas.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnome/README.applet
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jitter.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mini.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/one.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regexp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socket-man.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socket.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-aboutDialog.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-action.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-align-hor.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-align-vert.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-box.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-box2.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-box3.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/three.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-button.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-check.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-checkButton.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-clipboard.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-comboBox.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-comboEntry.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-dialog.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-dnd.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-entry.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-eventBox.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-expander.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-fileChooser.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-image.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-label.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-list.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-menu.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-menu2.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-notebook.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-paned.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/two.jpg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-plug.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-progressBar.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-radio.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-radioButton.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-scale.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-scrolledWindow.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-selectors.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-sizeGroup.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-spinButton.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-statusBar.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-table-col.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-table-row.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-table.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-table2.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-text.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-toolBar.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-tree.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-window.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vfs/q
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vfs/q.zip
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vfs/test-vfs.tcl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vfs/q3.zip
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/widgets.tcl
%%PORTDOCS%%@dirrm %%DOCSDIR%%/gnocl
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pics
%%PORTDOCS%%@dirrm %%DOCSDIR%%/xml
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/canvas
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/deprecated
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/gconf
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/gnome
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/vfs
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%