x11-toolkits/ocaml-labltk: drop nowadays useless (no-op) patches.

This commit is contained in:
Alexey Dokuchaev 2022-04-23 19:35:48 +00:00
parent f8e11dde83
commit dadd234a64
3 changed files with 0 additions and 42 deletions

View file

@ -28,8 +28,6 @@ post-patch:
-e 's/$$(INSTALLBINDIR)/$$(DESTDIR)$$(INSTALLBINDIR)/g' \
-e 's/$$(STUBLIBDIR)/$$(DESTDIR)$$(STUBLIBDIR)/g' \
-e 's/mkdir /& -p /g'
@${REINPLACE_CMD} -e 's|%%SCRIPTBASE%%|${PREFIX}/lib/ocaml/labltk/|g' \
${WRKSRC}/lib/Makefile
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/ocaml/stublibs

View file

@ -1,22 +0,0 @@
--- configure.orig 2014-09-18 04:08:33 UTC
+++ configure
@@ -44,10 +44,6 @@ exec 3>&1
# Parse command-line arguments
-if echo "$configure_options" | grep -q -e '--\?[a-zA-Z0-9-]\+='; then
- err "Arguments to this script look like '-libdir /foo/bar', not '-libdir=/foo/bar' (note the '=')."
-fi
-
while : ; do
case "$1" in
"") break;;
@@ -222,6 +218,8 @@ if test $has_tk = true && test -z "$tk_l
esac
if test -n "$tklibdir"; then
case "$system" in
+ freebsd) tk_libs="-L$tklibdir" ;;
+ bsd_elf) tk_libs="-L$tklibdir" ;;
*bsd*) tk_libs="-R$tklibdir -L$tklibdir" ;;
*) tk_libs="-L$tklibdir" ;;
esac

View file

@ -1,18 +0,0 @@
--- lib/Makefile.orig 2014-09-18 04:08:33 UTC
+++ lib/Makefile
@@ -75,7 +75,7 @@ $(LIBNAME)top$(EXE) : $(LIBNAME).cma ../
$(LIBNAME): Makefile
@echo Generate $@
@echo "#!/bin/sh" > $@
- @echo 'exec $(INSTALLDIR)/$(LIBNAME)top$(EXE) -I $(INSTALLDIR) "$$@"' >> $@
+ @echo 'exec %%SCRIPTBASE%%/$(LIBNAME)top$(EXE) -I %%SCRIPTBASE%% "$$@"' >> $@
install-script: $(LIBNAME)
cp $(LIBNAME) $(INSTALLBINDIR)
@@ -114,4 +114,4 @@ installopt:
cd $(INSTALLDIR); $(RANLIB) $(LIBNAME).$(A)
chmod 644 $(INSTALLDIR)/$(LIBNAME).cmxa
chmod 644 $(INSTALLDIR)/$(LIBNAME).$(A)
-endif
\ No newline at end of file
+endif