New port: desktop-file-utils, a couple of command line utilities

for working with desktop entries

	desktop-file-utils contains a couple of command line utilities
	for working with desktop entries, aswell as a menu module
	for GnomeVFS.

	WWW: http://www.freedesktop.org/Software/desktop-file-utils

PR:		ports/67814
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Edwin Groothuis 2004-07-18 12:04:44 +00:00
parent e88d4982c1
commit db18f2278d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113902
6 changed files with 66 additions and 0 deletions

View file

@ -185,6 +185,7 @@
SUBDIR += datadesigner
SUBDIR += ddd
SUBDIR += decompyle
SUBDIR += desktop-file-utils
SUBDIR += devhelp
SUBDIR += devtodo
SUBDIR += dia2code

View file

@ -0,0 +1,38 @@
# New ports collection makefile for: desktop-file-utils
# Date created: 11 Jun 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
#
PORTNAME= desktop-file-utils
PORTVERSION= 0.6
CATEGORIES= devel
MASTER_SITES= http://freedesktop.org/Software/desktop-file-utils/releases/
MAINTAINER= jylefort@brutele.be
COMMENT= A couple of command line utilities for working with desktop entries
LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
# This port contains no X program but it might install a GnomeVFS
# module and thus we need to use the same prefix as GnomeVFS.
USE_X_PREFIX= yes
USE_GNOME= glib20
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomevfs2} != ""
USE_GNOME+= gnomevfs2
PLIST_SUB+= GNOME_VFS=""
.else
PLIST_SUB+= GNOME_VFS="@comment "
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (desktop-file-utils-0.6.tar.gz) = dcace3294470e9cdc9ebfe7de1881ece
SIZE (desktop-file-utils-0.6.tar.gz) = 386988

View file

@ -0,0 +1,11 @@
--- src/menu-method.c.orig Fri Jun 11 00:39:02 2004
+++ src/menu-method.c Fri Jun 11 00:39:43 2004
@@ -117,7 +117,7 @@
GnomeVFSOpenMode mode,
FileHandle **handle,
gboolean exclusive,
- unsigned int perms);
+ mode_t perms);
static void file_handle_unref (FileHandle *handle);
static GnomeVFSResult file_handle_read (FileHandle *handle,
gpointer buffer,

View file

@ -0,0 +1,7 @@
desktop-file-utils contains a couple of command line utilities for
working with desktop entries, aswell as a menu module for GnomeVFS.
WWW: http://www.freedesktop.org/Software/desktop-file-utils
- Jean-Yves Lefort
jylefort@brutele.be

View file

@ -0,0 +1,7 @@
bin/desktop-file-install
bin/desktop-file-validate
bin/desktop-menu-tool
%%GNOME_VFS%%etc/gnome-vfs-2.0/modules/menu-modules.conf
%%GNOME_VFS%%lib/gnome-vfs-2.0/modules/libmenu.a
%%GNOME_VFS%%lib/gnome-vfs-2.0/modules/libmenu.la
%%GNOME_VFS%%lib/gnome-vfs-2.0/modules/libmenu.so