Update to 1.6.5.1a.

This unbreaks -current, so remove BROKEN.

Approved by:	maintainer timeout (distfile missing since december)
This commit is contained in:
Anders Nordby 2003-05-18 19:13:41 +00:00
parent 3d2066e576
commit db1d97300e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81270
7 changed files with 3 additions and 135 deletions

View file

@ -6,12 +6,9 @@
#
PORTNAME= xsidplay
PORTVERSION= 1.6.4.3
PORTREVISION= 2
PORTVERSION= 1.6.5.1a
PORTEPOCH= 1
CATEGORIES= audio emulators
# version 1.6.4.3 isn't fetchable anymore, informed maintainer about
# version 1.6.5pre19 which is still there - edwin 20021227
MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/
EXTRACT_SUFX= .tgz
@ -40,10 +37,6 @@ MAN1= xsidplay.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Configure fails"
.endif
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
@ -52,6 +45,7 @@ pre-patch:
.for file in configure src/Makefile.in
@${REINPLACE_CMD} -e 's|lib-mt|libqt-mt|g' ${WRKSRC}/${file}
.endfor
@${REINPLACE_CMD} -e 's|-lqt|-lqt-mt|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}|g' ${WRKSRC}/xsidplay.1
do-install:
@ -63,8 +57,6 @@ do-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/*.faq ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/example-sidtunes/*.sid ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (xsidplay-1.6.4.3.tgz) = a57dda653c9c27068fb830de3de2e6f8
MD5 (xsidplay-1.6.5.1a.tgz) = abe90bc6b7d552969bdd1db38f0a449b

View file

@ -1,25 +0,0 @@
--- scripts/ltmain.sh.orig Wed Nov 14 08:32:24 2001
+++ scripts/ltmain.sh Sat Nov 17 10:31:51 2001
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,11 +0,0 @@
--- src/PlaylistEditDialogData.cpp.orig Mon Nov 19 11:41:19 2001
+++ src/PlaylistEditDialogData.cpp Sat Aug 24 19:41:01 2002
@@ -151,8 +151,6 @@
subtuneSpinBox = new QSpinBox( this, "subtuneSpinBox" );
subtuneSpinBox->setGeometry( QRect( 260, 115, 50, 25 ) );
- subtuneSpinBox->setFrameShape( QSpinBox::WinPanel );
- subtuneSpinBox->setFrameShadow( QSpinBox::Sunken );
subtuneSpinBox->setButtonSymbols( QSpinBox::PlusMinus );
subtuneSpinBox->setMaxValue( 256 );
subtuneSpinBox->setMinValue( 1 );

View file

@ -1,33 +0,0 @@
--- src/audio/AudioDriver.cpp Thu Nov 29 19:15:31 2001
+++ src/audio/AudioDriver.cpp.new Tue Jan 8 21:52:35 2002
@@ -43,11 +43,28 @@
#include "AudioDriver.h"
#if defined(HAVE_NETBSD)
-const char *AudioDriver::AUDIODEVICE[] = { "/dev/audio" };
-#else
+const char *AudioDriver::AUDIODEVICE[] = { "/dev/audio", "" };
+#elif defined(HAVE_FREEBSD)
+const char *AudioDriver::AUDIODEVICE[] = {
+ "/dev/dsp",
+ "/dev/audio",
+ "/dev/dsp0",
+ "/dev/audio0",
+ "/dev/dsp0.0",
+ "/dev/dsp0.1",
+ "/dev/dsp0.2",
+ "/dev/dsp0.3",
+ "/dev/audio0.0",
+ "/dev/audio0.1",
+ "/dev/audio0.2",
+ "/dev/audio0.3",
+ ""
+};
+#elif defined(HAVE_LINUX)
const char *AudioDriver::AUDIODEVICE[] = {
"/dev/dsp",
"/dev/sound/dsp",
+ ""
};
#endif

View file

@ -1,33 +0,0 @@
--- src/audio/linux/AudioDriver.cpp Thu Nov 29 19:15:31 2001
+++ src/audio/linux/AudioDriver.cpp.new Tue Jan 8 21:52:35 2002
@@ -43,11 +43,28 @@
#include "AudioDriver.h"
#if defined(HAVE_NETBSD)
-const char *AudioDriver::AUDIODEVICE[] = { "/dev/audio" };
-#else
+const char *AudioDriver::AUDIODEVICE[] = { "/dev/audio", "" };
+#elif defined(HAVE_FREEBSD)
+const char *AudioDriver::AUDIODEVICE[] = {
+ "/dev/dsp",
+ "/dev/audio",
+ "/dev/dsp0",
+ "/dev/audio0",
+ "/dev/dsp0.0",
+ "/dev/dsp0.1",
+ "/dev/dsp0.2",
+ "/dev/dsp0.3",
+ "/dev/audio0.0",
+ "/dev/audio0.1",
+ "/dev/audio0.2",
+ "/dev/audio0.3",
+ ""
+};
+#elif defined(HAVE_LINUX)
const char *AudioDriver::AUDIODEVICE[] = {
"/dev/dsp",
"/dev/sound/dsp",
+ ""
};
#endif

View file

@ -3,27 +3,5 @@ share/pixmaps/xsidplay.xpm
%%PORTDOCS%%share/doc/xsidplay/README
%%PORTDOCS%%share/doc/xsidplay/STIL.faq
%%PORTDOCS%%share/doc/xsidplay/hv_sids.faq
%%PORTDOCS%%share/examples/xsidplay/Baby_Of_Can_Guru.sid
%%PORTDOCS%%share/examples/xsidplay/C-demo_tune.sid
%%PORTDOCS%%share/examples/xsidplay/Compleeto.sid
%%PORTDOCS%%share/examples/xsidplay/Connect_4.sid
%%PORTDOCS%%share/examples/xsidplay/Dignified.sid
%%PORTDOCS%%share/examples/xsidplay/G_I_Hero.sid
%%PORTDOCS%%share/examples/xsidplay/Galway-tune.sid
%%PORTDOCS%%share/examples/xsidplay/Game_On_Issue_11_89.sid
%%PORTDOCS%%share/examples/xsidplay/Lightforce.sid
%%PORTDOCS%%share/examples/xsidplay/Martinism.sid
%%PORTDOCS%%share/examples/xsidplay/Metropolis.sid
%%PORTDOCS%%share/examples/xsidplay/Microwave.sid
%%PORTDOCS%%share/examples/xsidplay/PayDay-Ingame_tune.sid
%%PORTDOCS%%share/examples/xsidplay/Platou.sid
%%PORTDOCS%%share/examples/xsidplay/Rage_03.sid
%%PORTDOCS%%share/examples/xsidplay/Rambo_First_Blood_Part_II.sid
%%PORTDOCS%%share/examples/xsidplay/SYS4096.sid
%%PORTDOCS%%share/examples/xsidplay/Startrash.sid
%%PORTDOCS%%share/examples/xsidplay/Sweet.sid
%%PORTDOCS%%share/examples/xsidplay/Think_Now.sid
%%PORTDOCS%%share/examples/xsidplay/Zybernix.sid
%%PORTDOCS%%@dirrm share/examples/xsidplay
%%PORTDOCS%%@dirrm share/doc/xsidplay
@unexec rmdir %D/share/pixmaps 2>/dev/null || true