add tulip 1.2.2
A system dedicated to the visualization of huge graphs
This commit is contained in:
parent
11edc1f4f3
commit
db2f1d5355
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=75121
16 changed files with 256 additions and 0 deletions
|
@ -381,6 +381,7 @@
|
||||||
SUBDIR += totem
|
SUBDIR += totem
|
||||||
SUBDIR += transcode
|
SUBDIR += transcode
|
||||||
SUBDIR += truevision
|
SUBDIR += truevision
|
||||||
|
SUBDIR += tulip
|
||||||
SUBDIR += txtmerge
|
SUBDIR += txtmerge
|
||||||
SUBDIR += urt
|
SUBDIR += urt
|
||||||
SUBDIR += utah-glx
|
SUBDIR += utah-glx
|
||||||
|
|
44
graphics/tulip/Makefile
Normal file
44
graphics/tulip/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
||||||
|
# ex:ts=8
|
||||||
|
# Ports collection makefile for: tulip
|
||||||
|
# Date created: Feb 8, 2003
|
||||||
|
# Whom: ijliao
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= tulip
|
||||||
|
PORTVERSION= 1.2.2
|
||||||
|
CATEGORIES= graphics
|
||||||
|
MASTER_SITES= http://dept-info.labri.fr/~auber/projects/tulip/x345/
|
||||||
|
|
||||||
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
|
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
|
||||||
|
png:${PORTSDIR}/graphics/png \
|
||||||
|
gnugetopt:${PORTSDIR}/devel/libgnugetopt
|
||||||
|
|
||||||
|
USE_REINPLACE= yes
|
||||||
|
USE_MESA= yes
|
||||||
|
USE_QT_VER= 3
|
||||||
|
CFLAGS+= -DHAVE_DECL_GETOPT
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||||
|
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lcompat"
|
||||||
|
USE_GMAKE= yes
|
||||||
|
INSTALLS_SHLIB= yes
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${REINPLACE_CMD} -e "s|-lqt|-lqt-mt|" ${WRKSRC}/configure
|
||||||
|
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||||
|
-e "s|malloc\.h|stdlib.h|"
|
||||||
|
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
|
||||||
|
-e "s|-ldl||" -e "s|-lpthread|${PTHREAD_LIBS}|"
|
||||||
|
|
||||||
|
post-configure:
|
||||||
|
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} \
|
||||||
|
-e "s|-D_GETOPT_H||"
|
||||||
|
|
||||||
|
pre-build:
|
||||||
|
@(cd ${WRKSRC} && ${GMAKE} clean)
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
graphics/tulip/distinfo
Normal file
1
graphics/tulip/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (tulip-1.2.2.tar.gz) = e8273b535aeb4434d8f8c71aa56c06fb
|
7
graphics/tulip/files/patch-CompleteGraph.cpp
Normal file
7
graphics/tulip/files/patch-CompleteGraph.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/CompleteGraph.cpp.orig Fri Jan 10 13:01:54 2003
|
||||||
|
+++ plugins/import/CompleteGraph.cpp Fri Jan 10 13:02:03 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
12
graphics/tulip/files/patch-FileSystem.cpp
Normal file
12
graphics/tulip/files/patch-FileSystem.cpp
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
--- plugins/import/FileSystem.cpp.orig Fri Jan 10 12:54:43 2003
|
||||||
|
+++ plugins/import/FileSystem.cpp Fri Jan 10 12:56:18 2003
|
||||||
|
@@ -1,8 +1,8 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qfiledialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
||||||
|
#include <sys/stat.h>
|
||||||
|
-#include <sys/types.h>
|
||||||
|
#include <dirent.h>
|
||||||
|
|
||||||
|
struct FileSystem:public ImportModule
|
7
graphics/tulip/files/patch-RandomGraph.cpp
Normal file
7
graphics/tulip/files/patch-RandomGraph.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/RandomGraph.cpp.orig Fri Jan 10 12:57:54 2003
|
||||||
|
+++ plugins/import/RandomGraph.cpp Fri Jan 10 12:58:04 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
7
graphics/tulip/files/patch-RandomSimpleGraph.cpp
Normal file
7
graphics/tulip/files/patch-RandomSimpleGraph.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/RandomSimpleGraph.cpp.orig Fri Jan 10 12:59:47 2003
|
||||||
|
+++ plugins/import/RandomSimpleGraph.cpp Fri Jan 10 12:59:59 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
7
graphics/tulip/files/patch-RandomTree.cpp
Normal file
7
graphics/tulip/files/patch-RandomTree.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/RandomTree.cpp.orig Fri Jan 10 13:04:39 2003
|
||||||
|
+++ plugins/import/RandomTree.cpp Fri Jan 10 13:04:46 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
7
graphics/tulip/files/patch-RandomTreeGeneral.cpp
Normal file
7
graphics/tulip/files/patch-RandomTreeGeneral.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/RandomTreeGeneral.cpp.orig Fri Jan 10 13:05:27 2003
|
||||||
|
+++ plugins/import/RandomTreeGeneral.cpp Fri Jan 10 13:05:35 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include <qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
7
graphics/tulip/files/patch-SmallWorldGraph.cpp
Normal file
7
graphics/tulip/files/patch-SmallWorldGraph.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/SmallWorldGraph.cpp.orig Fri Jan 10 13:06:05 2003
|
||||||
|
+++ plugins/import/SmallWorldGraph.cpp Fri Jan 10 13:06:13 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
11
graphics/tulip/files/patch-TemplateFactory.cxx
Normal file
11
graphics/tulip/files/patch-TemplateFactory.cxx
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- library/include/cxx/TemplateFactory.cxx.orig Fri Jan 10 12:29:37 2003
|
||||||
|
+++ library/include/cxx/TemplateFactory.cxx Fri Jan 10 12:30:17 2003
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
else
|
||||||
|
{
|
||||||
|
createObj =(func) dlsym(handle, "_creator");
|
||||||
|
- if ((error=dlerror())!=0)
|
||||||
|
+ if ((error=(char*)dlerror())!=0)
|
||||||
|
{
|
||||||
|
dlclose(handle);
|
||||||
|
if (loader!=0) loader->aborted(std::string(namelist[n]->d_name),std::string(error));
|
7
graphics/tulip/files/patch-completeBinaryTree.cpp
Normal file
7
graphics/tulip/files/patch-completeBinaryTree.cpp
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
--- plugins/import/completeBinaryTree.cpp.orig Fri Jan 10 13:06:51 2003
|
||||||
|
+++ plugins/import/completeBinaryTree.cpp Fri Jan 10 13:07:31 2003
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include<qinputdialog.h>
|
||||||
|
#include "TulipPlugin.h"
|
12
graphics/tulip/files/patch-config.h.in
Normal file
12
graphics/tulip/files/patch-config.h.in
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
--- config.h.in.orig Sat Jan 11 01:10:36 2003
|
||||||
|
+++ config.h.in Sat Jan 11 01:10:42 2003
|
||||||
|
@@ -34,9 +34,6 @@
|
||||||
|
/* Define to 1 if you have the <stdint.h> header file. */
|
||||||
|
#undef HAVE_STDINT_H
|
||||||
|
|
||||||
|
-/* Define to 1 if you have the <stdlib.h> header file. */
|
||||||
|
-#undef HAVE_STDLIB_H
|
||||||
|
-
|
||||||
|
/* Define to 1 if you have the <strings.h> header file. */
|
||||||
|
#undef HAVE_STRINGS_H
|
||||||
|
|
1
graphics/tulip/pkg-comment
Normal file
1
graphics/tulip/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
A system dedicated to the visualization of huge graphs
|
14
graphics/tulip/pkg-descr
Normal file
14
graphics/tulip/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
Tulip software is a system dedicated to the visualization of huge graphs. It
|
||||||
|
manages graphs with a number of elements(node and edges) up to 500.000 on a
|
||||||
|
personal computer(PIII 600, with 256mo). Its SuperGraph technology architecture
|
||||||
|
enables to do the following things :
|
||||||
|
* 3D visualizations
|
||||||
|
* 3D modifications
|
||||||
|
* Plug-in support for easy evolution
|
||||||
|
* Building of clusters and navigation into it
|
||||||
|
* Automatic drawing of graphs
|
||||||
|
* Automatic clustering of graphs
|
||||||
|
* Automatic selection of elements
|
||||||
|
* Automatic Metric coloration of graphs
|
||||||
|
|
||||||
|
WWW: http://www.tulip-software.org/
|
111
graphics/tulip/pkg-plist
Normal file
111
graphics/tulip/pkg-plist
Normal file
|
@ -0,0 +1,111 @@
|
||||||
|
bin/Tulip
|
||||||
|
bin/tlprender
|
||||||
|
lib/libtlp.a
|
||||||
|
lib/libtlp.la
|
||||||
|
lib/libtlp.so
|
||||||
|
lib/libtlp.so.0
|
||||||
|
lib/tlp/bitmaps/Fonts.bmp
|
||||||
|
lib/tlp/bitmaps/but1.xpm
|
||||||
|
lib/tlp/bitmaps/but2.xpm
|
||||||
|
lib/tlp/bitmaps/but3.xpm
|
||||||
|
lib/tlp/bitmaps/logo32x32.bmp
|
||||||
|
lib/tlp/plugins/clustering/arity.so
|
||||||
|
lib/tlp/plugins/clustering/aritysegment.so
|
||||||
|
lib/tlp/plugins/clustering/convol.so
|
||||||
|
lib/tlp/plugins/clustering/equalvalues.so
|
||||||
|
lib/tlp/plugins/clustering/geometric.so
|
||||||
|
lib/tlp/plugins/clustering/hierarchical.so
|
||||||
|
lib/tlp/plugins/clustering/quotientclustering.so
|
||||||
|
lib/tlp/plugins/clustering/segment.so
|
||||||
|
lib/tlp/plugins/clustering/sizen.so
|
||||||
|
lib/tlp/plugins/colors/histogrammapping.so
|
||||||
|
lib/tlp/plugins/colors/linearmapping.so
|
||||||
|
lib/tlp/plugins/export/generic.so
|
||||||
|
lib/tlp/plugins/export/gml.so
|
||||||
|
lib/tlp/plugins/export/tlp.so
|
||||||
|
lib/tlp/plugins/glyph/cone.so
|
||||||
|
lib/tlp/plugins/glyph/cube.so
|
||||||
|
lib/tlp/plugins/glyph/cubeoutlined.so
|
||||||
|
lib/tlp/plugins/glyph/cylinder.so
|
||||||
|
lib/tlp/plugins/glyph/sphere.so
|
||||||
|
lib/tlp/plugins/import/adjacencymatrix.so
|
||||||
|
lib/tlp/plugins/import/completebinary.so
|
||||||
|
lib/tlp/plugins/import/completegraph.so
|
||||||
|
lib/tlp/plugins/import/filesystem.so
|
||||||
|
lib/tlp/plugins/import/gml.so
|
||||||
|
lib/tlp/plugins/import/poset.so
|
||||||
|
lib/tlp/plugins/import/randomgraph.so
|
||||||
|
lib/tlp/plugins/import/randomsimplegraph.so
|
||||||
|
lib/tlp/plugins/import/randomtree.so
|
||||||
|
lib/tlp/plugins/import/randomtreegeneral.so
|
||||||
|
lib/tlp/plugins/import/smallworld.so
|
||||||
|
lib/tlp/plugins/import/tlp.so
|
||||||
|
lib/tlp/plugins/layout/circular.so
|
||||||
|
lib/tlp/plugins/layout/conetree.so
|
||||||
|
lib/tlp/plugins/layout/gem.so
|
||||||
|
lib/tlp/plugins/layout/generalgraph.so
|
||||||
|
lib/tlp/plugins/layout/generalgraph3d.so
|
||||||
|
lib/tlp/plugins/layout/generalgraphbox.so
|
||||||
|
lib/tlp/plugins/layout/random.so
|
||||||
|
lib/tlp/plugins/layout/springelectrical.so
|
||||||
|
lib/tlp/plugins/layout/sugiyama.so
|
||||||
|
lib/tlp/plugins/layout/tree3d.so
|
||||||
|
lib/tlp/plugins/layout/treeleaf.so
|
||||||
|
lib/tlp/plugins/layout/treemap.so
|
||||||
|
lib/tlp/plugins/layout/treeradial.so
|
||||||
|
lib/tlp/plugins/layout/treewalker.so
|
||||||
|
lib/tlp/plugins/layout/treewalkerbox.so
|
||||||
|
lib/tlp/plugins/layout/tutte.so
|
||||||
|
lib/tlp/plugins/metric/arity.so
|
||||||
|
lib/tlp/plugins/metric/barycenter.so
|
||||||
|
lib/tlp/plugins/metric/cluster.so
|
||||||
|
lib/tlp/plugins/metric/connectedandtreecomponnents.so
|
||||||
|
lib/tlp/plugins/metric/connectedcomponnents.so
|
||||||
|
lib/tlp/plugins/metric/daglevel.so
|
||||||
|
lib/tlp/plugins/metric/id.so
|
||||||
|
lib/tlp/plugins/metric/leaf.so
|
||||||
|
lib/tlp/plugins/metric/node.so
|
||||||
|
lib/tlp/plugins/metric/pathlength.so
|
||||||
|
lib/tlp/plugins/metric/pathsum.so
|
||||||
|
lib/tlp/plugins/metric/random.so
|
||||||
|
lib/tlp/plugins/metric/segment.so
|
||||||
|
lib/tlp/plugins/metric/spreadingactivation.so
|
||||||
|
lib/tlp/plugins/metric/spreadinginterpolation.so
|
||||||
|
lib/tlp/plugins/metric/strahler.so
|
||||||
|
lib/tlp/plugins/metric/strahlerall.so
|
||||||
|
lib/tlp/plugins/metric/strongcomponnet.so
|
||||||
|
lib/tlp/plugins/metric/treearitymax.so
|
||||||
|
lib/tlp/plugins/metric/viennot.so
|
||||||
|
lib/tlp/plugins/selection/inducedsubgraph.so
|
||||||
|
lib/tlp/plugins/selection/reachable.so
|
||||||
|
lib/tlp/plugins/selection/spanningdag.so
|
||||||
|
lib/tlp/plugins/selection/spanningtree.so
|
||||||
|
lib/tlp/plugins/sizes/AutoSize.so
|
||||||
|
lib/tlp/plugins/sizes/fittolabels.so
|
||||||
|
lib/tlp/samples/gml/GeneralPlanarGraph.gml
|
||||||
|
lib/tlp/samples/gml/dag50nodes.gml
|
||||||
|
lib/tlp/samples/gml/pussar.gml
|
||||||
|
lib/tlp/samples/matrix/ex1.mat
|
||||||
|
lib/tlp/samples/posets/posTest.pst
|
||||||
|
lib/tlp/samples/tlp/CrossReduc.Demo.tlp
|
||||||
|
lib/tlp/samples/tlp/MetaGraph.tlp
|
||||||
|
lib/tlp/samples/tlp/SimpleCurve.Demo.tlp
|
||||||
|
lib/tlp/samples/tlp/Tree_11259_Nodes.demo.tlp
|
||||||
|
lib/tlp/samples/tlp/Web.labri.Demo.tlp
|
||||||
|
lib/tlp/samples/tlp/graphSimple.144.245.tlp
|
||||||
|
@dirrm lib/tlp/samples/tlp
|
||||||
|
@dirrm lib/tlp/samples/posets
|
||||||
|
@dirrm lib/tlp/samples/matrix
|
||||||
|
@dirrm lib/tlp/samples/gml
|
||||||
|
@dirrm lib/tlp/samples
|
||||||
|
@dirrm lib/tlp/plugins/sizes
|
||||||
|
@dirrm lib/tlp/plugins/selection
|
||||||
|
@dirrm lib/tlp/plugins/metric
|
||||||
|
@dirrm lib/tlp/plugins/layout
|
||||||
|
@dirrm lib/tlp/plugins/import
|
||||||
|
@dirrm lib/tlp/plugins/glyph
|
||||||
|
@dirrm lib/tlp/plugins/export
|
||||||
|
@dirrm lib/tlp/plugins/colors
|
||||||
|
@dirrm lib/tlp/plugins/clustering
|
||||||
|
@dirrm lib/tlp/plugins
|
||||||
|
@dirrm lib/tlp/bitmaps
|
Loading…
Reference in a new issue