- Update to 1.4.24
- Disable mozilla and xulrunner options, they do not work. Interested parties are encouraged to submit patches
This commit is contained in:
parent
6f2bb26c30
commit
db3777d96d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=227445
5 changed files with 19 additions and 97 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= liferea
|
||||
PORTVERSION= 1.4.23
|
||||
PORTVERSION= 1.4.24
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= liferea
|
||||
|
@ -31,9 +31,9 @@ OPTIONS= LIBNOTIFY "Enable libnotify support" on \
|
|||
DBUS "Enable dbus support" on \
|
||||
GNUTLS "Enable SSL/HTTPS support" on \
|
||||
GTKHTML "Use GtkHtml for rendering" on \
|
||||
WEBKIT "Use Webkit for rendering" off \
|
||||
MOZILLA "Use Firefox for rendering" off \
|
||||
XULRUNNER "Use Xulrunner for rendering" off
|
||||
WEBKIT "Use Webkit for rendering" off
|
||||
# MOZILLA "Use Firefox for rendering" off \
|
||||
# XULRUNNER "Use Xulrunner for rendering" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -70,23 +70,29 @@ PLIST_SUB+= WEBKIT="@comment "
|
|||
.endif
|
||||
|
||||
.ifdef WITH_MOZILLA
|
||||
USE_GNOME+= gconf2 libxslt
|
||||
USE_GECKO= firefox mozilla
|
||||
CONFIGURE_ARGS+=--enable-gecko=${GECKO}
|
||||
CONFIGURE_ARGS+=--with-gecko=${GECKO}
|
||||
PLIST_SUB+= MOZ=""
|
||||
BROKEN= does not compile
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-gecko
|
||||
PLIST_SUB+= MOZ="@comment "
|
||||
.endif
|
||||
|
||||
.ifdef WITH_XULRUNNER
|
||||
CONFIGURE_ARGS+=--with-gecko=xulrunner
|
||||
BUILD_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
|
||||
RUN_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
|
||||
PLIST_SUB+= XUL=""
|
||||
BROKEN= does not configure
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-xulrunner
|
||||
PLIST_SUB+= XUL="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_MOZILLA) && !defined(WITH_XULRUNNER)
|
||||
CONFIGURE_ARGS+=--disable-gecko
|
||||
.endif
|
||||
|
||||
.ifdef WITHOUT_DBUS
|
||||
CONFIGURE_ARGS+=--disable-dbus
|
||||
.else
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (liferea-1.4.23.tar.gz) = 7772f04bd3ed995b7ce36e52d26ec088
|
||||
SHA256 (liferea-1.4.23.tar.gz) = d30dd398185d7ce14d9d28fcc190a074221b0c18c35f7ad9ccd56d0523d332b1
|
||||
SIZE (liferea-1.4.23.tar.gz) = 1655446
|
||||
MD5 (liferea-1.4.24.tar.gz) = e488b402265ab2417db94f0324674941
|
||||
SHA256 (liferea-1.4.24.tar.gz) = bddb38e2ce8845f2a50f8443b454f2b585dd9a17cde49dee914577aabf9a9f28
|
||||
SIZE (liferea-1.4.24.tar.gz) = 1670117
|
||||
|
|
|
@ -1,86 +0,0 @@
|
|||
--- configure.orig 2008-12-03 10:08:14.000000000 +0100
|
||||
+++ configure 2008-12-03 10:09:20.000000000 +0100
|
||||
@@ -28920,83 +28920,6 @@
|
||||
Usually this means the macro was only invoked conditionally." >&2;}
|
||||
{ (exit 1); exit 1; }; }
|
||||
fi
|
||||
-if test -z "${HAVE_MOZILLA_TOOLKIT_TRUE}" && test -z "${HAVE_MOZILLA_TOOLKIT_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_MOZILLA_TOOLKIT\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_MOZILLA_TOOLKIT\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_DEBUG_TRUE}" && test -z "${HAVE_GECKO_DEBUG_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_1_7_TRUE}" && test -z "${HAVE_GECKO_1_7_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_7\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_1_7\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_1_8_TRUE}" && test -z "${HAVE_GECKO_1_8_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_8\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_1_8\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_1_8_1_TRUE}" && test -z "${HAVE_GECKO_1_8_1_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_8_1\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_1_8_1\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_1_9_TRUE}" && test -z "${HAVE_GECKO_1_9_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_1_9\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_1_9\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_HOME_TRUE}" && test -z "${HAVE_GECKO_HOME_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_HOME\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_HOME\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_DEBUG_TRUE}" && test -z "${HAVE_GECKO_DEBUG_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_DEBUG\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${HAVE_GECKO_XPCOM_GLUE_TRUE}" && test -z "${HAVE_GECKO_XPCOM_GLUE_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"HAVE_GECKO_XPCOM_GLUE\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"HAVE_GECKO_XPCOM_GLUE\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${WITH_XULRUNNER_TRUE}" && test -z "${WITH_XULRUNNER_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"WITH_XULRUNNER\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"WITH_XULRUNNER\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
-if test -z "${WITH_MOZILLA_TRUE}" && test -z "${WITH_MOZILLA_FALSE}"; then
|
||||
- { { echo "$as_me:$LINENO: error: conditional \"WITH_MOZILLA\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&5
|
||||
-echo "$as_me: error: conditional \"WITH_MOZILLA\" was never defined.
|
||||
-Usually this means the macro was only invoked conditionally." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-fi
|
||||
if test -z "${WITH_WEBKIT_TRUE}" && test -z "${WITH_WEBKIT_FALSE}"; then
|
||||
{ { echo "$as_me:$LINENO: error: conditional \"WITH_WEBKIT\" was never defined.
|
||||
Usually this means the macro was only invoked conditionally." >&5
|
|
@ -5,7 +5,7 @@
|
|||
@WITH_GTKHTML2_TRUE@GTKHTML2 = gtkhtml2
|
||||
@WITH_WEBKIT_TRUE@WEBKIT = webkit
|
||||
-SUBDIRS = net parsers notification ui fl_sources scripting . $(GTKHTML2) $(WEBKIT) mozilla
|
||||
+@WITH_GECKO_TRUE@MOZILLA = mozilla
|
||||
+@WITH_MOZILLA_TRUE@MOZILLA = mozilla
|
||||
+SUBDIRS = net parsers notification ui fl_sources scripting . $(GTKHTML2) $(WEBKIT) $(MOZILLA)
|
||||
AM_CPPFLAGS = \
|
||||
-DPACKAGE_DATA_DIR=\""$(datadir)"\" \
|
||||
|
|
|
@ -135,6 +135,7 @@ share/locale/be@latin/LC_MESSAGES/liferea.mo
|
|||
share/locale/ca/LC_MESSAGES/liferea.mo
|
||||
share/locale/cs/LC_MESSAGES/liferea.mo
|
||||
share/locale/de/LC_MESSAGES/liferea.mo
|
||||
share/locale/el/LC_MESSAGES/liferea.mo
|
||||
share/locale/es/LC_MESSAGES/liferea.mo
|
||||
share/locale/eu/LC_MESSAGES/liferea.mo
|
||||
share/locale/fr/LC_MESSAGES/liferea.mo
|
||||
|
@ -146,6 +147,7 @@ share/locale/pt/LC_MESSAGES/liferea.mo
|
|||
share/locale/pt_BR/LC_MESSAGES/liferea.mo
|
||||
share/locale/ru/LC_MESSAGES/liferea.mo
|
||||
share/locale/sk/LC_MESSAGES/liferea.mo
|
||||
share/locale/sq/LC_MESSAGES/liferea.mo
|
||||
share/locale/sv/LC_MESSAGES/liferea.mo
|
||||
share/locale/tr/LC_MESSAGES/liferea.mo
|
||||
@dirrm share/liferea/xslt
|
||||
|
|
Loading…
Reference in a new issue